-   Mageia (
-   -   Boot mageia 3 from usb (

cuzzo 07-03-2013 05:19 AM

Boot mageia 3 from usb

Keep in mind i do want mageia 3 as a end result, xp is just a quick test medium. My bios finds my sd chip as lg android and i can set it to boot from it. but even if i set it and whether or not i press f12 and choose android it wont boot. Ive tried linux live usb creator, rufus, wintobootic, universal usb installer, hp usb creator and a a couple other ones ive tried win8 win xp ubuntu and mageia 3 from the various usb creators mentioned all following the corresponding forum posts. Nothing changes I even updated my bios from v1.20 to v1.30 figuring that would fix the problem but no change occurred. i confirmed that i could install the os's i mentioned from dvd+r, but the very same os's (same exact iso's) wont boot from usb. I talked to a toshiba tech and she said i needed to erase win 7 win 8 win xp and ubuntu and install xp first then the other os's. didnt sound like a good solution but i figured what the hey, it my laptops manufacture tech im talking to. so far i installed xp and set up the usb to boot the xp setup with rufus usb creator and i set the lg android option in the bios. (Im using xp cause its the smallest iso i have, that way it wouldnt take a long time) then i pressed f12 for good measure and chose lg android from the top of the list as it was already set to boot first. it will not boot, xp's boot loader appears. Funny thing is Toshiba wants me to pay them $150 a year for help on getting this running, or for me to buy a recovery disk. i wont have money for awhile. how can i get it (Toshiba Satellite l455d-s5976) to boot from usb. If i can get this working ill put mageia 3 on my pc as the main os.

widget 07-03-2013 06:22 AM

Have you checked your bios to make sure that booting from a usb device is enabled?

The android option is a new one to me but doesn't sound like a good one for booting Linux in general.

You should get an option, in the boot menu, boot from a usb device I woudl think. On this box (Dell - specs in sig) I just installed Mageia 3 from a disk running in an external DVD RW to an external drive, both of which are usb. I had an option to boot to a usb CDrom or usb Hdd when hitting F12 (Dell uses that same key which I find interesting).

In my bios booting from a usb device has to be enabled. I don't know how you get to bios on your box. Dell uses F2 for that.

This is Linux we are talking about and if you can boot a live CD/DVD why not use that to install? If you simply want to use the usb stick I would use a live session from a disk and use the dd command to write the ISO to a stick. Have done this with Mageia 3 and it booted fine. Would have installed from it but have something else on my only stick right now.

The dd command is pretty simple to use.

Stick should be formatted to some fat format. "if" is input file. "of" is output file.

dd if=<file> of=<device> bs=4M; sync
Put the appropriate path in place of <file> and <device> and hit enter. Will take a short while but works very well. Only thing most people have trouble with is the "of" part. It really is the entire device you want not a partition on the device. If stick is seen as sdc the path would be "/dev/sdc". When finished the imabe will be on /dev/sdc1".

It will boot if your bios are set to boot from a usb device.

GlennsPref 07-13-2013 05:53 AM

Hi, I haven't used any of the proprietory devices like Dell, but...

Contrary to wigets' advice(I haven't tried that),[Block size]It seems to work without it. I use ...

to write an iso to disk, do

dd if=<absolute path name>.iso of=/dev/<device name in fstab> <edit>It may not be there, but in /etc/mtab. get it using cat</edit>
sudo dd if=/home/glenn/Downloads/kubuntu-13.04-desktop-amd64.iso of=/dev/sdd

Dump Mageia ISOs on an USB stick?

All the Mageia ISOs are hybrid, which means you can burn them to an optical DVD/CD disc or just dump them on a USB stick and use it
to boot and install the system.

Mandriva-seed is another app to do the same...(it's not much better than what you have tried.)

I hope this helps you, Regards Glenn

All times are GMT -5. The time now is 08:06 AM.