LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   LQ Suggestions & Feedback (https://www.linuxquestions.org/questions/lq-suggestions-and-feedback-7/)
-   -   Rating A Thread. (https://www.linuxquestions.org/questions/lq-suggestions-and-feedback-7/rating-a-thread-4175652855/)

cwizardone 04-27-2019 11:21 AM

Rating A Thread.
 
I tried to rate a thread this morning and received the following error,

Quote:

A required field called <em>ipaddress</em> is missing or has an invalid value.
I was able to repeat this with Firefox, Pale Moon, SeaMonkey and Vivaldi, i.e., all returned returned the same error when I tried to rate a thread.

individual 04-27-2019 11:27 AM

Quote:

Originally Posted by cwizardone (Post 5988945)
I tried to rate a thread this morning and received the following error,



I was able to repeat this with Firefox, Pale Moon, SeaMonkey and Vivaldi, i.e., all returned returned the same error when I tried to rate a thread.

I get the same error on Firefox.

cwizardone 04-27-2019 11:57 AM

OK, I booted over to windows 7 and was able to duplicate the problem with Vivaldi and SeaMonkey.

rokytnji 04-27-2019 01:24 PM

Firefox

Code:

harry@biker:~
$ apt-cache policy firefox-esr
firefox-esr:
  Installed: 60.6.1esr-1~deb9u1
  Candidate: 60.6.1esr-1~deb9u1
  Version table:
 *** 60.6.1esr-1~deb9u1 500
        500 http://security.debian.org stretch/updates/main amd64 Packages
        100 /var/lib/dpkg/status
    60.5.0esr-1~deb9u1 500
        500 http://ftp.us.debian.org/debian stretch/main amd64 Packages
harry@biker:~

http://postmyimage.com/img2/450_screenshot.jpg

No problem here. Maybe a addon? Scratch that. I see you mentioned other browsers.

Edit: I rated the thread as average.

jsbjsb001 04-27-2019 01:57 PM

No problem for me either, I also rated this thread as "average". I'm using Firefox 60.6.1esr (64-bit) myself.

I'm using CentOS 7.6 if it helps.

ondoho 04-28-2019 04:06 AM

I just got the same error as op.

seamonkey 2.49.4, google-analytics.com blocked.

jeremy 04-28-2019 11:13 AM

I'm note able to reproduce this, but am looking into it further. Note that blocking google-analytics will not have any negative impact on browsing or using the site.

--jeremy

individual 04-28-2019 01:54 PM

OK, I will admit I am no web developer, but I was able to submit my rating by adding "ipaddress=123" to the URL and resubmitting the request. After doing that and trying to vote again it displays this:
Code:

LinuxQuestions.org Message
According to our records you have already voted on this thread. Changing votes is not allowed.

Something is preventing my browser (and apparently the OP's) from including this query in the URL.

EDIT: Here is what the URL looked like after modifying.
Code:

https://www.linuxquestions.org/questions/threadrate.php?t=4175652855&ipaddress=123
EDIT2:
Steps for others to try:
Open up Firefox Developer Tools on this page.
Click on the "Network" tab and refresh the page.
Click on the button to rate the thread. You should see a POST request made to https://www.linuxquestions.org/quest...p?t=4175652855.
Select that line and then click "Edit and Resend."
Under "Query String:" and below t=4175652855, add "ipaddress=123" and click Send.
Refresh your page and try to vote again, and you should see the message I posted above.

EDIT3: Sorry for the messy initial posts. Being in a hurry leads to incoherent writing.

ChuangTzu 04-28-2019 02:31 PM

I was able to rate it just now. No problems with Firefox ESR along with Ublock origin, Privacy Badger, https everywhere.

MensaWater 04-29-2019 09:10 AM

I was able to rate this thread in my older Firefox v49.0.2 installation on MS Windows. (I don't update this one because I need older Java 7 to work for some internal systems.)

cwizardone 04-29-2019 11:37 AM

It occurred to me the problem might be with the hosts file, so i tried an older one and eventually tried the "original" hosts file that came with the distribution. It didn't make a bit of difference. The problem remains.

Hmmmmm.... you know I did install the latest version of Java the other day... 8u211.

Just reverted to 8u201, but it didn't help. Problem remains.

ChuangTzu 04-29-2019 06:39 PM

Quote:

Originally Posted by cwizardone (Post 5989478)
It occurred to me the problem might be with the hosts file, so i tried an older one and eventually tried the "original" hosts file that came with the distribution. It didn't make a bit of difference. The problem remains.

Hmmmmm.... you know I did install the latest version of Java the other day... 8u211.

Just reverted to 8u201, but it didn't help. Problem remains.

Are you using Tor? Grasping at straws now. :scratch:

greencedar 04-29-2019 06:53 PM

I was able to vote on this thread; I voted "average" and the notice came up afterward that said the vote was counted.

My Firefox version is:

Quote:

66.0.3+build1-0ubuntu0.18.04.1

cwizardone 04-29-2019 07:25 PM

Quote:

Originally Posted by ChuangTzu (Post 5989609)
Are you using Tor? Grasping at straws now. :scratch:

No, but thanks for taking the time to reply.

:)

cwizardone 04-29-2019 08:23 PM

At the moment I'm in windows Xp, running in VirtualBox, using Opera-12.16, and was able to rate a thread.
Why it works in Xp, I don't know.


All times are GMT -5. The time now is 06:48 AM.