- Member Success Stories (
-   -   PostgreSQL horror finally over (

TexasDex 04-24-2003 06:08 PM

PostgreSQL horror finally over
Well I'd been working on trying to get an SQL database server running on my RedHat 8.0 machine. I started off knowing absolutely nothing about SQL except that it wasa database and it was needed for dynamic web pages, which I wanted. I installed it from the distro CD and made sure it would start up properly on boot. Then I tried to get into it. First of all the program wasn't started. Then I used the redhat services program to start it and tried the pgsql command. Invalid User. Damn. I tried to add an SQL user while logged in as root but it still wouldn't let me (still Invalid User). I then attempted to start it on my own because I knew that postgres makes a user based on the user who started it. But I couldn't start postmaster because it kept either saying:
1. Can't start pgsql as root
When I tried as my normal username:
2. Invalid database directory
3. Need RW permission for database directory, or
4. Database directory has world access
I checked several times to make sure that postgres was the owner of the right dir and the path passed to the postmaster command was correct but either it complained that it couldn't read or write to the directory or that too many people could. I tried to "su postgresql" but the user postgresql didn't exist. I also tried using the user options for the pgsql command, trying to log on to postgres as the right user, but I didn't know the password and I couldn't find it out from the RedHat user manager, even though the user postgres existed. I had just about given up when I realized that the name of the user wasn't postgresql, it was postgres. I used the su postgres command, made more users for my normal accounts, and Postgres is running just fine. Now if I only knew what to do with it...

Tinkster 04-27-2003 02:46 PM

No offense meant, but how is this a success story? :)

Postgres documentation is quite clear on all the steps
to take, creation of the user postgres, permissions on
related folders ...


All times are GMT -5. The time now is 07:28 AM.