- Member Success Stories (
-   -   Oracle runInstaller won't load on RHEL6 with Exceed (

MensaWater 11-29-2012 02:19 PM

Oracle runInstaller won't load on RHEL6 with Exceed
Posting this in the hopes it will help someone else:

We had recently installed two RHEL 6.3 systems with Oracle GRID. On doing so we had used a Windows 7 machine running Cygwin/X for displaying X windows back to the desktop and PuTTY with ssh tunneling enabled for initial login. We had no problems using the Oracle runInstaller GUI on that desktop.

After completion of this the DBA went to his own desk which is running Windows XP with Hummingbird Exceed 7.0. He is using SecureCRT rather than PuTTY to open initial session to the RHEL6.3 system. When he attempted to launch runInstaller for Oracle DB it gave 3 messages as if it was going to load but then returned to command prompt without error but the GUI didn't come up. We had verified xterm from the RHEL6.3 system DID come up so we knew X back to his desktop was working.

On doing further tests we found that we could launch the very same runInstaller (which was on an NFS mount) from any RHEL5 system but could NOT on either of the RHEL6.3 systems we had just installed nor on an earlier RHEL6.1 system we tested. The issue therefore appeared to be a combination of the user's desktop (likely Exceed) and RHEL6.

We attempted to launch the initial session on the Windows XP box using PuTTY instead of SecureCRT but this didn't make a difference so it wasn't the SecureCRT that was the problem.

We also realized that in fact the runInstaller was launching and staying active as a background java process on the RHEL6 machines. Running lsof -p against the pid of that process showed it was in fact connected back to the Windows XP desktop machine so it appears the issue was that Exceed couldn't display it properly when coming from RHEL6.

On searching for this I found various people had had the problem but the usual comment found was "RHEL 6 isn't supported for your version of Oracle". That may have been true for those versions but we had specifically verified the version we were running is now certified on RHEL6 before we did the GRID install. Finally I did find one post where the author saw exactly the same as we did and he noted that running xming or mobaxterm it worked properly which confirmed our suspicion the issue was Exceed itself. (Especially since it had worked on Cygwin/X on the other machine.)

Since Exceed 14 is the latest version and we were running Exceed 7 I decided to get the later version (we are running licensed copies so I had to get authorization for the non-demo download from vendor Open Text who had bought Hummingbird some time ago.) On installing that on both the Windows 7 box and the Windows XP box it successfully displayed the runInstaller on launch from the RHEL6.3 servers.

All times are GMT -5. The time now is 12:03 AM.