- Member Success Stories (
-   -   openoffice force default theme / no theme | dark theme fix (

H_TeXMeX_H 03-05-2010 11:21 AM

openoffice force default theme / no theme | dark theme fix
I've never posted in this particular forum before, but I think this is where this post goes.

So, recently I noticed that openoffice, including go-oo, will try to use your gtk theme no matter what, and it will often result in a crappy looking interface (especially with dark themes). The problem is documented here:

Using a dark theme erases colors and messes up backgrounds ... wonderful.

Although there is no way to force openoffice to use the default theme using the openoffice options, you can make a wrapper script like this:


GTK2_RC_FILES="" soffice "$1"
This resets the location of gtkrc-2.0 to nothing, and then runs soffice on whatever file you give it (opening the file). This forces openoffice to not know where your theme is, and thus uses the ugly default theme, tho the result is not quite as ugly as it trying to use a dark theme.

I don't know of any way to make it use a dark theme properly in all parts of openoffice. If you know, do post it.

Note that this also works for firefox, but firefox has no problems with dark themes, luckily.

Willrandship 03-08-2010 12:56 PM

Glad to see you fixed it!

I'm going to post to remove this from the "No replies" thread.

All times are GMT -5. The time now is 10:50 AM.