- Member Success Stories (
-   -   installing Nvidia drivers from .tar.gz (

MitchM99 03-27-2003 10:23 AM

installing Nvidia drivers from .tar.gz
My reasoning to writing this is to fill in the blanks that may be in question for those source installers. Fingel's guide is an awesome .rpm installation guide for your rpm install needs.

NOW, to the fun part.

this is intended for the non .rpm using distro's ect. mainly slackware

NOTE=(this is the way I do it and I have yet to have a problem)
(the commands are located in "" brackets, thats what you will type)
(when I refer to /home/user I am referring to your user directory. mine is mitch so I would go to /home/mitch/)
(the txt editor I use is pine's pico , if you use vi do so respectivly)

first go to the nvidia website and grab the newest drivers
This is for the TNT2 - GeForce 4 (maybe GeForce FX) get the IA32

Download the kernel and GLX drivers

for those with the IA64 people (you know who you are)
or the AMD64 get their respective drivers from

ok so now that you have them downloaded let say in your /home/user/ dir (assuming this) first this we need to do is set your inittab to runlevel 3 or the equivilant of multiuser mode. this setting is located at /etc/inittab/
make it look like
to edit it open a console and su to root. then type "pico /etc/inittab" go down and edit that initdefult.

now we need to check to see if you have your kernel source installed. if not no biggie, to check open up a console and type "cd /usr/src/linux"
if you get (cd: /usr/src/linux: No such file or directory) then try "cd /usr/src/linux-2.*) and if you get the same No such file or directory then we will need to install it. you can do either of 2 things, one you can go to the and download YOUR kernel only not a new one unless you want to upgrade, but we will do that in my next HOWTO ;)
The other option is to get it off your install cd. on my slackware cd it's located in /mnt/cdrom/slackware/k/kernel-source-2.4.18-noarch-4.tgz
install the package (assuming you know how) then it will place it in your /usr/src/linux-2.4.18 dir. now we need to creat a link to help our install along :)
open a console and su to root. now type "ln /usr/src/linux-2.4.18 /usr/src/linux"
this is assuming you are using kernel 2.4.18 if not change the command to reflect YOUR kernel. PHEW any problems with that step lmk.

now restart
when you get to the login screen type
(enter password) then hit enter
then go to the directory where the drivers are located
"cd /home/user" (assuming this is wher you downloaded them to)
not sure if they are there type "ls" to see if they are there
now we will untar them.
"tar -xzvf NVIDIA_kernel-1.0-4191.tar.gz"
"tar -xzvf NVIDIA_GLX-1.0-4191.tar.gz"


now we will cd to their respective directory's. Nvidia says install the Kernel driver frist ok so we will.
"cd NVIDIA_kernel-1.0-4191"
now for the installation
"make install"
it should finish without error (if you get one report it to the forums :)
now we will cd to the GLX driver dir
"cd /home/user/NVIDIA_GLX-1.0-4191"
now for the installation
"make install"
this should finish without errors also.

GREAT almost done ;)

now we need to edit out a few lines in your XF86Config file located in /etc/X11/

now that all the installing is done lets wrap this up with a quick
"pico /etc/X11/XF86Config"
scroll down to the (Section "Module") portion this is near the top
in that section go down to the GLX module part make sure it looks like this and no exceptions.
# This loads the GLX module
Load "glx"

ok now we are going down a little the portion called
# Graphics device section

the only part we are going to edit is the part where it says
Section "Device"
Driver "nvidia" #change it to "nvidia" instead of "nv"
so the end result should look like this

Section "Device"
Identifier "GeForce3 Ti500"
Driver "nvidia"
#VideoRam 64968
# Insert Clocks lines here if appropriate

ok lets recap we changed it to say load "glx" only and changed the driver strain to say "nvidia" instead of "nv"

great we are all but a startx away from being finished.
now type
you should see a white screen with the nvidia logo on it then it will go to your defult WM. if it worked kudos to you :)

now to go back to your inittab settings and change it back to 4 or 5 depends on your distro in slack it's 4.
in a console su to root
then type "pico /etc/inittab/"
change the runlevel to
now you are done. give your self a had as you are one step closer to becoming a guru :)

Thanks for reading

Fingel 03-28-2003 12:13 AM

Wow. good job mitch. Between our two installation guides we should recieve a LOT less Nvidia questions. I hope : \

MitchM99 03-28-2003 09:54 AM

that's my goal, thanks for the complament :) my next howto is a full proof audigy driver setup and howto get the cd player working and everything :) or maybe just a kernel recompilation . who knows what I may feel like doing as I have 2 more weeks till basic and I want to make good use of them as 7 weeks w/o linux will kill me LOL

well, lata


Fingel 03-28-2003 05:47 PM

Yeah! Do it on how to get the CD player to work. I mean, uhh, its not like I dont know how....:rolleyes: I dunno what I'll write about next. I'll come up with something. Probably enabling NTFS support. Oh yeah I added a link to your post in mine so that people wont get confused:) talk to ya later

umd 04-01-2003 05:05 PM

howdi ... just wanted to sy thanx for the howto ... gatta love it when a linux user dosent say to me 'man it' .. he .. anyways im ahving a prob linking my /usr/src/linux-2.4.20 /usr/src/linux using slack 9 btw .... i tried this be4 also and it gives this error ...

root@blu:/usr/src# ln /usr/src/linux-2.4.20 /usr/src/linux
ln: `/usr/src/linux-2.4.20': hard link not allowed for directory

i dont have a linux dir in /usr/src also dont know if i had to make one which i tried be4 also but that didnt work either by making one then linking it .... it would make a ln -s but that just maked a locked file of linux-2.4.20 in the linux dir ... so any help would be appreiciated ....

lhto 04-11-2003 02:28 AM

i got the error insmod nvidia failed
make: *** [package-install] Error 255

what must i do??

Apophis 06-09-2003 06:20 PM

This is what I get when I try running 'make install' for the nvidia kernel part:

bash-2.05b# make install

You appear to be compiling the NVIDIA kernel module with
a compiler different from the one that was used to compile
the running kernel. This may be perfectly fine, but there
are cases where this can lead to unexpected behaviour and
system crashes.

If you know what you are doing and want to override this
check, you can do so by setting IGNORE_CC_MISMATCH.

In any other case, set the CC environment variable to the
name of the compiler that was used to compile the kernel.

*** Failed cc sanity check. Bailing out! ***
make: *** [gcc-check] Error 1

Any ideas?

psykozovd 06-10-2003 05:15 PM

i have the same problem
Even though i suppose that the cause of this problem is that i am a complete newbie the problem still remains.
If you actually find out how to do it could you please let me know ?

dragonfly 06-12-2003 05:07 AM

I'm grateful that you open my urgent email.My trouble is: after I finished installing the Linux,it could boot well with Window Me.But one day,we I power up my computer,the boot just failed unwarningly.It just give me a black screen with GRUB configuration which I didn't know how to operate.Then every time I restarted the computer,it just gave me the same black screen with the same damn GRUB,my Linux and Window Me couldn't boot normally .I simply didn't know what had I done wrong.So I reinstalled Window XP Pro.Luckily It worked,but my Linux missing.I used to run PartitionMagic 8.0 to exam if my ext3 partition had corrupted,but it remained ok,which convinced me that there must be something wrong with the bootloader.It might be that after my installing the WinXP the WinXP's bootloader had overlapped the GRUB or LILO,so no matter I'm right or not ,Please show me the right way out.YOU ARE MY ONLY SAVIOR !!!!!THANX.


k0ljat 12-10-2003 02:36 PM

i did just as the topic told me to do, but when i have installed kernel, GLX, and the other things without an error, then when i go to edit the XF86Config, there just generic vesa and when i change it then the X wound start up... what am i duing wrong _

MitchM99 12-11-2003 07:48 AM

alright.. firstly please describe exactly what you did and what errors you get and what you did. did you have to install the kernel? where did it error on you.


p.s. this is an older help guide. The drivers are now installed with a script so that will take a installation process.

All times are GMT -5. The time now is 11:09 AM.