- Member Success Stories (
-   -   Getting Flash plug-in to work with older CPUs (

DavidMcCann 08-05-2012 11:36 AM

Getting Flash plug-in to work with older CPUs
Version 11 of the Flash plug-in for web browsers has been compiled to use the sse2 feature in the CPU. This was introduced in the Intel Pentium 4, but other chip manufacturers only used it in 64-bit CPUs. If you have a Pentium 3 or earlier, or a 32-bit chip from AMD or VIA, the plug-in will not work. If you have a 32-bit computer and Flash is not working, follow these instructions.

1. Check your CPU by entering this command in a terminal emulator:
cat /proc/cpuinfo
If the Flags line doesn’t contain ‘sse2’ (‘sse’ won’t do), then you need to use version 10 of the plug-in.

2. Check that you do have the wrong version. In Firefox, enter the url ‘about:plugins’, in Opera ‘opera:plugins’, or in Chrome ‘chrome://plugins’, and see if Shockwave Flash is version 11.

If (1) and (2) showed that you need to change the plug-in, there’s no need to uninstall and re-install: just changing the plug-in library file is sufficient.

3. First find where the file ‘’ is kept. The most likely places are /usr/lib/flash-plugin or /usr/lib/adobe-flashplugin. If it’s not there, look for a nearby folder with the name of you browser’s provider — e.g. for Firefox, that would be /usr/lib/mozilla — and that will contain a symbolic link to

4. Download the Flash package. Currently the address for the last issue of version 10 is
If it’s not there, check at

5. Open the file with your archive manager (or at the command-line if you prefer). Inside is a folder called and inside that is another archive flashplayer_10_3r183_20_linux.tar.gz and inside that is Extract it.

6. Now move it to the correct destination. The command will be
su -c "mv -f Downloads/ /usr/lib/flash-plugin"
sudo mv -f Downloads/ /usr/lib/flash-plugin
Obviously use the correct addresses if mine don’t apply.

That’s it: congratulations!

UlfZibis 11-11-2012 12:22 PM


I have found out, that on Pentium III Mobile 1 Ghz I can also use all versions < 11.2.
I currently use version, which works fine.

For additional info and discussion see here:

DavidMcCann 12-25-2012 10:55 AM


In Linux Mint, the plugin is kept in /opt/mint-flashplugin-11/

mcmorj 02-12-2013 06:07 PM

oops posted in wrong thread - deleting... well I would if I could figure out how to.

nitz 02-19-2014 10:55 AM

It works for me
Thanks man i have a AMD athlon XP 2400+ & this worked for mee :-)

Merel 04-13-2014 02:21 PM

Addendum to modify the information of post #1 may not be that simple
(Starting to understand why not everyone likes Linux)

Post#1 describes how to replace an existing version of the file by an older version. Version 10 of Adobe Flasplayer will work with older CPU's. However the latest version 10 is not the one mentioned in the article.
Actually the most latest version 10 to download from Adobe website.

you can download the file

This archive contains a lot of maps and folders for different operating systems.
While making your way through the unzipping process, you can remove all the non-linux related items. Keeping only the unzipped Linux stuff makes your work easier to reach the file which you need.

This file ( is the one we use as source to replace the file which does not work for your older system.

Regarding STEP 3, the existing locations found on my system were the following
Computer/usr/lib/flashplugin-installer/ (17,422,820 bytes)

FIREFOX actually uses the same file, in the samefolder. Please note that the file is accessed via LINKS, appearing at other locations made by Mozilla.

The existing file must be replaced by the older file with same name, which was unpacked.

To do this, finally copy the extracted file
to the DESTINATION folder /usr/lib/flashplugin-installer


This Terminal (copy) command overwrites the not-working existing file with the old working version. The COPY command keeps the source file for expected later use (instead of using the move command)


cp -f ~/Downloads/fp_10.3.183.90_archive/10_3_r183_90/flashplayer_10_3r183_90_linux/ /usr/lib/flashplugin-installer

This worked for my old PC with Celeron CPU. However Chromium was removed before executing the procedure, with Firefox only installed. I guess I should install again Chromium, to verify if some links are working now in this browser as well as in Firefox

nitz 04-15-2014 10:43 PM

Thanks for the info
Thanks for the detailed and patient :-) response
had figured this out after posting the query.....yup thts true that why every body does not like linux...
and thats part of the game ...anyway thanks again....

Footer 04-20-2014 07:52 PM

Awesome post. Thanks. I found via a google search. Trying to get an older machine (turned into a Mythbuntu box) to play Flash content, more specifically, iHeartRadio streaming and finally figured out this was the culprit.

Thanks again for this awesome post!


jps07 06-18-2014 02:19 PM

Thanks everyone I've done all this BUT... my is protected and nothing I try will move or replace it.
How do I get around this? Ideas welcome.
Do I need to deactivate or uninstall flashplayer and then try and install the older version?
Very grateful for any suggestions. (PS I'm a bit new to this)

Merel 06-18-2014 03:18 PM

To jps07
You might try to first delete the current file before to put the required "old" into place ? But did you use the "sudo" after the command prompt when trying to replace the file ?

Regarding 'rights' of a user to execute some commands, you must acquire rights of a "super-user".
Each command must be executed as "super user", meaning that the first word to type after the prompt (and before the command itself) must be sudo.

I'm a beginner myself and must struggle through each command's syntax.
The basic information about "super user" is very well explained HERE.

It is not necessary to un-install and re-installl Flash itself because you might install again a later version which will never work. The idea of this process : to use the old file !
All you need to do to make it work is replace that file with an old version.

If you don't succeed, please 'select' and 'copy' the contents of your attempts in Terminal and 'paste' it into next post.

jps07 06-24-2014 05:58 PM

Thanks Merel I will try this :-)

jps07 06-25-2014 05:10 PM

sh*t..clicked the wrong reply

Hi Merel,
I put
sudo cp -f ~/Downloads/fp_10.3.183.67_archive/10_3_r183_67/flashplayer_10_3r183_67_linux/ /usr/lib/flashplugin-installer
into the terminal window and it worked! Inasmuch as it's replaced the fp version 12 with the version 10.
However... fp still doesn't work in my firefox (after restart)
Anyone got any other ideas?
By the way thanks for the hint about sudo. I'm beginning to get the hang of this.

byteforge 01-07-2015 05:35 PM

I ran into the same problem in fall 2013. Can't part of my Athlon XP 2200+ either, because I'm no gaming geek, so why should I upgrade so soon?
However, it appears to me that Adobe DOES have a secret deal with hardware companies, which involves inhibiting the use of our t-birds and whatnot. They DO want us to upgrade, because this will (of course) boost the productivity with hardware companies.

As I did not want to create another "member success story" which might look like a mere derivative of this one, I've chosen to append it to this thread as it's the very same topic.

Warning: You will use this plug-in at your own risk. As Adobe deliberately keeps the secure ones out of our reach (according to their highly questionable "upgrade your CPU or die!" methodics), I simply cannot guarantee that this plug-in version is free of security holes.

As written further above, 11.1.* works fine, even though it's extremely hard to obtain because these versions have been withdrawn from nearly every major server I've come across.
However, I've found an 11.2.* version which works fine as well:

It's taken from an early build of Google Chrome v19.

What I did two years ago was the following:

- Used adobe-flashplugin_11.2.202.228-0maverick1_i386.deb as a basis, to know how files are structured

- Created a derivative of this package so that it installs instead (Non-SSE2 build packaged with earlier Google Chrome v19.x binary)

- Rebuilt the .deb package

The package can be found at .

All times are GMT -5. The time now is 05:14 AM.