LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   LinuxQuestions.org Member Success Stories (https://www.linuxquestions.org/questions/linuxquestions-org-member-success-stories-23/)
-   -   finally got dual boot up and running! (https://www.linuxquestions.org/questions/linuxquestions-org-member-success-stories-23/finally-got-dual-boot-up-and-running-81740/)

mcd 08-13-2003 07:13 PM

finally got dual boot up and running!
 
When windows XP crashed two weeks ago, I thought it might be a good time to revamp my whole computer. I got a new mobo (Soyo), a new P4 processor, more RAM, and a new ATI Radeon 9200. Then I installed Mandrake 9.1 on my 8.4G hard drive, only to have problems with getting my onboard lan to work (the software forum history helped me figure out how to fix that), and used it to back up my windows files before reinstalling another mandrake 9.1 on my 15G hard drive. Then I switched my files back over to the bigger hard drive, with the idea of installing win98 on the smaller one for a dual boot system. (I wanted to be able to run games on my windows OS). Before booting the win98 CD I disconnected my slave drive w/ linux, just to be safe. First win98 setup wouldn't even recognize that I had a hard drive, so I reconnected linux, logged in and partitioned the master using a vfat filesystem. Windows scanned the disk, declared it error-free, then told me it couldn't write to the disk because it had an error. I ran the Maxtor diagnostics disk, which declared the drive error free and factory re-certified. I tried win98 setup again, same result. I tried using Maxtor's partitioning tool, which told me it couldn't write to the disk because of an error. I ran the diagnostic program again and again it came back clean.

Now I was getting frustrated.

I ran fdisk and erased everything, then created a primary DOS partition. This time, win98 setup co-operated and decided to let me install. When it was done it asked me to restart, which then produced an I/O error, please replace system disk. This got me a little worried, until I searched through a few threads on help boards and found people who had the same error message, in their case solved by changing the jumper settings. I tried master, I tried slave, I tried cable select, and I tried empty. I switched IDE cables and tried them all again. Nothing worked.

So I ran fdisk again and erased the whole drive again. I ran more diagnostics and again found nothing wrong with the disk. Finally, after 2 more attempted installations, and god only knows how many fdisk sessions, win98 installed and booted without a problem. I was able to use the mandrake CD to reinstall LILO to the MBR, and edit the lilo.conf file to boot both OS's, and my computer is finally back up and running properly!! (Now I just need to configure the fstab correctly....and find a way to configure my Radeon 9200 to work in linux without crashing X....but I have faith, all in good time.)

So thanks to all those out there who fought their way through similar problems and to those whose posts helped solve them, and to those of you reading this post, for your patience. Somtimes you just need to celebrate with others.

Thanks,

McD


All times are GMT -5. The time now is 11:23 PM.