- Member Success Stories (
-   -   [SOLVED] Debian udev Version 617-1 problems (

kevinbenko 04-06-2011 02:16 PM

[SOLVED] Debian udev Version 617-1 problems
I installed udev version 617-1 from the unstable (sid) repository of Debian yesterday. Shortly thereafter my USB keyboard and mouse froze. I plugged in another USB keyboard and mouse, still frozen.
(sadly, I have no PS2 port with which to check my PS2 keyboard and mouse)

So, I did a dreaded (soft) power cycle, and when it rebooted, my keyboard, mouse, and external drives were still not recognized, although GRUB did recognize my keyboard.

I figured it was udev and booted into a live CD (slax)

After using my Google-fu powers, it seems that the problem was the damnable new /run directory which was not fully implemented and udev needed to write to /run while / was still in a read-only state.


As an experiment in "what if...." I archived the /run directory, deleted /run, and rebooted.
My machine rebooted, I downgraded to udev 616-1, and I set up a proper /etc/apt/preferences file, which I had been planning for a few weeks but kept putting off.

At least in my case, removing the /run directory and downgrading udev to the testing (wheezy) version 616-1 fixed my problem with udev.

craigevil 04-06-2011 03:38 PM

Debian User Forums View topic - udev broken in sid :

All times are GMT -5. The time now is 12:57 AM.