LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > LinuxQuestions.org > LinuxQuestions.org Member Intro
User Name
Password
LinuxQuestions.org Member Intro New to LinuxQuestions.org? Been a long time member but never made a post? Introduce yourself here.

Notices


Reply
  Search this Thread
Old 06-10-2003, 10:20 PM   #1
Q-collective
Member
 
Registered: Jun 2003
Location: Netherlands
Distribution: Gentoo, obviously
Posts: 113

Rep: Reputation: 15
Cool Greetings!


I'm Q and am very new to the Linux world...blablabla
I'm running redhat 9.0 atm but I've the odd thing that I can't get any sound from it!
I have an intergrated mobo sound system (AC '97 offcourse )
But Linux doesn't want to see that...

I already tried looking on the cd that came with the mobo But due to my n00byness I didn't get much from it....very confuzing in n00by eyes!

So there ya go! I've an ASUS mobo with an ali chipset (yes, my dma is turned of )...what more is there to say?

Oh yes!

Hello...
 
Old 06-10-2003, 10:31 PM   #2
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 60
the borg got Q!

Welcome to the world of Linux.

On board sound sucks anyhow because it is so noisy. I can't stand them in either Linux or Windows. Of course, they are totally useless for good recording, a must for me as I am a musician.

Why put the sound stuff next to the noisy CPU?

The SoundBlaster Live is approaching $20 now, so why antagonize your ears?

# Redhat links
RedHat Linux Manuals
Maximum RPM
rpmfind
Easier software management: apt4rpm - Red Carpet
RedHat 8.0 Tips & Tricks

# Redhat 7.3 down configuration commands
setup leads to several configuration tools

# Redhat 7.3 up configuration commands
Configure soundcard:
redhat-config-soundcard
Configure X server:
redhat-config-xfree86
Configure network:
redhat-config-network
 
Old 06-10-2003, 10:44 PM   #3
Q-collective
Member
 
Registered: Jun 2003
Location: Netherlands
Distribution: Gentoo, obviously
Posts: 113

Original Poster
Rep: Reputation: 15
DOH!!!

I already HAVE a soundcard!!!
Soundblaster live 5.1

I put the card out of my pc because of an....yes, windows problem

So, I just put my card in and everything should work fine?


Btw: I am the Q, you will be annoyed, resistance is futile!
 
Old 06-10-2003, 11:01 PM   #4
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 60
Remember to diasble the on board sound in the BIOS. You just may need to run

redhat-config-soundcard

as root first, then you should smile as Linus sooths your agonized nerves

Last edited by fancypiper; 06-10-2003 at 11:05 PM.
 
Old 06-12-2003, 10:13 PM   #5
Q-collective
Member
 
Registered: Jun 2003
Location: Netherlands
Distribution: Gentoo, obviously
Posts: 113

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by fancypiper
Remember to diasble the on board sound in the BIOS. You just may need to run

redhat-config-soundcard

as root first, then you should smile as Linus sooths your agonized nerves
I tried what you said, but I couldn't find any option in the BIOS that would disable the mobo sound...Maybe I looked for the wrong thing?

Also, I already tried the redhat-config-soundcard command several times, but to no avail...
 
Old 06-12-2003, 10:35 PM   #6
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 60
Search all your options under each listing in your bios setup. It's in there somewhere. The sblive won't work until that's disabled.

I had to scroll down a pretty good way on one of the pages on this sis board to turn mine off. Did you scroll down to the bottom of each one?

Last edited by fancypiper; 06-12-2003 at 10:44 PM.
 
Old 06-13-2003, 05:23 AM   #7
Q-collective
Member
 
Registered: Jun 2003
Location: Netherlands
Distribution: Gentoo, obviously
Posts: 113

Original Poster
Rep: Reputation: 15
Okay, now I have disabled the onboard sound but a next riddling problem appears: When I reboot and he is in the proces of restarting he says:"insmod ov511 failed"

Well the error msg was a bit longer but this is I think the most significent part (it was a hell of a long msg) and it said in the same msg that it has something to do with the audio, so here I am again!
 
Old 06-13-2003, 10:17 AM   #8
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 60
A quick google search says that "This is a driver for the OV511, a USB-only chip used in many "webcam" devices"

Did you try running

redhat-config-soundcard
 
Old 06-13-2003, 10:23 AM   #9
Q-collective
Member
 
Registered: Jun 2003
Location: Netherlands
Distribution: Gentoo, obviously
Posts: 113

Original Poster
Rep: Reputation: 15
Oops! I could have usedgoogle myself...

However, yes I did run that, but to no avail. I simply don't hear *any* sound and when I press the 'no' button I get "sound detection failed, there is no sound availeble on the system" (but you probably know that )
I really appreciate your help anywayz!

grtz
 
Old 06-13-2003, 10:31 AM   #10
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 60
Well, I'm running a sound blaster live and here are the modules I have loaded:
Code:
phil@uilleann$ su -
Password: 
[root@uilleann root]# lsmod
Module                  Size  Used by    Not tainted
emu10k1                63968   2  (autoclean)
ac97_codec             11936   0  (autoclean) [emu10k1]
sound                  71916   0  (autoclean) [emu10k1]
soundcore               6692   7  (autoclean) [emu10k1 sound]
The card is inserted all the way into the PCI slot? Did you run kudzu?
 
Old 06-13-2003, 10:44 AM   #11
Q-collective
Member
 
Registered: Jun 2003
Location: Netherlands
Distribution: Gentoo, obviously
Posts: 113

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by fancypiper
Well, I'm running a sound blaster live and here are the modules I have loaded:
Code:
phil@uilleann$ su -
Password: 
[root@uilleann root]# lsmod
Module                  Size  Used by    Not tainted
emu10k1                63968   2  (autoclean)
ac97_codec             11936   0  (autoclean) [emu10k1]
sound                  71916   0  (autoclean) [emu10k1]
soundcore               6692   7  (autoclean) [emu10k1 sound]
The card is inserted all the way into the PCI slot? Did you run kudzu?
ok, question 1: were can I find those working modules?
question 2: what the heck is kudzu?

And yes, the card is all the way in that pci slot, in winnie it is working perfectly!
 
Old 06-13-2003, 10:59 AM   #12
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 60
Modules are part of the kernel that can be loaded or unloaded while the kernel is running

Kudzu is a hardware probing/configuring tool. As root command:

kudzu

See if it mentions new hardware.

Also, plug and play should be disabled in your BIOS. Have you done that?

Troubleshooting Your Sound Card
 
Old 06-13-2003, 11:03 AM   #13
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 60
My /etc/modules.conf file:
Code:
alias parport_lowlevel parport_pc
alias eth0 sis900
alias usb-controller usb-ohci
alias usb-controller1 usb-uhci
alias usb-controller2 usb-uhci
alias usb-controller3 ehci-hcd
alias sound-slot-0 emu10k1
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
 
Old 06-13-2003, 11:08 AM   #14
Q-collective
Member
 
Registered: Jun 2003
Location: Netherlands
Distribution: Gentoo, obviously
Posts: 113

Original Poster
Rep: Reputation: 15
Ah! now we are getting somewere!

Btw, why should plug and play be disabled?
 
Old 06-13-2003, 11:42 AM   #15
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 60
To keep settings from getting changed each boot. If the settings get changed, they have to be re-configured every boot. Boots are much faster and hardware works more reliabably than with plug and pray.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



LinuxQuestions.org > Forums > LinuxQuestions.org > LinuxQuestions.org Member Intro

All times are GMT -5. The time now is 11:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration