-   LinuxAnswers Discussion (
-   -   DISCUSSION: Setup Raid0 on Slack 10.2 (

XavierP 01-11-2006 02:25 PM

DISCUSSION: Setup Raid0 on Slack 10.2
This thread is to discuss the article titled: Setup Raid0 on Slack 10.2


Once I bought a second hard drive, I decided it was time to try out raid. I found searching around that most of the tutorials on setting up raid was either for old linux versions, for hardware raid, or for raid1 (mirroring). The closest how-to I could find was for a Slackware 8.1 system at - which is what this tutorial is mostly based on. I tried the methods described numerous times, and nothing prevailed. Finally, I winged it and tried the steps described in this tutorial.

vonst 05-21-2006 09:52 AM

Slack 10.2 RAID 0 install on SATA drives...alt
This article is great! However, I tried this mini-HOWTO right out of the box and it failed miserably. In order to install with the options of SATA and RAID, you have to use the "sata.i" kernel. On loading, I would get a warning and error that the superblock was invalid:


md: invalid raid superblock on...
I could generate the array; I could format the array; I could install Linux into the array; I could not get the array to come back to me on reboot! I would then restart Linux with the install disks, regenerate the array, and find my install sitting there fat, dumb, and happy.


It took me two months to find this solution and I took it right out of the old Software-RAID-HOWTO. md was doing the complaining. Eventually, I found that mdadm administers md. The Software-RAID-HOWTO (Sect 2.4) says that you don't need mdadm. However, if you are experiencing the same problem with generating a persistent superblock that I did, mdadm is a must.

mdadm is not in your Slackware installer disks. You may be able to copy it into your RAM OS after you load up sata.i, but I did not do that. I actually just about gave up on RAID and completely installed Slackware onto a single partition. At that point, I discovered mdadm and ran a single command that I learned from the Software-RAID-HOWTO (Sect 5.4). It suceeded nicely, just like mkraid suceeded nicely. However, on reboot, all the errors went away and from then on, it finds and installs the /dev/md0 that I asked for when I ran the command. Oddly, I seem (for now) to have no need to keep a raidtab file at all. I generated one, just in case. Anyway, here's the command that saved my sanity:


mdadm --create --verbose /dev/md0 --level=raid0 --raid-devices=3 /dev/sdb2 /dev/sdc2 /dev/sdd2
I hope this helps everybody else!


Note: This post is an edit of a plea from 2 months earlier to help me solve the problem of the non-persistent superblocks.

eRJe 10-05-2006 12:07 PM

I'm trying to setup a raid (jbod) config. I've been going through a lot of tutorials but basically there all the same. I always get stuck somewere along the way. I have 2 SATA drives which I want to combine to one drive. On a 3rd drive I have my slackware distribution 11 kernel 2.6.18 installed.

I have tried so far:

mdadm --create --verbose /dev/md0 --level=linear --raid-devices=2 /dev/sda1 /dev/sdb1
but getting the error message: mdadm: error opening /dev/md0: No such file or directory
then I tried creating md0 by doing: mknod /dev/md0 b 9 0
but after: mkraid /dev/md0 I get the error message: cannot determine md version: 6.

Does anyone know how to proceed?

Any help is much appreciated!


vonst 10-05-2006 01:58 PM

This thread was meant to discuss the article. Granted, the article is general and cannot meet all needs. You've got one of those big problems that the forums were meant to help with.

Could you bump this post out to the Slackware forum so that me and the other Slackware RAID guys can better understand your setup and errors and help you out there?

After we fix your problem, assuming we can fix your problem, you can post your solution back on this thread like I did.

-- vonSt

Furlinastis 10-24-2006 11:58 PM

I hope I'm not overstepping my bounds by posting here, but I finally installed raid with slackware, but I used a gentoo liveCD to set up raid with mdadm. There's no need for a /etc/raidtab file or anything with mdadm, just run the command and format and install slack. :) I would suggest that someone put mdadm into the install disc of slackware.

My drives are like so: (in case this helps anyone)
/dev/md2 / raid1 256MB /dev/hd(a,b)2
/dev/md1 /boot raid1 38MB /dev/hd(a,b)1
/dev/md3 /usr raid0 5.7GB /dev/hd(a,b)3
/dev/md4 /opt raid0 5.7GB /dev/hd(a,b)6
/dev/md5 /home raid0 98GB /dev/hd(a,b)7

All partitions were done with ext3.

I used this tutorial as well:

All times are GMT -5. The time now is 04:20 PM.