-   LinuxAnswers Discussion (
-   -   DISCUSSION: Resetting Windows Passwords with Knoppix (

halo14 05-20-2005 04:43 PM

DISCUSSION: Resetting Windows Passwords with Knoppix
This thread is to discuss the article titled: Resetting Windows Passwords with Knoppix

pingu 06-09-2005 05:54 AM

Unfortunately ver 3.8 does not have captive-ntfs although it says so trying to remount hda1 writable...
And ver 3.4 is no longer in the archives...

pingu 06-09-2005 07:29 AM

Well I found version 3.4, it has no such thing as captive-ntfs?

darin3200 08-09-2005 11:07 AM

I also tried this with Knoppix 3.4 and couldn't find the captive NTFS utility

yekrahs 09-27-2005 07:43 AM

The link to download the chntpw from the debian unstable repository is broken, btw.

Also, when I looked for it on the debian package website, it said that it was "non-free".
Is it still going to be ok to use it?

fakie_flip 11-05-2005 03:57 PM

I found chntpw click here. I am using Knoppix 3.9, and I cannot find captive ntfs in it. Has anyone got the password reset to work?

fakie_flip 11-05-2005 04:25 PM

Kanotix 2005-04 rc7 has captive ntfs. I do not know about the other versions. They might too.

yekrahs 11-06-2005 09:06 AM

You don't have to use Knoppix by the way. (or bother with Capive ntfs etc.) People have made good easy to use Windows ports of chntpw.

Read this weblink here:

It runs from a bootable floppy.
(Or a USB, I suppose).

fakie_flip 11-06-2005 10:18 AM

How can a linux user use that? It is in exe format.

yekrahs 11-12-2005 10:39 AM

Oh come on...
Windows computers are everywhere. Libraries, etc.
It might be a simpler to make a sacrifice and make the floppy on one of Bill Gates's.

I'm just trying to say what's easier: given that it seems that some people have had problems with captive ntfs on knoppix, I think that link is helpful.

fakie_flip 11-16-2005 02:29 PM

Come on now to you...

For you bible lover: Does the bible have a writing about being very rude?

I do not have a car. My windows xp is broke. I am not allowed to download and run most dos executable files from public computers. Part of the many ways I try to solve this problem was coming on here. I solved the problem by another way and I have got into the windows machine. It is not a problem anymore.

yekrahs 11-18-2005 06:08 AM

I wasn't trying to be rude there... (a little facetious perhaps).
...sorry if you thought so.

I would have made the files myself and emailed them to you if I'd known your XP was broke...

(I thought you mighn't have wanted to download them because you were one of those hardcore linux types, refuses to use windows for anything, on ethical grounds!


How can a linux user use that? It is in exe format.
(You are using gentoo, after all: often a distribution for people who really want to delve into linux and never go back. NB, I'm not making a generalised statement about why you're using it, by the way). Didn't know you couldn't actually download them. (you should have said, and as I mentioned, I'd have emailed them to you).

I am genuinely happy to see you solved it some other way though.

yekrahs 11-18-2005 06:14 AM

The verse is:

Ephesians 4 v 29:
Do not let any unwholesome talk come out of your mouths, but only what is helpful for building others up according to their needs, that it may benefit those who listen. (NIV)

I *was* trying to be helpful in the first place by providing the link by the way, given that
people were having problems with captive NTFS, as I've said before. I do believe in sharing information that you find good / useful for the benefit of others (That's also why there's a bible verse as my signature).

NB. If anyone else out there has the same problem, and hasn't an obliging Windows user as an aquaintance, you can email me and I'll send you a .zip of the files. Just click on the email button below this post (don't forget to include your own address!)

AskMe 12-25-2005 09:48 AM

I am using Knoppix 4.0 but sorry to say that there is no anything called captive-ntfs in Menu Knoopix>>utilities>>.....
Please let me know where is-- captive-ntfs !!
By the way I tried to mount NTFS partition and tried to set action as read/write mode, but when I tried to change/delete SAM file ----/mnt/hda1/windows/system32/config/sam it give me error SAM is read file only, write protected.
I also tried chntpw But did not work!!!

Please let me know how can I reset my Windows XP admin password using knoppix.

StrongB@d 04-22-2006 10:27 PM

UPDATED: Knoppix 4.02 CD, for Dell intel controller and SATA drive with NTFS partition.
problems: Knoppix 4 CD does not contain captive-ntfs, I am using a new Dell with SATA and an intel controller (it seems knoppix is one of the few distros with the ability to recognize the drives -/dev/sda).

1. mount the ntfs partition using the instructions on the KNOPPIX CD:
"It will work on Knoppix 4 (adding a few files, modifying files) using
the description in the KNOPPIX/linux-ntfs/FOR-DEVELOPERS.txt for
libntfs+fuse, or regularly and transparent on Knoppix 5 with the
included mount.ntfs". -Klaus Knopper

2. continue with chntpw instructions above.

Good luck

Trintith 01-24-2007 05:57 AM


Originally Posted by yekrahs
You don't have to use Knoppix by the way. (or bother with Capive ntfs etc.) People have made good easy to use Windows ports of chntpw.

Read this weblink here:

It runs from a bootable floppy.
(Or a USB, I suppose).

It actually uses the exact same technique as discussed with knoppix (uses linux and chntpw), not windoze.

johngreenwood 02-18-2007 08:38 PM

There is also Ultimate Boot CD

ademarog 04-12-2007 06:04 PM

Can't see full original post
I am a newbie, just joined within the last hour. I know this must be a stupid question, but I can't see the full original post - it appears to be truncated after a few sentences. Could this be something on my end (I'm using Firefox)? If not, what else could it be? Thanks for any help that anyone can give me.


phantom_cyph 04-12-2007 07:00 PM

So, I have a friend that can't get on her computer because she forgot her password for Windows. Can I use Knoppix to look at it or change it? If so, what is the directory I need to look in?

Pronco 10-13-2007 02:25 PM

This Tutorial is not completed

Thank You!

All times are GMT -5. The time now is 02:01 AM.