-   LinuxAnswers Discussion (
-   -   DISCUSSION: Configuring HPLIP for Slackware 10.2 (

simcox1 01-24-2006 04:53 PM

DISCUSSION: Configuring HPLIP for Slackware 10.2
This thread is to discuss the article titled:


Reasons: The reason for this how-to is simply that configuring hplip on slackware can be problematic, partly because it doesn't use SystemV style init scripts. Assumptions: This is just to list my own basic set-up so you can see exactly what I was using. My printer is an HP PSC 1110, all-in-one printer/scanner/copier. I have a full install of Slackware 10.2 with the 2.4.31 kernel, although I do not have KDE/QT installed. Among the system requirements listed by hplip are QT and net-snmp. However, QT is only required for the hp-toolbox GUI, and net-snmp is only required if your printer is networked. Therefore firstly install net-snmp if you have a networked printer, otherwise it's not required.

BlackHawk1966 02-22-2007 02:27 PM

In regards to your how to

Thank you so very much. I had tried a simpler tutorial with no success. Yours has worked to the point of getting my printer up and running and the scanner (if used with kooka) works also. xsane launches the license agreement but cannot, then find my scanner.

This is perhaps because of the differences in driver versions as well as Slackware versions.

I used your tutorial to install an HP PSC 1610 all-in-one on a full install of Slackware 11.0 with the kernel.

Once again, thank you.

simcox1 04-02-2007 07:31 AM

There are couple of omissions which need to be added to this tutorial, the most important of which is, that after you've moved the sane libs, you will need to run 'ldconfig' as root. Otherwise sane won't launch. In other words, before running 'scanimage -L' towards the end of the tutorial, run 'ldconfig' as root. It should be ok then.


PS sorry for the late reply.

XavierP 04-02-2007 08:18 AM

If you want to add any amendments, send me a mail with the changes and where they need to be added and I'll put them in for you.

All times are GMT -5. The time now is 04:26 PM.