-   Linux - Wireless Networking (
-   -   WPC11 Version 4! (

mordanda 05-26-2003 12:56 AM

WPC11 Version 4!
Hi All. I have a compaq 17XL365 notebook dual-booting XP Pro and Red Hat 9. I just got the linksys wireless network B kit which comes with a card and router.

The card is the infamous wpc11, but it is version 4! With a little help I've discovered that the controller chip in this card is a realtek 8180L, realtek has driver binaries and source to download on their site, but I have two things going against me...

1. I can install and use Linux reasonably well, but I'm not real good at configuration or alteration outside of the initial install. I'm also kinda shakey doing stuff out of the GUI (read: not afraid, just inexperienced)

2. I am completely new to wireless networking.

Can anybody help me set up this card?

Also, one question to satify a curiosity, if I add a driver by means of an RPM, why if I use the GUI tools to set it up is the driver not listed. (ex. I added the prism2 drivers while attempting the get the card up and running, but using the red hat 9 network setup tool, the prisim2 driver was not listed in the drop down menu.)

Thanks in advance,

steven999 05-26-2003 02:07 AM

Issues here as well
I picked up the same kit yesterday and have been trying hard to get this thing going. Downloaded the driver and insmod'ed it, but the dmesg log says the driver didn't see a device.

I'm horrible at configuring networking things on linux so any help appreciated. For reference I'm on a thinkpad t23 and Mandrake 9.1.


finegan 05-28-2003 03:18 PM


The Realtek site has a binary precompiled driver for RH9.0, you just have to insmod it, now....

I've never done that, actually my experience with that card is about 2 hours a month and a half ago with some generic version of the chipset that I borrowed off a kid who had picked it up for ~$20USD in Seoul about a month before. I got it talking WEP for a few minutes and got bored with it. I had to compile it from scratch, which is what steven999 is what you're going to have to do too dude...

The precompiles for RH aren't going to swing into Mandrake just that easily. You'll have to have a compiler and your kernel source installed and make certain that you edit the top of the Makefile to reflect the name of your current kernel, post back if you get lost with it.

Also, all of the settings for it are a little weird, they use the "iwpriv" command for EVERYTHING, even turing the card on, which is a bit annoying. Its all in the README, which isn't that bad of a readme to be honest. There's also another thread in Hardware about this kid too, you might want to check some of that one out too.



steven999 05-28-2003 04:14 PM

Hi Finegan,

Thanks for chiming in. I have been following the other message thread as well, and I've spent quite some time getting nowhere with this card, to the point where I'm actually booting into Win2K for the time being. (yuck.)

I had already compiled the driver with a modified Makefile to account for Mandrake's kernel version. I can insmod it in and lsmod will show it's loaded. depmod -a will say there's missing symbols however.

Using the default wlanup script that comes with the driver didn't get it to work, unfortunately. If I dhcpcd wlan0, my computer crashes and I have to reboot. I'm using a Thinkpad T23, and when I do the dhcpcd, I get some blinking lights and everything is frozen.

If I use ifconfig wlan0 I do see it bound to the right memory address that's reported from lspci.

I do get some strange messages when I dmesg about the driver not being AP or something. I'm not that familiar with wireless cards, so it's eluded me a bit. I also get a message about something regarding PIO and #0.

I'll post more information later when I get to my laptop and get the logs and configuration files off of it.


finegan 05-28-2003 04:32 PM

The script is very basic, and I don't think it sets the mode correctly to begin with, a crash is odd... before I figured out its iwconfigs I just got timeouts...


#Load module
/sbin/insmod rtl8180_24x.o

#/sbin/iwpriv wlan0 wlan_para ssid2scan=aptest

#Enable wireless lan driver
/sbin/iwpriv wlan0 enable

#Configure wlan0 IP address
/sbin/ifconfig wlan0
echo "$(/sbin/ifconfig wlan0)"

Doesn't set the mode it should be in... hmm...

before setting the ssid, try adding the line:

/sbin/iwpriv wlan0 wlan_para networktype infra
and then set the ssid2scan with your AP's essid, a stock Linksys AP is "linksys"

Check the current settings with:

/sbin/iwpriv wlan0 wlan_para

and post back with those. Also, is your AP running WEP?



steven999 05-28-2003 10:45 PM

Okay, I tried that out and got about as far as I ever get. If I do ifconfig wlan0, i get:

wlan0 Link encap:Ethernet HWaddr 00:06:25:2B:B2:5E
inet addr: Bcast: Mask:
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:11 Base address:0x4000

(I set the address to instead of 101)

from running dmesg, during bootup I got:

******** RTL8180 Wireless Lan Driver Version 1.0 loaded when 00:35.08********
PCI: Setting latency timer of device 03:00.0 to 64
RTL8180: 03:00.0: region #0 IS a PIO resource!
RTL8180: STA is NOT acting as AP!
RTL8180: rtl8180_pci_driver loaded. ioaddr=0x4000, irq=11, MAC_addr=0:6:25:2b:b2:5e

and from running lspci -vv, i got:

03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd.: Unknown device 8180 (rev 20)
Subsystem: Linksys: Unknown device 0019
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Latency: 64 (8000ns min, 16000ns max)
Interrupt: pin A routed to IRQ 11
Region 0: I/O ports at 4000 [size=256]
Region 1: Memory at 20800000 (32-bit, non-prefetchable) [size=512]
Capabilities: [50] Power Management version 2
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME(D0-,D1+,D2+,D3hot+,D3cold+)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-

I have WEP off on the AP, and pretty much left the AP alone as I wanted to get a connection first before securing it.

At this point it looks like the card is up but I just can't seem to figure this stuff out. I can't ping the AP or any other IP so I'm pretty sure no connection is up.

Any help greatly appreciated!


finegan 05-28-2003 10:54 PM

Well, the driver is loaded and the IRQ and MAC are good, but the important part is the current settings, what's the output of:

/sbin/iwpriv wlan0 wlan_para



steven999 05-29-2003 04:37 AM

Hi again,

That command didn't work (along the lines of syntax error). I tried without the wlan_para and got:

wlan0 Available private ioctl :
senddata (89F3) : set 3 int & get 0
enable (89F4) : set 0 int & get 0
disable (89F5) : set 0 int & get 0
rtl_io (89F2) : set 32 char & get 0
sta_tbl (89F8) : set 16 char & get 0
wlan_para (89F6) : set 128 char & get 0
drv_para (89F7) : set 64 char & get 0
msglevel (89FA) : set 1 int & get 0
set_by_flash (89FB) : set 32 char & get 0

also, here's something I saw a couple days ago, but forgot about. I had redid my wlanup a little to add the infra, and when i ran it i got from dmesg:

RTL8180: Use RTL private command [ssid2scan]
RTL8180: Set ssid2scan = 0x6c(l) 0x69(i) 0x6e(n) 0x6b(k) 0x73(s) 0x79(y) 0x73(s)
RTL8180: Use RTL private command [channel]
RTL8180: Use RTL private command [networktype]
RTL8180: ------ Enable RTL8180 driver ------
RTL8180: Read CONFIG4: RTL8180 + RFMD RF.
RTL8180: Autoload RFChipID in EEPROM -> RTL8180 + MAXIM RF.
RTL8180: Scan PHY channel number = 1
RTL8180: Scan PHY channel number = 2
RTL8180: Scan PHY channel number = 3
RTL8180: Scan PHY channel number = 4
RTL8180: Scan PHY channel number = 5
RTL8180: Scan PHY channel number = 6
RTL8180: Scan PHY channel number = 7
RTL8180: Scan PHY channel number = 8
RTL8180: Scan PHY channel number = 9
RTL8180: Scan PHY channel number = 10
RTL8180: Scan PHY channel number = 11
RTL8180: Neither joining a BSS or starting an IBSS

I tried an experiment and pinged the IP i set for wlan0 and sent/received packets fine (don't know if that means a thing at all).

I'm going to take my laptop to work and try to tackle it there tomorrow. Thanks again for helping along with this!


finegan 05-29-2003 04:49 AM

That's good, this card needs to have its hand held through everything, so just not having tx errors trying to ping yourself means that its half-set-up-right. Try this set, maybe this will beat it senseless:

iwpriv wlan0 enable
iwpriv wlan0 wlan_para authtype=opensystem
iwpriv wlan0 wlan_para ssid2scan=networknamehere
iwpriv wlan0 wlan_para wepmode=off
iwpriv wlan0 wlan_para networktype=infra
iwpriv wlan0 wlan_para ssid=networknamehere

Hopefully that combination of mungy mess might give it something to latch onto, in the previous scan it looked but didn't find anything, but evidently this kid has to be told the exact name of the ssid to join, which is a bit tedious, but there seems to be 2 commands for that?!?



steven999 05-29-2003 01:41 PM

Okay, tried out all of those settings and got the same thing.

One thing to note: doing a make clean removes all .o files, including a file called priv_part.o. After doing that, I realized there's an open source part and a closed source part to this.

That got me thinking, the download was for redhat 8.0 and I don't remember if redhat 8.0 had gcc 3 series or if that was the release with the redhat special 2.96. I'm wondering now if the priv_part.o isn't binary compatible. I'm hoping I'm wrong about the 2.96 thing, but when I do do a depmod -a, I have been getting Unresolved Symbols in the rtl8180_24x.o.

Well, I'll keep trying out other things...

thanks again!

steven999 05-29-2003 01:45 PM

Scratch that, it says right in the directory "compiled using gcc_3.2". doh!

steven999 05-29-2003 02:04 PM

Okay, I started from scratch (yet again) and got different results this time. Now I can't insmod the module (bizarre) and I get:

rtl8180_24x.o: kernel-module mismatch
rtl8180_24x.o was compiled for kernel version 2.4.21-0.13mdkcustom
while this kernel is version 2.4.21-0.13mdk.

There's something strange about this for sure. I'm going to investigate along these lines and see if there's not something strange going on here.

thanks again,

steven999 05-29-2003 02:18 PM

Alright, I found that version.h in the kernel source in linux-2.4.21-0.13mdk/include/linux had #defined UTS_RELEASE to 2.4.21-0.13mdkcustom insted of 2.4.21-0.13mdk. I changed that and got the module to insmod fine. So I'm going back to trying other things.

steven999 05-29-2003 04:13 PM

Okay, probably should have checked this a while ago, but when I run iwconfig --version, it says:

wlan0 Recommend Wireless Extension v0 or later,
Currently compiled with Wireless Extension v0.

Is this something to look into?


finegan 05-29-2003 04:22 PM

I wouldn't sweat it, this guy wrote the driver to not really interact with wireless extensions at all, which he will hopefully resolve one day. Anything new turn up? Aside from Mandrake being silly?



All times are GMT -5. The time now is 06:44 AM.