LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 03-30-2005, 04:04 PM   #1
Irob
LQ Newbie
 
Registered: Nov 2004
Distribution: Fedora Core 3
Posts: 6

Rep: Reputation: 0
WMP54Gv2 on Ndiswrapper 1.1 not connecting to DCHP (FC3)


I installed ndiswrapper per instruction on the ndiswrapper installation wiki. It set up fine, and I installed the bcmwl5.inf driver. I did the whole RadioState|1 thing, but whenever I do ifup wlan0, it can never find my IP address.
Here's some information that I copied that could possibly be helpful for finding the problem.

Code:
[root@localhost]# iwlist wlan0 scan
wlan0     Scan completed :
          Cell 01 - Address: E6:E0:D9:36:B7:4D
                    ESSID:"essid"
                    Protocol:IEEE 802.11b
                    Mode:Ad-Hoc
                    Frequency:2.462GHz (Channel 11)
                    Quality:0  Signal level:0  Noise level:0
                    Encryption key:off
                    Bit Rate:1Mb/s
                    Bit Rate:2Mb/s
                    Bit Rate:5.5Mb/s
                    Bit Rate:6Mb/s
                    Bit Rate:9Mb/s
                    Bit Rate:11Mb/s
                    Bit Rate:12Mb/s
                    Bit Rate:18Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0
Code:
[root@localhost net]# iwconfig wlan0
wlan0     IEEE 802.11g  ESSID:"essid"  Nickname:"localhost.localdomain"
          Mode:Ad-Hoc  Frequency:2.462GHz  Cell: E6:E0:D9:36:B7:4D
          Bit Rate=54Mb/s   Tx-Power:14 dBm
          RTS thr=2347 B   Fragment thr=2346 B
          Encryption key:off
          Power Management:off
          Link Quality:100/100  Signal level:-57 dBm  Noise level:-256 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:105   Missed beacon:0
After trying to ifup wlan0, I did dmesg and this appeared:
ndiswrapper (iw_set_bitrate:413): setting bit rate failed (C00000BB)

Here is my .conf file that the driver runs on:
Code:
NdisVersion|0x50001
Environment|1
BusType|5
mac_address|XX:XX:XX:XX:XX:XX
ndis_version|Linksys,07/17/2003, 3.30.15.0

antdiv|-1
Authentication|1
BadFramePreempt|0
BTCoexist|1
Channel|11
EnableAutoConnect|0
EnableLeap|0
EnableSoftAP|0
frag|2346
FrameBursting|0
gpio0|-1
gpio1|-1
gpio2|-1
gpio3|-1
IBSSGProtection|2
Interference_Mode|-1
Locale|15
NetworkAddress|
NetworkType|-1
PLCPHeader|0
PowerSaveMode|0
PwrOut|100
RadioState|1
Rate|0
RoamTrigger|-70
rts|2347
scan_channel_time|-1
scan_home_time|-1
scan_passes|-1
scan_unassoc_time|-1
SSID|
WEP|
Any other information that might possibly be useful:
Every time I uninstall and reinstall the driver, the MAC address for my router seems to change. This might be something related to the router's settings, but I really don't think that should be happening.
The antenna for my card was "half-broken". I honestly don't know if my computer recognizes the fact that there's an antenna or not. My card seems to still be sending and recieving packets on my Windows partiton, though (and I'm currently connected to the internet).

Thanks in advance for any help.
 
Old 03-30-2005, 07:16 PM   #2
mrGenixus
Member
 
Registered: Dec 2004
Location: Colorado, US
Distribution: gentoo, debian, ubuntu live gnome 2.10
Posts: 440

Rep: Reputation: 30
double-check your driver, make sure its EXACTLY the correct driver for your card. Broadcom wireless cards are very sensitive to this.

Also, how does your google searching fair?
 
Old 03-30-2005, 08:09 PM   #3
Irob
LQ Newbie
 
Registered: Nov 2004
Distribution: Fedora Core 3
Posts: 6

Original Poster
Rep: Reputation: 0
Searching up "ndiswrapper (iw_set_bitrate:413): setting bit rate failed (C00000BB)" brought up one result, but to see the answer, I would have to subscribe to the forums. I'm trying to use an older version of ndiswrapper (1.0 instead of 1.1), which is known to work. Also, I am certain this is the correct driver for the correct card. It's a linksys card that uses the bcmwl5 driver.
 
Old 03-30-2005, 08:14 PM   #4
mrGenixus
Member
 
Registered: Dec 2004
Location: Colorado, US
Distribution: gentoo, debian, ubuntu live gnome 2.10
Posts: 440

Rep: Reputation: 30
There are aprox 30 versions of the bcmwl5 driver that I have personally used. Get the exact one for your linksys card
 
Old 03-30-2005, 08:17 PM   #5
Irob
LQ Newbie
 
Registered: Nov 2004
Distribution: Fedora Core 3
Posts: 6

Original Poster
Rep: Reputation: 0
I have the one that the ndiswrapper site told me to get (I also have it on CD)
 
Old 03-30-2005, 08:25 PM   #6
mrGenixus
Member
 
Registered: Dec 2004
Location: Colorado, US
Distribution: gentoo, debian, ubuntu live gnome 2.10
Posts: 440

Rep: Reputation: 30
have you tried the newer version of ndis wrapper as well?
 
Old 03-30-2005, 09:19 PM   #7
Irob
LQ Newbie
 
Registered: Nov 2004
Distribution: Fedora Core 3
Posts: 6

Original Poster
Rep: Reputation: 0
1.1 is the latest version (unless you're counting CVS, and I don't think that would help).
I looked at the distrobution-specific installation instructions on the ndiswrapper wiki and I've noticed that I've made some mistakes, but I'm still not sure if I'm doing it right. I'll give an update tomorrow if it works.
 
Old 03-31-2005, 12:37 AM   #8
Harriskaver
LQ Newbie
 
Registered: Mar 2005
Location: Birmingham, UK
Distribution: Fedora Core 5
Posts: 25

Rep: Reputation: 15
I had this problem with mine. To solve it:
1) Goto Applications->System Settings-> Network.
2) Click edit on the device used for wlan0.
3) Under the general tab, check 'Activate device when computer starts'.
4) Reboot your computer.

It worked for me, hope it works for you.
- Dan
 
Old 03-31-2005, 12:43 AM   #9
dping
Member
 
Registered: Dec 2004
Location: Oregon, USA
Distribution: Kubuntu 9.04
Posts: 181

Rep: Reputation: 30
Oops. Question was answered while I typed. Here's my post anyway...


The site that comes up in google is trying to trick people into signing up. The answer to the question is actually farther down the page. Here it is again if you want to take another look.

I didn't think it was very helpful, but you may get something out of it.

This, however, may explain that error:
Quote:
> ndiswrapper (iw_set_bitrate:413): setting bit rate failed
Accroding to ndiswrapper FAQ:
http://ndiswrapper.sourceforge.net/p.../index.php/FAQ
-----------
Not all wireless settings in Linux are supported by NDIS drivers (e.g., promiscuous mode, above). As of now, all settings that are possible with NDIS drivers are implemented. Some settings are implemented, but most NDIS drivers give errors when setting them; e.g., setting bit rate gives errors, but as per NDIS, one doesn't need to set the rate - the card will pick what is best.
------------
So it should be ok

Last edited by dping; 03-31-2005 at 12:46 AM.
 
Old 03-31-2005, 12:19 PM   #10
mrGenixus
Member
 
Registered: Dec 2004
Location: Colorado, US
Distribution: gentoo, debian, ubuntu live gnome 2.10
Posts: 440

Rep: Reputation: 30
that's actually kindof funny...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Connecting to Wireless Network with ndiswrapper shimano55 Linux - Newbie 12 04-26-2006 08:32 PM
ndiswrapper not working on FC3 ssimontis Linux - Wireless Networking 3 02-21-2005 01:53 PM
FC3: ndiswrapper causes lockups simon_w Linux - Wireless Networking 6 12-11-2004 02:14 PM
problem connecting wireless to DLINK DI-524 using ndiswrapper/BCM94306/Slackware 10 kirkross Linux - Wireless Networking 17 12-07-2004 10:18 PM
ndiswrapper: trouble connecting to router nvidiausr Linux - Wireless Networking 1 11-03-2004 12:34 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 10:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration