LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 11-23-2005, 12:26 PM   #1
dave`2005
Member
 
Registered: Aug 2005
Distribution: Ubuntu 7.10, Slackware 12
Posts: 270

Rep: Reputation: 30
wlan0 has been compiled with version 18, this program supports up to version 17.


Hi all, Im having a problem with my Netgear WG511T PCMCIA card using a Netgear DG834G wireless router. I installed ndiswrapper 1.5 a while back with the correct files from the WG511T's install cd and things were working fine. I recently tried using wifi again and when doing "iwlist wlan0 scan" im getting
Code:
Warning: Driver for device wlan0 has been compiled with version 18
of Wireless Extension, while this program supports up to version 17.
Some things may be broken...
Ive followed a few fixes for this (including installing wireless_tools.27) but they dont seem to 100% be the same problem as mine. The only thing i can recall that has changed since it used to work is i changed the kernel headers back to 2.4.31 from 2.6.13 (the newer kernel i compiled) because i was told this is what i had to do for frozen-bubble to work. Can anyone help me on this matter?

Dave

Last edited by dave`2005; 11-23-2005 at 12:35 PM.
 
Old 11-23-2005, 05:16 PM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 420Reputation: 420Reputation: 420Reputation: 420Reputation: 420
If you're using a 2.6.13 or later kernel, you need to install wireless tools 28, which is in beta right now. I compilied a Slackware package by modifiying the wireless tools Slackbuild script for version 28 and it works very well. If you read through this thread there is an explanation of how to modify the slackbuild script and a link to a package of wireless tools 28.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Regarding distribution + kernel version + gcc version + glib version. JCipriani Linux - General 8 04-19-2008 03:54 PM
rpmdb: Program version 4.2 doesn't match environment version jhibbets Red Hat 2 05-29-2007 10:57 PM
Can software compiled for old version work well shadkong Slackware 2 09-25-2005 11:50 AM
glibc compiled on which keernel version? acidjuice Slackware 4 05-27-2005 10:52 AM
redhat fedora gcc version (compiled for 2.4.20) doesn't match kernel version 2.4.22 start1000 Linux - Software 0 03-16-2004 09:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 09:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration