-   Linux - Wireless Networking (
-   -   wlan0 appears as eth1 and can't get an ip (

kovermours 04-11-2004 10:00 PM

wlan0 appears as eth1 and can't get an ip
Using SuSE 9, my Linksys WPC11 (that works, and I had running under SuSE 8.1 a few months ago) appears as eth1 instead of wlan0, and won't grab an ip from my router. It does in winXP. eth0 is my onboard nic and it works.

I'm using orinoco_cs, external pcmcia.

If you need any other data, please ask!


kovermours 04-11-2004 10:03 PM

it appears as wlan0 during boot, it's set to hotplug.

only in kwifimanager and iwpriv / iwconfig does it appear as eth1.

david_ross 04-12-2004 07:30 AM

Moved: This thread is more suitable in Wireless Networking and has been moved accordingly to help your thread/question get the exposure it deserves.

joninsb 09-13-2004 01:39 PM

have you figured it out yet
I have the same problem. I am not sure what I did, but after adding an interface through yast and a couple of reboots I now get eth1 to work as my wireless interface. This does not seem correct though.

rhettmaxwell 09-13-2004 02:07 PM

you can use iwconfig from the command line to view the adapter. if it shows a mac address like 4444:4444:4444:4444 then its not finding your AP.

you can also use iwconfig to set the ssid, and other wireless configs

iwconfig eth1 essid abcssid key s:abckey

'man iwconfig' for more details.

i think you can change the name of the device from eth1 to wlan0 by renaming /etc/sysconfig/network-scripts/ifcfg-eth1 to ifcfg-wlan0, but i don't use suse, so i don't know for sure.

joninsb 09-13-2004 03:32 PM

Well, I got something working. In /etc/sysconfig/network I have a file named ifcfg-wlan-bus-pcmcia. Weird thing is that my wireless interface always comes up as eth1 but it used this configuration file. I tried renaming it to ifcfg-wlan0 to no avail. I just get an error that says "no configuration information for eth1. It turns out the eth1 basically works but it does not get the default gateway (which I set through yast) so I had to create a file called /etc/sysconfig/network/ifroute-wlan-bus-pcmcia (which somehow gets mapped to eth1) with the following contents.


This works. I still wish I knew how to change eth1 to wlan0 though.

rhettmaxwell 09-13-2004 03:53 PM

ok, i think i figured it out

add the following line to your ifcfg- file


joninsb 09-13-2004 04:55 PM

Thanks for your help. Even though my network is now functional I tried what you said just to see if I could change the name of the interface to wlan0. When I ran '/etc/init.d/network restart' I got:

Shutting down service network . . . . . . . . . . . . . done.
Hint: you may set mandatory devices in /etc/sysconfig/network/config
Setting up network interfaces:
lo IP address: done
eth0 device: Intel Corp. 82801BD PRO/100 VE (MOB) Ethernet Controller (rev 83)
eth0 configuration: eth-id-00:08:0d:23:4b:33
eth0 (DHCP) . . . . . no IP address yet... backgrounding. waiting
eth1 device: "TOSHIBA", "Wireless LAN Card", "Version 01.01", ""
eth1 configuration: wlan-bus-pcmcia
eth1 warning: using NO encryption
interface wlan0 is not available failed
Setting up service network . . . . . . . . . . . . . . done.

I should have mentioned that I already have an ifcfg-wlan0 (which I have no clue what it is for - maybe attached to the pcmcia slot somehow), but I removed this and still got the same error. I don't undertand how hotplug devices work, but I think both wlan-bus-pcmcia and wlan0 are hotplug devices. Don't know if that is related somehow.


All times are GMT -5. The time now is 02:02 PM.