-   Linux - Wireless Networking (
-   -   wlan-ng problems (senao/engenius wlan usb adapter) (

poo bear 05-03-2004 04:02 PM

wlan-ng problems (senao/engenius wlan usb adapter)
My box:

2.0 ghz
512 mb ram
NVIDIA Geforce 2 GTS (32 mb)
Dual booted w/Windows XP and Redhat 9 (2.4.20-6 kernel)

My problem:

I have a Senao/Engenius (prism chipset, I think) wireless lan USB adapter that I use to connect to my access point which gives me internet access, but it seems that it is incompatible with linux. After quite a bit of digging, I learned that I would have to get the wlan-ng drivers to allow it to be used with linux, so I went to [ADDRESS USED TO BE HERE, BUT REMOVED DUE TO STUPID 5 POST RULE] to download pre-packaged RPMs. I chose this route mainly because I am rather new to linux and I thought RPMs would probably be alot easier than downloading and compiling the drivers from source.

Unfortunately for me, the RPMs are only available for kernel versions 2.4.20-20.9, 24.9, 27.9, 30.9, and 31.9. None of which I have and none of which are available for download on [ADDRESS USED TO BE HERE, BUT REMOVED DUE TO STUPID 5 POST RULE].

So then I went to the original site for the wlan-ng drivers ([ADDRESS USED TO BE HERE, BUT REMOVED DUE TO STUPID 5 POST RULE]) to download the sourcecode of the drivers since none of the RPMs would work. First of all, the site offers no information about which files I need to download (there are about 40 different compressed packages) so I tried to go ahead and download all of them. Suffice to say, half of them would not download properly (including the readme file). Even if I could download all of the files, I would have to burn them on to a disc and then switch back to linux and compile each package and see which one works by process of elimination. And that would truly be a pain.

So I'm not sure what I should do, but I know I'm tired of wasting more than half of my 80 gb harddrive on an OS that I rarely use, just because I don't have access to the internet.

Any help would be greatly appreciated.

PS: I want to strangle whoever made that 5 post universal resource locater rule. Thanks for making me retype this entire thing, dickhead.

jayjay1784 05-04-2004 05:00 AM

i think we bove have/had the same problem.

what i did:

i downloaded the wlan_ng(usb) driver rpm's...

as you said, to install them you need a newer kernel version....
so i downloaded the newest kernel available from
i downloaded the rpm-package so installing the new kernel wasn't difficult...

then istalled wlan_ng usb driver rpm's and now my wlan adapter is working.

poo bear 05-04-2004 04:24 PM

Ok, so just download the newest kernel, despite the fact that the rpms are only available for the kernel versions listed above? (see original post)

I might as well give it a shot... thanks!

jayjay1784 05-04-2004 04:53 PM

the newest kernel i could get in the mirror i selected was 31.9, and that was exactly the one i needed / you need.

poo bear 05-04-2004 06:39 PM

Bah... I downloaded and installed it (2.4.20-31.9) along with the accompanying wlan-ng driver rpms and it still doesn't seem to be working.

I keep getting a bunch of weird junk at boot, and it just stays there, so I eventually have to cut the power and go back to windows. I would post what it says, but its really just alot of "mumbo-jumbo" followed by this:

"<0> Kernel panic: Aiee, killing interrupt handler
In interrupt handler - not syncing"

Ofcourse I can avoid this by unplugging the adapter, but that defeats the whole purpose of why I am doing all of this.

jayjay1784 05-05-2004 06:13 AM

i'm also a noob and dont no much about linux....i hope that there are a few linux gurus who can help you, but i think there is a problem with the driver rpm.
i also have problems when i use my adapter....everythink seems to work fine but after a few minutes there seems to be somethink like a memory lack....i think downloading the source and compiling would have been a better solution, but configuring the usb-adapter isnt easy....i'm also still looking for a good solution....

poo bear 05-05-2004 05:54 PM

Despite the fact that I haven't found a solution, its nice to know I'm not in it alone...

Thanks for your time!

All times are GMT -5. The time now is 06:26 PM.