LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 08-12-2005, 05:27 PM   #1
regy109
LQ Newbie
 
Registered: Aug 2005
Location: Christchurch, NZ
Distribution: Mandrake 10.0
Posts: 12

Rep: Reputation: 0
Wink Wireless works... but not on boot up.


I used to have an Ad Hoc network between my Windows XP laptop and my Mandrake 10.0 box. Then I bought an ADSL router that doubles as wireless access point, and now I'm trying to persuade the Linux box to talk to it. After a prolonged struggle, it works...

...But not when I boot up. Yes I have "ONBOOT=yes" in the ifcfg (with a capital ON, which the list editor here seems to make lower case)
When I boot up, it first tries to connect through the ethernet card, and quickly fails because the cable's not plugged in. Then it has a go at my my wireless card on wlan0. It sits there for absolute ages (a minute?) doing apparently nothing, then outputs some stuff about

zcip: Retrieved address 127.255.255.255 for wlan0
sending probe 1 for 127.255.255.255
sending probe 3 for 127.255.255.255
claiming ownership of address 127.255.255.255
watching for collisions

Then a bit further on it tries to start proftpd which complains about a temporary failure in name resolution: "unable to determine IP address of 'obelix'" (the machine is called obelix).

Then I log in and try ping something, and I get
"connect: network is unreachable".

So I do
> ifdown wlan0
NETLINK answers: No such device or address
NETLINK answers: No such device or address

> ifup wlan0
Determining IP information for wlan0... done

And then it all works swimmingly. Well, except that I can ping the whole world except itself. If I try that I get 'ping: unknown host obelix'

Righ, so my question is, why doesn't the wireless network start on boot up?


Here is /etc/sysconfig/network-scripts/icfg-wlan0

DEVICE=wlan0
BOOTPROTO=dhcp
ONBOOT=yes
ESSID="Blah"
MII_NOT_SUPPORTED=no
WIRELESS_ENC_KEY="<big long secret key here>"
DHCP_HOSTNAME=obelix
CHANNEL=1
TYPE=Wireless
MODE=Managed
 
Old 08-12-2005, 06:01 PM   #2
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,012

Rep: Reputation: 115Reputation: 115
does /etc/hosts have something like
Code:
127.0.0.1    obelix.whatever.com  obelix
also, what does iwconfig say right after you boot it up?
 
Old 08-12-2005, 06:16 PM   #3
bushidozen
Member
 
Registered: Oct 2004
Posts: 215

Rep: Reputation: 30
Did you use ndiswrapper to set up and configure your wireless card? If so, as root type:
Code:
ndiswrapper -m
That should get it to start at boot time. If you are not using ndiswrapper, you might need to add something like:
Code:
ifconfig wlan0 up
to /etc/modules.conf (or something like that).
 
Old 08-13-2005, 02:16 AM   #4
regy109
LQ Newbie
 
Registered: Aug 2005
Location: Christchurch, NZ
Distribution: Mandrake 10.0
Posts: 12

Original Poster
Rep: Reputation: 0
No I don't have an entry in the hosts file for obelix. I know that will fix my ping problem, but I was hoping my router might be able to resolve the name some how magically?

Yes I do use ndiswrapper, and ndiswrapper -m says

modprobe config already contains alias directive

Here is what iwconfig says after boot up:

wlan0 IEEE 802.11b ESSIDff/any Nickname:"obelix"
Mode:Auto Frequency:2.412GHz Access Point: 00:00:00:00:00:00
Bit Rate=11Mb/s Tx-Power:20 dBm Sensitivity=0/3
RTS thr=2432 B Fragment thr=2432 B
Encryption keyff
Power Managementff
Link Quality:100/100 Signal level:-48 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

For some reason it's not using the ESSID I put into the ifcfg-wlan0.
 
Old 08-13-2005, 10:16 AM   #5
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,012

Rep: Reputation: 115Reputation: 115
get rid of every setting having to do with mandrake trying to do this and issue
Code:
ifconfig wlan0 up
iwconfig mode "Managed"
iwconfig key "foo"
iwconfig essid "bar"
dhcpcd wlan0
 
Old 08-13-2005, 04:25 PM   #6
regy109
LQ Newbie
 
Registered: Aug 2005
Location: Christchurch, NZ
Distribution: Mandrake 10.0
Posts: 12

Original Poster
Rep: Reputation: 0
Um, get rid of the mandrake stuff from where, sorry?
 
Old 08-14-2005, 01:31 PM   #7
demurray
LQ Newbie
 
Registered: Aug 2005
Posts: 5

Rep: Reputation: 0
I would like to suggest the following.

From your iwconfig report I noticed that the MODE is not set to managed and ESSID is OFF. Try the format from this sample ifcfg-wlan0. The HWADDR is the MAC address of your wireless NIC.


MODE=Managed
ESSID=Your-ESSID-String-Here
# KEY=<26 hex characters for the 128 bit WEP key specific to my AP>
DEVICE=wlan0
ONBOOT=yes
BOOTPROTO=dhcp
HWADDR=00:0C:41:C9:BF:3B
USERCTL=no
PEERDNS=no
TYPE=Wireless
NETMASK=
DHCP_HOSTNAME=
IPADDR=
DOMAIN=
GATEWAY=
IPV6INIT=no
RATE=Auto
CHANNEL=1

This is what the iwconfig report should look like.

wlan0 IEEE 802.11g ESSID:"Your-ESSID-String"
Nickname:"YaYa.Planet4us.com"
Mode:Managed Frequency:2.437GHz Access Point:
00:0C:41:F3A:4F
Bit Rate=11Mb/s Tx-Power:14 dBm
RTS thr=2347 B Fragment thr=2346 B
Encryption keyff
Power Managementff
Link Quality:100/100 Signal level:-60 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:252 Invalid misc:59274 Missed beacon:0
 
Old 08-15-2005, 03:08 AM   #8
regy109
LQ Newbie
 
Registered: Aug 2005
Location: Christchurch, NZ
Distribution: Mandrake 10.0
Posts: 12

Original Poster
Rep: Reputation: 0
I tried the above in ifcfg-wlan0, but it made no difference: it doesn't connect to the network on bootup, but if I do an ifdown and an ifup, it seems to be okay.

Therefore I'm convinced there's nothing wrong with my ifcfg file. The boot process must be failing to do something that ifup normally does. Or the boot process does something that ifup doesn't do. Or the boot process has got things in the wrong order, or something like that.
 
Old 08-15-2005, 02:26 PM   #9
bushidozen
Member
 
Registered: Oct 2004
Posts: 215

Rep: Reputation: 30
Just out of curiosity, where did you get your driver from? I've found that when I install the driver directly from the Windows driver disk (for a Linksys WMP54G), ndiswrapper works, but when I take that same driver, copy it to a hard drive or USB drive and try to use that, I doesn't work. If you have the installation disk, pull your drivers from there and see what happens.
 
Old 08-16-2005, 03:43 AM   #10
regy109
LQ Newbie
 
Registered: Aug 2005
Location: Christchurch, NZ
Distribution: Mandrake 10.0
Posts: 12

Original Poster
Rep: Reputation: 0
Sounds like black magic! I installed the driver last year some time so honestly can't remember, but it has worked ok in Ad Hoc up till the time I got the router.
 
Old 08-18-2005, 09:17 AM   #11
demurray
LQ Newbie
 
Registered: Aug 2005
Posts: 5

Rep: Reputation: 0
The ndiswrapper and driver are being loaded properly according to the log file you sent, so try placing these commands in the '/etc/rc.local' file, as a temp work around. Use DHCP or ifconfig to define the IP address. Do not make any changes to ifcfg-wlan0. Let me know what the results are.

/sbin/iwconfig wlan0 mode Managed
/sbin/iwconfig wlan0 essid (Your ESSID String Here )
/sbin/dhclient wlan0

Last edited by demurray; 08-18-2005 at 09:26 AM.
 
Old 08-18-2005, 03:49 PM   #12
aysia
LQ Newbie
 
Registered: Aug 2005
Posts: 2

Rep: Reputation: 0
Re: Wireless works... but not on boot up.

Quote:
why doesn't the wireless network start on boot up ?
Edit /etc/modules

Quote:
name_your_wireless_modules

Then edit /etc/modules.conf or /etc/modprobe.conf

Quote:
alias wlan0 name_your_wireless_modules
 
Old 08-20-2005, 01:19 AM   #13
regy109
LQ Newbie
 
Registered: Aug 2005
Location: Christchurch, NZ
Distribution: Mandrake 10.0
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by demurray
The ndiswrapper and driver are being loaded properly according to the log file you sent, so try placing these commands in the '/etc/rc.local' file, as a temp work around. Use DHCP or ifconfig to define the IP address. Do not make any changes to ifcfg-wlan0. Let me know what the results are.

/sbin/iwconfig wlan0 mode Managed
/sbin/iwconfig wlan0 essid (Your ESSID String Here )
/sbin/dhclient wlan0
Not sure if I took your meaning correctly, but I added the above three lines to rc.local and rebooted. I think the new stuff in the log is this:


Aug 20 17:50:56 obelix dhclient: Internet Software Consortium DHCP Client V3.0.1rc13
Aug 20 17:50:56 obelix dhclient: Copyright 1995-2002 Internet Software Consortium.
Aug 20 17:50:56 obelix dhclient: All rights reserved.
Aug 20 17:50:56 obelix dhclient: For info, please visit http://www.isc.org/products/DHCP
Aug 20 17:50:56 obelix dhclient:
Aug 20 17:50:56 obelix dhclient: sit0: unknown hardware address type 776
Aug 20 17:50:58 obelix dhclient: sit0: unknown hardware address type 776
Aug 20 17:50:58 obelix dhclient: Listening on LPF/wlan0/00:40:f4:9e:ef:3b
Aug 20 17:50:58 obelix dhclient: Sending on LPF/wlan0/00:40:f4:9e:ef:3b
Aug 20 17:50:58 obelix dhclient: Sending on Socket/fallback
Aug 20 17:50:59 obelix dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
Aug 20 17:50:59 obelix perl: drakupdate_fstab called with --auto --add /dev/ide/host0/bus0/target0/lun0/part1
Aug 20 17:51:01 obelix perl: drakupdate_fstab called with --auto --add /dev/ide/host0/bus0/target0/lun0/part2
Aug 20 17:51:03 obelix perl: drakupdate_fstab called with --auto --add /dev/ide/host0/bus0/target0/lun0/part5
Aug 20 17:51:05 obelix dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
Aug 20 17:51:05 obelix perl: drakupdate_fstab called with --auto --add /dev/ide/host0/bus0/target1/lun0/part1
Aug 20 17:51:08 obelix perl: drakupdate_fstab called with --auto --add /dev/ide/host0/bus0/target1/lun0/part2
Aug 20 17:51:10 obelix perl: drakupdate_fstab called with --auto --add /dev/ide/host0/bus0/target1/lun0/part5
Aug 20 17:51:12 obelix perl: drakupdate_fstab called with --auto --add /dev/ide/host0/bus0/target1/lun0/part6
Aug 20 17:51:15 obelix perl: drakupdate_fstab called with --auto --add /dev/ide/host0/bus1/target1/lun0/part1
Aug 20 17:51:16 obelix dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 17
Aug 20 17:51:33 obelix dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 21
Aug 20 17:51:41 obelix smb: smbd shutdown failed
Aug 20 17:51:54 obelix dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
Aug 20 17:52:00 obelix dhclient: No DHCPOFFERS received.
Aug 20 17:52:00 obelix dhclient: No working leases in persistent database - sleeping.
Aug 20 17:52:10 obelix login(pam_unix)[2245]: session opened for user root by (uid=0)
 
Old 08-21-2005, 06:14 PM   #14
demurray
LQ Newbie
 
Registered: Aug 2005
Posts: 5

Rep: Reputation: 0
Hello,

Well it looks like there was no response from the DHCP server. Lets take that function out of the equation and assign a static IP address in the ifcfg-wlan0. There may be a couple of "ifcfg-wlan0" files on your system. You need to modify the file located "/etc/sysconfig/networking/devices/ifcfg-wlan0 ". If it does not exist, create it.

MODE=Managed
ESSID=ESSID-STRING-HERE
# KEY=<26 hex characters for the 128 bit WEP key specific to my AP>
DEVICE=wlan0
ONBOOT=yes
BOOTPROTO=
HWADDR=00:0C:41:C9:BF:3B
USERCTL=no
PEERDNS=no
TYPE=Wireless
NETMASK=255.255.255.0
DHCP_HOSTNAME=
IPADDR=192.168.x.x
DOMAIN=
GATEWAY=192.168.x.x
IPV6INIT=no
RATE=Auto


Let me know the results......
 
Old 08-23-2005, 04:06 AM   #15
regy109
LQ Newbie
 
Registered: Aug 2005
Location: Christchurch, NZ
Distribution: Mandrake 10.0
Posts: 12

Original Poster
Rep: Reputation: 0
Yeah, I tried that. If I use a static IP it doesn't have the one-minute delay during boot up while it looks for a DHCP server. However, in spite of everything looking fine in the boot log (to my untrained eye), the network is still broken until I log in and do an
Code:
ifup wlan0
. I found that I can do this at the end of the rc.local too.

So I think my linux machine doesn't manage to "see" the router during the boot up, so it can't find the DHCP server. But something must get put right a little later in the boot process, or my ifup wlan0 wouldn't work at all, would it?

This is the log:

Code:
Aug 23 20:51:32 obelix kernel: wlan0: ndiswrapper ethernet device 00:40:f4:9e:ef:3b using driver netr8180
Aug 23 20:51:32 obelix kernel: wlan0: encryption modes supported: WEP
Aug 23 20:51:32 obelix kernel: ndiswrapper: driver netr8180 (KYE System Corp.,05/21/2003,5.140.521.2003) added
Aug 23 20:51:33 obelix rc: Starting partmon:  succeeded
Aug 23 20:51:34 obelix nfslock: rpc.lockd startup succeeded
Aug 23 20:51:34 obelix rpc.statd[1228]: Version 1.0.6 Starting
Aug 23 20:51:34 obelix rpc.statd[1228]: statd running as root. chown /var/lib/nfs/sm to choose different user 
Aug 23 20:51:34 obelix nfslock: rpc.statd startup succeeded
Aug 23 20:51:36 obelix random: Initializing random number generator:  succeeded
Aug 23 20:51:36 obelix xfs: xfs startup succeeded
Aug 23 20:51:37 obelix xfs: ignoring font path element /usr/X11R6/lib/X11/fonts/drakfont (unreadable) 
Aug 23 20:51:37 obelix xfs: ignoring font path element /usr/X11R6/lib/X11/fonts/drakfont/Type1 (unreadable) 
Aug 23 20:51:37 obelix xfs: ignoring font path element /usr/X11R6/lib/X11/fonts/drakfont/ttf (unreadable) 
Aug 23 20:51:37 obelix netfs: Mounting other filesystems:  succeeded
Aug 23 20:51:37 obelix xfs: ignoring font path element /usr/X11R6/lib/X11/fonts/100dpi:unscaled (unreadable) 
Aug 23 20:51:37 obelix xfs: ignoring font path element /usr/X11R6/lib/X11/fonts/pcf_drakfont:unscaled (unreadable) 
Aug 23 20:51:37 obelix atd: atd startup succeeded
Aug 23 20:51:38 obelix sshd: Starting sshd:
Aug 23 20:51:38 obelix kernel: NET: Registered protocol family 10
Aug 23 20:51:38 obelix kernel: Disabled Privacy Extensions on device c035fe60(lo)
Aug 23 20:51:38 obelix kernel: IPv6 over IPv4 tunneling driver
Aug 23 20:51:38 obelix net.agent[1379]: add event not handled
Aug 23 20:51:39 obelix sshd[1389]: Server listening on :: port 22.
Aug 23 20:51:39 obelix sshd[1389]: error: Bind to port 22 on 0.0.0.0 failed: Address already in use.
Aug 23 20:51:39 obelix sshd: startup succeeded
Aug 23 20:51:39 obelix sshd: ^[[65G
Aug 23 20:51:39 obelix sshd: [^[[1;32m
Aug 23 20:51:39 obelix sshd:   OK  
Aug 23 20:51:39 obelix sshd: 
Aug 23 20:51:39 obelix rc: Starting sshd:  succeeded
Aug 23 20:51:39 obelix xinetd: xinetd startup succeeded
Aug 23 20:51:40 obelix xinetd[1412]: Service ftp: attribute already set: disable [file=/etc/xinetd.d/proftpd-xinetd] [line=16]
Aug 23 20:51:40 obelix kernel: parport0: PC-style at 0x378 [PCSPP,TRISTATE]
Aug 23 20:51:40 obelix kernel: lp0: using parport0 (polling).
Aug 23 20:51:40 obelix kernel: lp0: console ready
Aug 23 20:51:41 obelix xinetd[1412]: xinetd Version 2.3.13 started with libwrap options compiled in.
Aug 23 20:51:41 obelix xinetd[1412]: Started working: 3 available services
Aug 23 20:51:49 obelix cups: cupsd startup succeeded
Aug 23 20:51:49 obelix nfs: Starting NFS services:  succeeded
Aug 23 20:51:49 obelix kernel: Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
Aug 23 20:51:49 obelix nfs: rpc.nfsd startup succeeded
Aug 23 20:51:50 obelix nfs: rpc.mountd startup succeeded
Aug 23 20:51:50 obelix loadkeys: Loading /usr/lib/kbd/keymaps/i386/qwerty/us-latin1.kmap.gz
Aug 23 20:51:50 obelix keytable: Loading keymap: us-latin1 succeeded
Aug 23 20:51:50 obelix loadkeys: Loading /usr/lib/kbd/keymaps/include/compose.latin9.inc.gz
Aug 23 20:51:50 obelix keytable: Loading compose keys: compose.latin9.inc succeeded
Aug 23 20:51:50 obelix keytable:  succeeded
Aug 23 20:51:50 obelix postfix: Starting postfix: 
Aug 23 20:51:50 obelix postfix: postalias: warning: My hostname obelix is not a fully qualified name - set myhostname or mydomain in /etc/postfix/main.cf
Aug 23 20:51:51 obelix postfix: postmap: warning: My hostname obelix is not a fully qualified name - set myhostname or mydomain in /etc/postfix/main.cf
Aug 23 20:51:51 obelix last message repeated 4 times
Aug 23 20:51:53 obelix postfix:  succeeded
Aug 23 20:51:53 obelix postfix: ^[[65G
Aug 23 20:51:53 obelix postfix: [^[[1;32m
Aug 23 20:51:53 obelix postfix:   OK  
Aug 23 20:51:53 obelix postfix: 
Aug 23 20:51:53 obelix rc: Starting postfix:  succeeded
Aug 23 20:51:53 obelix numlock: Starting numlock: 
Aug 23 20:51:53 obelix numlock: ^[[65G[^[[1;32m
Aug 23 20:51:53 obelix numlock:   OK  
Aug 23 20:51:53 obelix numlock: 
Aug 23 20:51:54 obelix rc: Starting numlock:  succeeded
Aug 23 20:51:55 obelix proftpd[1761]: localhost - ProFTPD 1.2.9 (stable) (built Thu Nov 20 16:14:14 CET 2003) standalone mode STARTUP 
Aug 23 20:51:55 obelix proftpd: proftpd startup succeeded
Aug 23 20:51:55 obelix crond[1776]: (CRON) STARTUP (fork ok) 
Aug 23 20:51:56 obelix crond: crond startup succeeded
Aug 23 20:51:57 obelix smb: smbd startup succeeded
Aug 23 20:51:58 obelix smb: nmbd startup succeeded
Aug 23 20:52:04 obelix httpd: httpd2 startup succeeded
Aug 23 20:52:10 obelix rc: Starting kheader:  succeeded
Aug 23 20:52:13 obelix python: Site list is missing: mailman
Aug 23 20:52:13 obelix python: 
Aug 23 20:52:13 obelix python: Logging error: <StampedLogger to '/var/lib/mailman/logs/error'>
Aug 23 20:52:13 obelix python: Traceback (most recent call last):
Aug 23 20:52:13 obelix python:   File "/usr/lib/mailman/Mailman/Logging/Logger.py", line 67, in __get_f
Aug 23 20:52:13 obelix python:     1)
Aug 23 20:52:13 obelix python:   File "/usr/lib/python2.3/codecs.py", line 566, in open
Aug 23 20:52:13 obelix python:     file = __builtin__.open(filename, mode, buffering)
Aug 23 20:52:13 obelix python: IOError: [Errno 13] Permission denied: '/var/lib/mailman/logs/error'
Aug 23 20:52:13 obelix python: Original log message:
Aug 23 20:52:13 obelix python: [Errno 13] Permission denied: '/var/lib/mailman/logs/error'
Aug 23 20:52:13 obelix python: Aug 23 20:52:13 2005 (2012) Site list is missing: mailman
Aug 23 20:52:13 obelix mailman: python startup failed
Aug 23 20:52:14 obelix devfsd: Running devfsd actions:  succeeded
Aug 23 20:52:16 obelix perl: drakupdate_fstab called with --auto --add /dev/ide/host0/bus0/target0/lun0/part1 
Aug 23 20:52:19 obelix perl: drakupdate_fstab called with --auto --add /dev/ide/host0/bus0/target0/lun0/part2 
Aug 23 20:52:21 obelix perl: drakupdate_fstab called with --auto --add /dev/ide/host0/bus0/target0/lun0/part5 
Aug 23 20:52:23 obelix perl: drakupdate_fstab called with --auto --add /dev/ide/host0/bus0/target1/lun0/part1 
Aug 23 20:52:25 obelix perl: drakupdate_fstab called with --auto --add /dev/ide/host0/bus0/target1/lun0/part2 
Aug 23 20:52:26 obelix login(pam_unix)[2060]: session opened for user root by (uid=0)
Aug 23 20:52:26 obelix  -- root[2060]: ROOT LOGIN ON vc/1
Aug 23 20:52:28 obelix perl: drakupdate_fstab called with --auto --add /dev/ide/host0/bus0/target1/lun0/part5 
Aug 23 20:52:30 obelix perl: drakupdate_fstab called with --auto --add /dev/ide/host0/bus0/target1/lun0/part6 
Aug 23 20:52:33 obelix perl: drakupdate_fstab called with --auto --add /dev/ide/host0/bus1/target1/lun0/part1 
Aug 23 20:52:56 obelix smb: smbd shutdown failed
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless works.. what now? Sugarat Linux - Wireless Networking 5 09-16-2005 02:58 PM
Wireless works, then fails... djKale Linux - Wireless Networking 1 02-04-2005 03:20 PM
wireless works, cant get online justagirl Linux - Wireless Networking 9 12-15-2004 11:57 PM
RH9 and WinXP_seperate drives dual boot + XP wireless network hardly works anymore? andrewc Linux - General 3 06-17-2004 09:28 AM
I Want A Wireless Card That Works!!!!!! SlackinMonkeee Linux - Laptop and Netbook 20 12-02-2003 10:05 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 07:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration