-   Linux - Wireless Networking (
-   -   Wireless Slackware 13.37 not working Sony Vaio (

na2th 08-28-2012 11:43 PM

Wireless Slackware 13.37 not working Sony Vaio
I just bought this new computer, and the first thing to do was to install Slackware on it. As usual, I installed wicd to connect to the wireless router, but when I ask it to show the networks, it says there's nothing.
I went to the terminal and ran iwconfig, to get this log:
lo no wireless extensions

eth0 no wireless extensions

It does not show the wlan0, and when I run iwconfig wlan0 I got
wlan0 No such device

What should I do ? My Network controller is a Atheros Communications Inc. AR9485 Wireless Network Adapter, and all those commands were after adding the ath9k module with modprobe.

vtel57 08-28-2012 11:58 PM

This is going to sound like a really stupid question, but does your Sony Vaio have a manual wireless on/off switch on it somewhere as the older Vaios did?

na2th 08-29-2012 12:11 AM

No, it doesn't

vtel57 08-29-2012 12:18 AM


Have you read here yet?

And I don't mean that as a RTFM reply. Please don't take it that way.

na2th 08-29-2012 12:35 AM

Oh I didn't take it that way, thank you for the help, btw. Still, I read it and it's meaningless to me. Do I need to set my wlan network at the /etc/rc.d/rc.wireless.conf ? Isn't it a way to make wicd( or any other wireless manager) works like it does in the other computer?

vtel57 08-29-2012 01:19 AM

On my laptop, I did have to manually configure everything, so... you might also have to. :(

vtel57 08-29-2012 01:20 AM

By the way, I think this is what actually got me going...

After 2AM here. I'm off to bed. Luck with it! :)


sycamorex 08-29-2012 01:42 AM

Is the wireless chip recognised at all?

What's the output of /sbin/lspci?

and just to be sure: ifconfig and iwconfig.

na2th 08-29-2012 03:38 PM

bash-4.1# lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation 2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:14.0 USB Controller: Intel Corporation Device 1e31 (rev 04)
00:16.0 Communication controller: Intel Corporation Device 1e3a (rev 04)
00:1a.0 USB Controller: Intel Corporation Device 1e2d (rev 04)
00:1b.0 Audio device: Intel Corporation Device 1e20 (rev 04)
00:1c.0 PCI bridge: Intel Corporation Device 1e10 (rev c4)
00:1c.1 PCI bridge: Intel Corporation Device 1e12 (rev c4)
00:1c.2 PCI bridge: Intel Corporation Device 1e14 (rev c4)
00:1d.0 USB Controller: Intel Corporation Device 1e26 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Device 1e59 (rev 04)
00:1f.2 SATA controller: Intel Corporation Device 1e03 (rev 04)
00:1f.3 SMBus: Intel Corporation Device 1e22 (rev 04)
01:00.0 VGA compatible controller: ATI Technologies Inc Device 6841
01:00.1 Audio device: ATI Technologies Inc Device aa90
07:00.0 Network controller: Atheros Communications Inc. AR9485 Wireless Network Adapter (rev 01)
08:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5209 (rev 01)
09:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 07)
bash-4.1# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

bash-4.1# ifconfig
eth0 Link encap:Ethernet HWaddr 30:f9:ed:b8:d2:3c
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:42 Base address:0xc000

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:480 (480.0 B) TX bytes:480 (480.0 B)

sycamorex 08-30-2012 04:10 AM

Have a look at this thread:

Looks like this wifi chipset is supported out of the box in -current (slackware14). Either follow the steps in that thread or wait for Slackware 14.

Cassie 08-30-2012 07:02 AM

Is the wlan active? Try

ifconfig wlan0 up

cynwulf 08-30-2012 08:11 AM

AR9485 is probably not supported by the version of ath9k in the 2.6.37 kernel. Try building a newer kernel, 3.2 is likely to be a safe bet.

na2th 08-30-2012 11:23 PM

Whenever I try the wlan0 up it says that cannot find device. I tried upgrading the kernel, but got a Kernel Panic ( yay! ). I decided to switch to Ubuntu and wait for Slackware 14 to come out

ReaperX7 08-31-2012 12:00 AM

First off... If you're using Slackware 13.37 upgrading the kernel should really be done by just upgrading the whole system to -Current as simply updating the kernel might not do it due to all the new tools used now.

Switch the slackpkg mirror to a -current tree and run it in this order:

slackpkg update
slackpkg install-new
slackpkg upgrade-all
slackpkg clean-system

the upgrade-all and install-new options may need to be ran two or three times.

Also, you may want to change the slackpkg configuration script to download all the package prior to installation.


If your network card doubles as a Bluetooth adapter (built-in bluetooth) you HAVE to turn on the bluetooth module and enable the bluetooth daemon. If you disable the bluetooth on a hybrid wifi + bluetooth card, it often disables the whole card.

vtel57 08-31-2012 12:28 PM

Umm... upgrading via slackpkg is a bit more involved than that and CAUTION should be exercised when trying to upgrade that way.

Just a little warning...

All times are GMT -5. The time now is 03:23 AM.