-   Linux - Wireless Networking (
-   -   Wireless set-up on SuSE 10.2 with BT Voyager 1040 (Broadcom BCM4306) PCI Card (

ibovey 02-05-2007 04:07 PM

Wireless set-up on SuSE 10.2 with BT Voyager 1040 (Broadcom BCM4306) PCI Card
I am relatively new to the wonderful world of SuSE Linux but feel that it could succeed as a real alternative to the exploiting methods of Microsoft. However I have a Broadcom BCM4306 (BT Voyager 1040) PCI Card and seem to have tried everything. If I can get wifi up and running I WILL bin Windows.

1) I am running SuSE Linux 10.2
2) I have blacklisted the BCM43xx Linux stuff
3) I have installed NDISWrapper 1.34
4) I copied the windows driver (bcmwl5.inf and bcmwl5.sys) files from my working Windows XP machine.
5) I ran ndiswrapper -i ..../bcmwl5.inf
6) ndiswrapper -l says "driver installed", and "device present"
7) I deleted the Linux installed network card from YaST, then re-started YaST.
8) I added a new Wireless card with Module : ndiswrapper

Please help!

I am starting to get desperate now and would really like to have a fully functional and connected Linux installation.

jmbrink26 02-05-2007 09:34 PM


Ok, so you got SuSE running w/ a card using the Broadcomm 43xx chip.

So, now when you said you deleted the card from Yast, what are you referring to? Because that card should be showing up in yast.

When you run /sbin/ifconfig, what output do you get?

Is the wlan card assigned to a interface name like eth0, or wlan0?

ibovey 02-06-2007 10:41 AM


When I do /sbin/ifconfig I get eth0 and lo, but no wlan0.

With reference to previous message I deleted the card that Linux placed automatically from Yast, and I added a new one with device type wireless, module name ndiswrapper and put my WPA-PSK passphrase in.

I look forward to your thoughts.


jmbrink26 02-07-2007 10:08 AM

Hi, good to hear back.

Ok, so when you run /sbin/ifconfig and look at eth0 is that representing the wifi card? Or do you have a wired card connected to a Cat 5 cable connected to it?

And when you configured the drivers using ndsiwrapper, did you create an alias for the card? I know it's one of the steps during the config. It's an argument line like:

ndiswrapper driver.inf -a

Or something like that.

Let me know.



ibovey 02-07-2007 01:06 PM


I think eth0 is representing the wifi card (it says hardware address .....) and the Linux entry in YaST (that I deleted prior to trying to setting-up the wireless NDISWrapper entry) made reference to the Wifi card.

I am definately not connecting via cable as I do not have an ethernet RJ45 socket on the back of my PC.

Regarding the alias I have not seen any instructions telling me to type "ndiswrapper driver.inf -a". I have only installed the driver with ndiswrapper -i /../driver.inf then modprobe ndiswrapper.

Hope this helps. I hope you can help me crack this as I am keen to see a fully working Linux installation, and hence bin WinXP.

Lets keep this thread going until we reach a conclusion.

Many Thanks


neolithic 03-10-2007 11:29 AM

me too!
I also own a bt voyager 1040 wifi card which is a Broadcom BCM4300 series and I have been trying various distros under VMware very good way to try linux and other OS'es) I want to do a full install on my new 4.2 Ghz AMD64 dual core setup of Suse 10.2 64bit which runs like a dream under VMware as it takes care of most of the driver issues as it thinks it running on a hard wired network even though its sat under Windows Vista 32 bit, yeah you can run anything on anything with VMware! On my previous pc I managed to install the Broadcom and it worked at least until the next reboot when it ceased, please help me to convert to Linux for once and for all I am a windows web developer but I have seen the light and its a penguin! I have the luxury of 5 pc's to play with at home

jmbrink26 03-10-2007 11:57 PM

Hi Y'all,

So yes, use the argument -i to install the .inf file with ndiswrapper. Then use the -m arument to use the mobprobe, which should create the eth0 or wlan0 alias.

Hope this helps. Let me know if you continue to have issues ;)

All times are GMT -5. The time now is 11:38 PM.