LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 05-28-2010, 09:16 PM   #1
Elixer
Member
 
Registered: Dec 2009
Location: Massachusetts, USA
Distribution: Debian 8 64
Posts: 121

Rep: Reputation: 16
wireless not starting about 75 % of time at boot


I have a Linksys WMP54G wirelesss card which I believe to be a Ralink RT2561. My primary OS is Debian Lenny. More often than not wireless will not initialize at boot. Sometimes requireing 3 or more reboots before it starts. It is just realy annoying. If I boot WinXP or Xandros 4.5OCE on the same box and hardware, the wireless always starts. I think the key here is the time allowed to initialize during boot. Win XP, well boots like a turtle, (no a slug) thus giving plenty time. Xandros not much faster befor GUI is up and running. Debian Lenny boots like lightning but seldom initializes wireless. I have posted a thread requesting help on this back on 2-17-10 and recieved some help but no solution.

http://www.linuxquestions.org/questi...ghlight=Elixer

I would like if possible information on how to alter the time allowed at boot for wireless card to initialize. As a second less acceptable patch for this problem perhaps some code I can type in at shell to initialize wireless card in circumstance in does not start so I do not have to keep rebooting just to get online.

Any help appriciated. Thanks, Jon
 
Old 05-29-2010, 06:06 PM   #2
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 21,163

Rep: Reputation: 4125Reputation: 4125Reputation: 4125Reputation: 4125Reputation: 4125Reputation: 4125Reputation: 4125Reputation: 4125Reputation: 4125Reputation: 4125Reputation: 4125
A while back I had a similar issue with Ubuntu. What mine problem was the init scripts started the wireless before the network was completely ready.
So I merely moved the start script later in the sequence. You could also move it to rc.local or similar - that way you could feel better about putting a delay in if needed (probably not).
If Debian are using upstart these days you could put a dependancy (on the network) before allowing the wireless to start.
 
Old 05-31-2010, 08:15 PM   #3
Elixer
Member
 
Registered: Dec 2009
Location: Massachusetts, USA
Distribution: Debian 8 64
Posts: 121

Original Poster
Rep: Reputation: 16
Here is ther last of about 250 lines of dmesg. It apperars it is trying to initialize wireless hardware at the end. This report is obviosly when it does not start. I assume the start script is near or at the end as it is at the end of the dmesg report.

Still new to linux. Would need some faily detailed help to acomplish the latter of the 3 suggestions.

No way to just type a command at shell prompt to start up wireless lan if it fails to start ar boot?





4.067537] NET: Registered protocol family 10
[ 14.068090] lo: Disabled Privacy Extensions
[ 14.239249] lp0: using parport0 (interrupt-driven).
[ 14.256425] ppdev: user-space parallel port driver
[ 17.462217] firmware: requesting rt2561s.bin
[ 17.573374] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 17.694992] eth0: link down
[ 17.695239] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 20.138248] nvidia: module license 'NVIDIA' taints kernel.
[ 20.393179] ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 16
[ 20.393191] PCI: Setting latency timer of device 0000:01:00.0 to 64
[ 20.393393] NVRM: loading NVIDIA UNIX x86 Kernel Module 190.53 Tue Dec 8 18:51:41 PST 2009
[ 77.710965] ADDRCONF(NETDEV_UP): wlan0: link is not ready
jon@debianlenny:~$
 
Old 06-01-2010, 02:21 AM   #4
rkski
Member
 
Registered: Jan 2009
Location: Canada
Distribution: CentOS 6.3, Fedora 17
Posts: 247

Rep: Reputation: 51
If having problems starting wlan at boot, you can disable the boot start in your distro, and start it at the command line whenever you want:

Code:
ifup wlan0
or:

Code:
ifconfig wlan0 up
...
dhclient wlan0
 
Old 06-13-2010, 09:01 PM   #5
Elixer
Member
 
Registered: Dec 2009
Location: Massachusetts, USA
Distribution: Debian 8 64
Posts: 121

Original Poster
Rep: Reputation: 16
Tried both, neither seems to work. Is there a command to just retry brining up the wlan0 if it doeds not start up at boot? Thanks, Jon
 
Old 06-14-2010, 03:51 AM   #6
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
Hi.
Can you post here output of:
chkconfig | grep net


Thanks.
 
Old 07-07-2010, 09:46 PM   #7
Elixer
Member
 
Registered: Dec 2009
Location: Massachusetts, USA
Distribution: Debian 8 64
Posts: 121

Original Poster
Rep: Reputation: 16
jon@debianlenny:~$ su
Password:
debianlenny:/home/jon# chkconfig | grep net
bash: chkconfig: command not found
debianlenny:/home/jon#

Something wrong with syntax I guess
 
Old 07-08-2010, 01:49 AM   #8
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
I suggest you to read through manuals for Debian and find there how to disable interface activation on boot.
On my OpenSuse I have:
Code:
       STARTMODE {manual*|auto|hotplug|ifplugd|nfsroot|off}
              Choose when the interface should be set up.
              manual Interface  will be set up if ifup is called manually (without option boot or
                     hotplug)
              auto   Interface will be set up as soon as it is available (and service network was
                     started).  This  either happens at boot time when network is starting or via
                     hotplug when a interface is added to the system (by adding a device or load-
                     ing  a driver). To be backward compliant onboot, on and boot are aliases for
                     auto.
              hotplug
                     This mode is nearly the same as auto.  The difference between auto and  hot-
                     plug is that the latter does not make rcnetwork fail if the interface cannot
                     be brought up.
              ifplugd
                     The interface will be controlled from ifplugd. At initial ifup only  ifplugd
                     will  be started for this interface. Then if ifplugd detects a link if calls
                     ifup  again  which  finally  sets  the  interface  up.  See  also   variable
                     IFPLUGD_PRIORITY below.
              nfsroot
                     Nearly like auto, but interfaces with this startmode will never be shut down
                     via rcnetwork stop.  ifdown <interface> still works. Use this when you use a
                     root filesystem via network.
              off    Will never be activated.

And second, network service has its own config, there is:
## Type: integer
## Default: 30
#
# Some interfaces need some time to come up or come asynchronously via hotplug.
# WAIT_FOR_INTERFACES is a global wait for all mandatory interfaces in
# seconds. If empty no wait occurs.
#
WAIT_FOR_INTERFACES="30"


On Debian should be something the same.

Last edited by nimnull22; 07-08-2010 at 01:51 AM.
 
Old 07-20-2010, 10:02 PM   #9
Elixer
Member
 
Registered: Dec 2009
Location: Massachusetts, USA
Distribution: Debian 8 64
Posts: 121

Original Poster
Rep: Reputation: 16
I am still quite new, Where would I find the network config. Thanks, Jon
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting programs at boot time. glore2002 Slackware 8 07-10-2008 08:18 PM
starting hdparm at boot time moljac024 Linux - General 9 02-13-2008 05:04 AM
Starting eth0 at boot time ? Antonius Linux - Newbie 1 01-19-2005 07:27 PM
starting applications at boot time jogurt666 Debian 4 01-21-2004 03:39 AM
starting services at boot-time noisybastard Linux - Newbie 2 11-09-2003 05:13 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 02:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration