-   Linux - Wireless Networking (
-   -   wireless nic work w/o encryption, but not wpa (

coho66 02-20-2007 04:10 PM

wireless nic work w/o encryption, but not wpa
Hello all,

I"m new to linux, although I have played with an earlier version of mandrake and dabbled in unix, but this was many moons ago. So i am comfortable with command line interface, but I don't remember any of the linux commands or pertinent tools or software to use.

Anyways, I currently have an issue with trying to enable wpa with my trendnet tew-424 usb wireless nic (uses zd1211 chipset) in mandriva 2007 (powerpack).

I can get the network/internet to work fine without any encryption enabled, but I can't seem to connect to the internet while enabling wpa, regardless of whatever settings i've tried? The odd thing is i can obtain a network address using wpa through the wireless manager, but still no dice with eeenturnet access. Any suggestions on how to troubleshoot this process? All advice is appreciated.



JimBass 02-20-2007 09:22 PM

You need a program called wpa_supplicant to use wpa protected wifi. One of the interesting features of wpa is that you usually do get an address even without the wpa passkey, but you can't handle the encryption and can't browse.

Use your distro's package manager to search and install wpa_supplicant (may also be called wpa-supplicant or wpasupplicant), or install it from source.


coho66 02-20-2007 11:00 PM

yup, wpa supplicant is installed...

but, still no dice???

in addition to regular dhcp, I tried manually configuring an ip and then it says "associated with eth2" upon successful connection with the router...and the browser will attempt to look for the domain i choose but never reaches a site...the signal strength is pitiful and the connection disconnects

All times are GMT -5. The time now is 03:28 PM.