LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 12-03-2002, 04:38 PM   #1
SkydiverFL
LQ Newbie
 
Registered: Dec 2002
Posts: 8

Rep: Reputation: 0
Unhappy Wireless NIC Config Help -- PLEEEEASE!


Okay, I've RTFMed, read threads, and I'm about 99.9% closer. Unfortunately, I just can't seem to get my Linksys WPC11 wireless NIC configured. I'm incredibly green to Linux, so I am confiden that I'm just screwing up the commands / steps.

Here's my config...

Toshiba Satellite 5005-S507
Internal Intel PRO 100 VE Embedded NIC on eth0
Linksys WPC11 v3.0 Wireless PCMCIA NIC
Red Hat v8.0 (kernel 2.4.18-18.8.0)

If I do a lsmod, I can see the following modules loaded...

prism2_cs
p80211
... a couple of others, however, it appears the right stuff is loaded

If I restart pcmcia, it successfully shuts down and starts up with two annoyingly pleasent beeps.

Again, my problem is that I simply don't know how to configure it. Can someone give me some IDIOT PROOF instructions? =(

Sorry to be a pain. Thanx to anyone that can help.

R/S
Fred
 
Old 12-03-2002, 05:25 PM   #2
KevinJ
Member
 
Registered: Feb 2001
Location: Colorado Springs, CO
Distribution: Redhat v8.0 (soon to be Fedora? or maybe I will just go back to Slackware)
Posts: 857

Rep: Reputation: 30
what does "ifconfig -a" show?

Have you run "netconfig"?

What does "iwconfig" show?

-KevinJ
 
Old 12-03-2002, 05:27 PM   #3
SkydiverFL
LQ Newbie
 
Registered: Dec 2002
Posts: 8

Original Poster
Rep: Reputation: 0
Working... somewhat...

Well, it's working somewhat. I can get a DHCP served IP address. I'm still a little confused, however.

I yanked my CAT5 from the embedded NIC and could not browse anything. I have tried getting to the config page of my WAP by using the IP address and could not get anywhere. If I do a "route" command I can see that both "eth0" and "wlan0" have the same information and the default route is set to "eth0."

Anyone know where I can configure this? I need to be able hit wlan0 after trying eth0. Even better would be to have this dynamically set based on what interfaces were available at boot.
 
Old 12-03-2002, 05:45 PM   #4
KevinJ
Member
 
Registered: Feb 2001
Location: Colorado Springs, CO
Distribution: Redhat v8.0 (soon to be Fedora? or maybe I will just go back to Slackware)
Posts: 857

Rep: Reputation: 30
my wireless card IS eth0.

Can you run the commands I posted up top?

Also run an "lsmod".

-Kevin
 
Old 12-03-2002, 06:03 PM   #5
SkydiverFL
LQ Newbie
 
Registered: Dec 2002
Posts: 8

Original Poster
Rep: Reputation: 0
RESULTS OF "ifconfig -a":
eth0 Link encap:Ethernet HWaddr 00:00:39:40:C0:F0
inet addr:192.168.2.100 Bcast:192.168.2.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:174 errors:0 dropped:0 overruns:0 frame:0
TX packets:191 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:124290 (121.3 Kb) TX bytes:24703 (24.1 Kb)
Interrupt:6

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:72 errors:0 dropped:0 overruns:0 frame:0
TX packets:72 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4694 (4.5 Kb) TX bytes:4694 (4.5 Kb)

wlan0 Link encap:Ethernet HWaddr 00:06:25:0B:94:4B
inet addr:192.168.2.103 Bcast:192.168.2.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1274 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:406606 (397.0 Kb) TX bytes:336 (336.0 b)
Interrupt:3 Base address:0x100


RESULTS OF "iwconfig":
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11-b ESSID:"Marbella Software, Inc." Nickname:"Marbella Software, Inc."
Mode:Managed Frequency:2.437GHz Access Point: 00:06:25:5D:93:79
Bit Rate:11Mb/s Tx-Power:2346 dBm
Retry min limit:8 RTS thrff Fragment thrff
Encryption keyff
Link Quality:78/92 Signal level:-40 dBm Noise level:-96 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


RESULTS OF "lsmod":
Module Size Used by Not tainted
sr_mod 18168 0 (autoclean)
soundcore 6532 0 (autoclean)
prism2_cs 74320 1
autofs 13348 0 (autoclean) (unused)
p80211 22184 1 [prism2_cs]
ds 8712 2 [prism2_cs]
yenta_socket 12960 2
pcmcia_core 54784 0 [prism2_cs ds yenta_socket]
eepro100 22264 1
iptable_filter 2412 0 (autoclean) (unused)
ip_tables 14936 1 [iptable_filter]
ide-scsi 10512 0
scsi_mod 107240 2 [sr_mod ide-scsi]
ide-cd 33608 0
cdrom 33696 0 [sr_mod ide-cd]
mousedev 5524 1
keybdev 2976 0 (unused)
hid 22244 0 (unused)
input 5920 0 [mousedev keybdev hid]
usb-uhci 26188 0 (unused)
usbcore 77024 1 [hid usb-uhci]
ext3 70368 1
jbd 52212 1 [ext3]
 
Old 12-03-2002, 06:05 PM   #6
SkydiverFL
LQ Newbie
 
Registered: Dec 2002
Posts: 8

Original Poster
Rep: Reputation: 0
I think my issue is now with my routing. If I do a "route" I can see the interface, however, the default is set to "eth0." Is there any way to add the "wlan0" to the loop so that if "eth0" is not connected that "wlan0" will be attempted?

RESULTS OF "route":
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.2.0 * 255.255.255.0 U 0 0 0 eth0
192.168.2.0 * 255.255.255.0 U 0 0 0 wlan0
127.0.0.0 * 255.0.0.0 U 0 0 0 lo
default 192.168.2.1 0.0.0.0 UG 0 0 0 eth0
 
Old 12-03-2002, 06:16 PM   #7
SkydiverFL
LQ Newbie
 
Registered: Dec 2002
Posts: 8

Original Poster
Rep: Reputation: 0
Okay, I figured out the route command and can add a default gateway throuth my wireless NIC, but I had to remove the one for "eth0" to get it to work.

What I would ultimately want is the following...

1. A gateway route set up through "eth0" AND "wlan0"; and,
2. The ability to use "wlan0" only if "eth0" is not present.

Also, I am concerned that if I simply yank the CAT5 after "wlan0" is working properly, that I will run into problems when I reboot and "eth0" is being initialized.
 
Old 12-03-2002, 06:19 PM   #8
SkydiverFL
LQ Newbie
 
Registered: Dec 2002
Posts: 8

Original Poster
Rep: Reputation: 0
I have tried to add "wlan0" with a higher metric, and it did not work...

Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.2.0 * 255.255.255.0 U 0 0 0 eth0
192.168.2.0 * 255.255.255.0 U 0 0 0 wlan0
127.0.0.0 * 255.0.0.0 U 0 0 0 lo
default 192.168.2.1 0.0.0.0 UG 0 0 0 eth0
default 192.168.2.1 0.0.0.0 UG 1 0 0 wlan0
 
Old 12-03-2002, 06:27 PM   #9
KevinJ
Member
 
Registered: Feb 2001
Location: Colorado Springs, CO
Distribution: Redhat v8.0 (soon to be Fedora? or maybe I will just go back to Slackware)
Posts: 857

Rep: Reputation: 30
maybe its setting eth0 as the default because its a lower IP addy? Not sure. What happens to the routing table if you do a "service network restart" after eth0 is disconnected?

I don't think you can have "multiple default gateways" if that is what you are trying to do. Maybe if you use some sort of load balancing software?

-KevinJ
 
Old 12-03-2002, 06:52 PM   #10
KevinJ
Member
 
Registered: Feb 2001
Location: Colorado Springs, CO
Distribution: Redhat v8.0 (soon to be Fedora? or maybe I will just go back to Slackware)
Posts: 857

Rep: Reputation: 30
What you need is to use a fault tolerant solution of some kind. Where you have a 3rd "virtual" address. This is commonly used in highly available systems to provide redundancy. Basically, there is address translation going on from the virtual NIC through one of the real NIC's.

Take a look at this:
http://www.ibiblio.org/pub/Linux/ALP...y-HOWTO-8.html

-KevinJ
 
Old 12-03-2002, 07:28 PM   #11
SkydiverFL
LQ Newbie
 
Registered: Dec 2002
Posts: 8

Original Poster
Rep: Reputation: 0
Geesh! I think I'll pass. I'm not experianced with Linux enough to throw anything else in the mix.

As it stands, life is good. I added the second default gateway using the wireless NIC and setting it to a higher metric. With the CAT5 cable plugged in, when the network comes up, everything flows through the 100 base T connection. Without the wired connection, when the network comes up, everything flows through the wireless NIC... that's good enough for me!

Thanx, guys, for all of your help! =)

Now, if I could only get my sound to work. Guess I'll go post a message in the Hardware forum... ;-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless nic config phoneix Mandriva 28 08-14-2005 11:54 AM
Don't know how to config NIC - HELP! Rasputin Linux - Networking 7 02-26-2004 11:21 PM
Help, Nic Config Illusion *BSD 4 07-15-2003 10:48 AM
Help with NIC config newbiejlove Linux - Hardware 7 04-04-2003 05:38 PM
I need help pleeeease penguin Linux - Security 1 07-07-2001 04:09 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 01:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration