LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (https://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   Wireless network on eth1 diabled Ethernet eth0 and eth0 never comes back (https://www.linuxquestions.org/questions/linux-wireless-networking-41/wireless-network-on-eth1-diabled-ethernet-eth0-and-eth0-never-comes-back-231837/)

tadatoshi 09-17-2004 12:28 PM

Wireless network on eth1 diabled Ethernet eth0 and eth0 never comes back
 
I'm trying to setup Wireless Network.
Installing and loading the driver seemed to have worked.
But after that, I've encountered series of problems.

1. In /etc/sysconfig/network-scripts, I added ifcfg-eth1 with the same data as in ifcfg-eth0 except for TYPE=Wireless. Then executed ifup eth1.
Error message said something like MAC address is not valid.
2. Executed ifdown eth0. ifup eth1 still displayed the same message.
3. In ifcfg-eth1, I removed MAC address at HWADDR=.
Now error message was something like some bite cannot be assigned.
4. I disconnected ethernet cable. ifup eth1 displayed error message like device is not found or disconnected or something.
5. I connected ethernet cable again. I executed ifup eth0. But eth0 was not up this time.
6. Removed ifcfg-eth1 and executed ifup eth0. And still eth0 was down.
7. Put back ifcfg-eth1 and executed ifup eth1. Error message was something like , "Check if cable is connected."
8. I opened Gnome Network Configuration and tried to activate them. But same error messages were displayed.
9. Restarted the computer. Fedora Core 2 detected a new network device. I selected "Configure" and let it configure it. Then eth2 with wireless network driver with TYPE=Ethernet was added. It was down. eth1 was not associated with the wireless network driver any more.
10. Removed ifcfg-eth2 and ifcfg-eth1 and up back the original ifcfg-eth1. Restarted the machine. eth2 was not added this time.
11. eth0 was down but eth1 was up and I can access Internet through Wireless network. But I cannot use Ethernet to access Internet any more.

How can I make Ethernet connection to work again while keeping the functioning Wireless network connection setup?

tadatoshi 09-17-2004 12:42 PM

P.S.

It turned out that the it is using Ethernet connection through eth1 instead of Wireless connection.
But ifcfg-eth1 has still TYPE=Wireless (ifcfg-eth0 has TYPE=Ethernet).
What is going on?...

alphaproject 09-17-2004 01:15 PM

you could delete eth1, and create a new eth0 with type=ethernet

otherwise, i dont have a single clue.

tadatoshi 09-19-2004 04:33 PM

I have booted the system. And now eth0 is up with Ethernet connection and eth1 is down.
More over, wireless device is not recognized.
How can I set up wireless connection?

alphaproject 09-23-2004 05:57 PM

just go to system settings, network device control and just create the wireless connection


All times are GMT -5. The time now is 03:33 AM.