-   Linux - Wireless Networking (
-   -   Wireless network manager using WPA encryption (

dgranger 06-15-2006 12:19 PM

Wireless network manager using WPA encryption
Can anyone recommend a wireless network manager for Linux that uses both a graphical user interface AND handles WPA encryption?
Many thanks!

Don Granger

osbie 06-15-2006 06:42 PM

In KDE 3.5.1 + Use the default Knetworkmanager.

to adjust wpa select 'conect to other wireless network' it contains all the options wep, wpa (psk,esk?), wpa2 (psk,esk) aes or tksomthing encription etc. The onl complaint is that the level bars are a bit flakey, right now iwconfig shows 94/100 but i have 2 out of 4 bars. that will probably change next boot.

dgranger 06-16-2006 10:26 AM

Wireless network manager using WPA encryption
Many thanks! I had no idea that the answer was so close at hand. It's good to know that WPA is readily available on the KDE desktop.


Limbonic 06-22-2006 03:33 AM

First of all thanks for the hint that led me to the WPA option.
Unfortunately it looks like knetworkmanager tries to connect to my wlan, but at 28% it freezes for some seconds and after that says "knetworkmanager is disconnected" or something like that.
Does anyone know possible reasons?
Thanks in advance.

osbie 06-22-2006 11:09 AM

I will say the WEP config always works-no probs.. when using WPA i too get the occasional hiccup, i.e. stopping at 28% then works on second attempt. i also set this up in yast,what difference that makes...? make sure to do the latest upgrades if you haven't, it may help ( i've had fewer problems lately after a couple of them.

sometime this stuff is so quirky, then it just works. when i first set this up i had to always go to 'connect to other network' and manualy do it each time, just clicking on it from the list would never work. Now it connects automatically. Go figure. don't know if this helps at all ( bit of a Fonzy fix) just kep at it, it will work.

Cogar 06-22-2006 11:22 AM

IIRC, only SUSE uses YaST. Although setting up a wireless network using YaST in SUSE 10.0 is straightforward (not so sure about 10.1 since I have not tried it), it is not so straightforward in other distributions. For example KNetworkManger does a decent but not stellar job in Kubuntu.

dgranger 06-23-2006 10:10 AM

I discovered the same problem reported by Limbonic--KNetworkManager "freezes" at 28% and then disconnects--using Kubuntu 6.06 with an Artech RT 2500 wireless chip. I'd like an answer to the question he raises, too, as I was unable to get beyond this point.


Limbonic 06-25-2006 10:20 AM

Looks like we have a problem, dgranger... :scratch:
If we knew how to have a look at the log file (that possibly exists), we could try to find out, where the troubles might come from...
I guess we both need a solution and I don't want to buy a cable...

rh-penguin 09-18-2006 07:05 PM

'NetworkManager' does not work most of the time for WLAN(thats y it stops at 28%).you have to use 'ifup'. The thing is....once u do configure it with 'ifup' KNetworkManager shuts down.....i've bin told that then the WLAN needs to be configured via Shell/Terminal..... have a loook....type "man iwconfig".
I myslef am stuck.....i type: iwconfig essid MYESSID and get stuff like:
Error : unrecognised wireless request "MYESSID"
maybe someone could help me out? i must be typing the command wrong or something.......

Another thing you can use is: KWiFiManager but the only encryption it seems to accept is WEP....which is quite crap..... (easy to crack)

dgranger 09-18-2006 11:58 PM

wireless network manager using WPA encryption
So, the concensus seems to be that using WPA for wireless networking within a graphic interface (GUI) is
still a crying need. Perhaps someone in the Linux community will take this on as the latest challenge to making Linux competitive on the desktop. I hope so!

NeroZero2 09-19-2006 01:35 AM

Good Morning! This is exactly why I have posted my question in the first place! It hangs on 28% and then own is to use the alternative method striking up networks when YAST asks you... did you try wpa_gui instead for wpa connections?

Limbonic 09-20-2006 01:15 AM

I tried wpa_config, wpa_gui, ifup, and the KNetworkManager - they all sucked.
After weeks spent on this problem, I was told that my networking chipset could not be brought to work under Linux, though it is a PrismGT. There seem to be certain known incompatibilities with my PCMCIA card and probably buying another card would help.
Anyway - there would still be the chance that wpa won't work on another card neither, so I bought 20 meters of networking cable and things worked out fine in no time... :rolleyes:

dgranger 09-20-2006 09:52 AM

Me, too
Limbonic and I seem to have tried the same alternatives with the same results. CAT5 cable does solve the problem, but I still want wireless with WPA encryption to be as easy to set up in Linux as it is in W*ND*WS.

odcheck 09-20-2006 10:03 AM



Use this command
iwconfig --version

to see which version of Wireless-Tools you use.

WPA is included or lets say improved alway with the latest Version.
The main features of the latest beta is WE-21 support (long/short retry, power saving level, modulation), enhanced command line parser in iwconfig, scanning options, more WPA support and more footprint reduction tricks.

jspaar 09-20-2006 12:23 PM


Originally Posted by dgranger
So, the concensus seems to be that using WPA for wireless networking within a graphic interface (GUI) is
still a crying need. Perhaps someone in the Linux community will take this on as the latest challenge to making Linux competitive on the desktop. I hope so!

As a datapoint: I use WPA "personal" with NetworkManager on Fedora, and it "just works" for me.

(Atheros chipset card, madwifi driver, linksys AP, FC5 with current updates.)

All times are GMT -5. The time now is 06:57 PM.