LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 05-20-2008, 07:13 AM   #1
abodana
LQ Newbie
 
Registered: Dec 2004
Location: Saudi Arabia
Distribution: Fedora
Posts: 20

Rep: Reputation: 0
Wireless netowrk card on FEDORA 9 ?


Gentlemen,

I have tried to install my wireless network card using the following instruction "I got these instructing from earlier post "bob""

- I do not know is my wireless card configured correctly or not??
How to check??

- How to connect/search for a wireless network?

#1
How to Install Wireless network card in FEDORA

1. copy two files from the windows driver, the .inf file and the .sys file to ndiswrapper home directory
2. Install ndiswrapper , using the command " yum install ndiswrapper "
3. ndiswrapper -i (driverfile).inf
4. ndiswrapper -l
This time, if all went well, you should see the comment:
(driver) installed; device present
5. modprobe ndiswrapper

==========================================================
#2
My wireless network configuration/installation

[root@localhost ndiswrapper-1.52]# ll -tr
total 6308
drwxr-xr-x 2 1100 1100 4096 2008-02-03 05:45 utils
-rw-r--r-- 1 1100 1100 1410 2008-02-03 05:45 README
-rw-r--r-- 1 1100 1100 2889 2008-02-03 05:45 ndiswrapper.spec
-rw-r--r-- 1 1100 1100 3462 2008-02-03 05:45 ndiswrapper.8
-rw-r--r-- 1 1100 1100 2679 2008-02-03 05:45 Makefile
-rw-r--r-- 1 1100 1100 881 2008-02-03 05:45 loadndisdriver.8
-rw-r--r-- 1 1100 1100 2762 2008-02-03 05:45 INSTALL
drwxr-xr-x 2 1100 1100 4096 2008-02-03 05:45 driver
-rw-r--r-- 1 1100 1100 26563 2008-02-03 05:45 ChangeLog
-rw-r--r-- 1 1100 1100 116 2008-02-03 05:45 AUTHORS
-rwxr-xr-x 1 root root 119811 2008-05-20 23:58 w29n51.INF
-rwxr-xr-x 1 root root 14821 2008-05-20 23:58 w29n51.cat
-rwxr-xr-x 1 root root 2938112 2008-05-20 23:58 w29n50.sys
-rwxr-xr-x 1 root root 3298432 2008-05-20 23:58 w29n51.sys

[root@localhost ndiswrapper-1.52]# ndiswrapper -i w29n51.INF
installing w29n51 ...

[root@localhost ndiswrapper-1.52]# ndiswrapper -l
w29n51 : driver installed
device (8086:4220) present (alternate driver: ipw2200)

[root@localhost ndiswrapper-1.52]# modprobe ndiswrapper

[root@localhost Documents]# lsmod
Module Size Used by
ndiswrapper 159380 0



Appreciate you help...
 
Old 05-20-2008, 09:45 AM   #2
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
I'd start off this way:

1) test if there is a driver loaded already, or if the card works.
Code:
su -
iwlist wlan0 scan
exit
First it asks for root password, then tries to scan networks, then exits the root shell. Sometimes the interface is not wlan0 but eth1 instead (when eth0 would be the wired card), so try switching it if this doesn't work with wlan0. It should either print information about available networks (card and driver work), say that interface doesn't support scanning (driver doesn't work or it's not the right device) or drop an error of some sort, in which case the interface is wrong or driver doesn't work.

2) get a working driver - first find out what chipset your card has, then search the web for what driver that chipset uses, and if there is a native Linux driver somewhere. See
Code:
lspci
for information on your card - the model is what you're after. Once you know that, search for it on the web and try to find native Linux driver name.

3) if there is no native Linux driver for that model..then obtain Windows drivers for that exact model from somewhere. You need a somename.inf and somename.sys files from the driver: if it's a .cab file or something else that's archived, you need to extract it first to get your hands on the two files. Then install ndiswrapper - either trough your system's package manager or compile from source code. When it's installed, open a terminal, change working directory to the directory where the .sys and .inf files are, and install the drivers using ndiswrapper:
Code:
su -
modprobe ndiswrapper
cd /path/to/driver/files/
ndiswrapper -i drivername.inf
ndiswrapper -l
exit
The second ndiswrapper command should tell you that driver is installed and hardware is present. That means the thing should work; anything else means the driver is wrong or there were some other problems (maybe a bad ndiswrapper installation, wrong versions, ...)

After the ndiswrapper driver is installed, edit your /etc/modules.conf or equivalent and have it automatically load module 'ndiswrapper' at boot (otherwise you need to use modprobe each time yourself). After this return to step 1).

Once you see some networks, connect to them. Easiest method is to use NetworkManager or equivalent - see if your panel has a network applet you can use (click it; is there anything about wireless networks?), or if there is a (wireless) network connection manager in your menu somewhere. Use those if you can; namely just enter access point name (or scan for it), encryption type used on the access point, passphrase and hit connect. If you don't have graphical tools, you can use iwconfig as root to connect to non-secured or WEP-secured networks, or wpa_supplicant to connect to wired, wireless, non-secured, WEP-secured or WPA-secured networks (basically anything you need) - you can use wpa_passphrase to generate a basic configuration block for the wpa_supplicant.conf configuration file.

From your post it seems like your card could use ipw2200 driver, which should already be in kernel. In this case there is no need to use ndiswrapper, so you can just as well remove it (at least remove the Windows driver from ndiswrapper); if you have both native driver in the kernel and ndiswrapper, the two are likely to interfere causing the card possibly not work at all (I've been in that situation). If you have two drivers, you have to choose which one to use and ditch the other to make things work smoothly. If you can use ipw2200 driver, use it and not ndiswrapper - ndiswrapper should be used only when there is no other possibility, because it just makes things more complex than they need to be.

Last edited by b0uncer; 05-20-2008 at 09:48 AM.
 
Old 05-20-2008, 01:03 PM   #3
abodana
LQ Newbie
 
Registered: Dec 2004
Location: Saudi Arabia
Distribution: Fedora
Posts: 20

Original Poster
Rep: Reputation: 0
Thanks for your reply,

i Have read your post carefully , it seems my configuration is fine,, see the detail below ,
The only make me confuse is the scanning?? it did not give any output?


[root@localhost ~]# lspci | grep -i net

06:05.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)
06:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)

[root@localhost etc]# ndiswrapper -l
w29n51 : driver installed
device (8086:4220) present (alternate driver: ipw2200)

[root@localhost etc]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 unassociated ESSIDff/any
Mode:Managed Channel=0 Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power=20 dBm Sensitivity=8/0
Retry limit:7 RTS thrff Fragment thrff
Encryption keyff
Power Managementff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

pan0 no wireless extensions.

ppp0 no wireless extensions.

[root@localhost etc]# lsmod | grep -i wr
ndiswrapper 159380 0

[root@localhost etc]# iwlist eth1 scan
eth1 No scan results

[root@localhost etc]# iwlist scanning
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

eth1 No scan results

pan0 Interface doesn't support scanning.

ppp0 Interface doesn't support scanning.



Please advise me what to do ?

I really appreciate your help
 
Old 05-21-2008, 07:19 AM   #4
abodana
LQ Newbie
 
Registered: Dec 2004
Location: Saudi Arabia
Distribution: Fedora
Posts: 20

Original Poster
Rep: Reputation: 0
Hello Gentlemen,

My wireleess cards is working fine , as i am able to find 4 wreiless netowrk in my area using the cmd "iwlist eth1 scan".

I tried to use wpa_passphrase to generate a basic configuration block for the wpa_supplicant.conf but i did not work ?

Also whenever try to run ifup eth1 , i am getting this error ,
Determing IP information for eth1... failed; no link present .. check cable?

demsg displayed also this error for ifup eth1
ADDRCONF(NETDEV_UP) eth1:link is not ready


Any help please.
 
Old 05-24-2008, 11:45 PM   #5
abodana
LQ Newbie
 
Registered: Dec 2004
Location: Saudi Arabia
Distribution: Fedora
Posts: 20

Original Poster
Rep: Reputation: 0
I used ipw2200 instead

Hello Gentlemen,

First of all , i have removed the ndiswrapper as recommended , i just used ipw2200.

Below is the detail of my network card , i need your help in this , please?

[root@localhost ipw2200-1.2.2]# ./verify_wifi_hw
Found: Intel PRO/Wireless 2200BG Network Connection
PCI location: /sys/bus/pci/devices/0000:06:05.0

[root@localhost proc]# lsmod | grep -i ipw
ipw2200 127304 0
ieee80211 30280 1 ipw2200

[root@localhost proc]# lsmod | grep -i iee
ieee80211_crypt_wep 7680 0
ieee80211 30280 1 ipw2200
ieee80211_crypt 8324 2 ieee80211_crypt_wep,ieee80211

[root@localhost proc]# ll -tr /lib/firmware/ | grep -i ipw2200
-rw-r--r-- 1 root root 12007 2005-08-11 15:33 LICENSE.ipw2200
-rw-r--r-- 1 root root 187836 2006-03-07 22:49 ipw2200-sniffer.fw
-rw-r--r-- 1 root root 185660 2006-03-07 22:49 ipw2200-ibss.fw
-rw-r--r-- 1 root root 191142 2006-03-07 22:49 ipw2200-bss.fw

[root@localhost proc]# dmesg | grep -i ipw
ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
ipw2200: Copyright(c) 2003-2006 Intel Corporation
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200: Detected geography ZZR (14 802.11bg channels, 0 802.11a channels)

[root@localhost proc]# dmesg | grep -i iee
ieee80211_crypt: registered algorithm 'NULL'
ieee80211: 802.11 data/management/control stack, git-1.1.13
ieee80211: Copyright (C) 2004-2005 Intel Corporation <jketreno@linux.intel.com>
ieee80211_crypt: registered algorithm 'WEP'

[root@localhost proc]# rpm -qa ipw2200-firmware
ipw2200-firmware-3.0-9.noarch

[root@localhost proc]# lspci | grep -i wireless
06:05.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)


[root@localhost proc]# iwconfig eth1
eth1 unassociated ESSIDff/any Nickname:"localhost.localdomain"
Mode:Managed Frequency=2.457 GHz Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power=20 dBm Sensitivity=8/0
Retry limit:7 RTS thrff Fragment thrff
Encryption keyff
Power Managementff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

[root@localhost proc]# iwlist eth1 scan
eth1 No scan results

I used these commands to connect to wireless network ,

- iwconfig eth1 essid any

- ifconfig eth1 up
in /var/log/messages
May 25 21:27:02 localhost avahi-daemon[2421]: Registering new address record for fe80::213:ceff:fed1:c1d5 on eth1.*.

- dhclient eth1
in /var/log/messages
May 25 21:27:54 localhost dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 3
May 25 21:27:57 localhost dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 3
May 25 21:28:00 localhost dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 5
May 25 21:28:05 localhost dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 10
May 25 21:28:15 localhost dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 15
May 25 21:28:30 localhost dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 14
May 25 21:28:44 localhost dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 10
May 25 21:28:54 localhost dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 1
May 25 21:28:55 localhost dhclient: No DHCPOFFERS received.
May 25 21:28:55 localhost dhclient: No working leases in persistent database - sleeping.

The above messages it keep in scrolling !!! any ideas ???

Also in demesg , it displayed this message ,
eth1: no IPv6 routers present

Also whenever i enable the wireless network from the button it gave this error in the /var/log/messages

May 25 21:45:20 localhost kernel: ipw2200: Failed to send SCAN_ABORT: Command timed out.
May 25 21:45:21 localhost kernel: ipw2200: Failed to send CARD_DISABLE: Command timed out.


One more questions ...

What is the different in the configuration , if am going to connect to encrypted network or to non encrypted network.
 
Old 05-31-2008, 10:03 AM   #6
Fergatron
LQ Newbie
 
Registered: Apr 2005
Location: Georgia, USA
Distribution: Fedora 12
Posts: 25

Rep: Reputation: 15
It's good to see other folks having wireless issues with their Fedora 9. For a moment I thought it was only me. Sorry to hear it, but good to know I'm not alone.

I installed F9 on my IBM Thinkpad R40. iwscan eth0 scan picks up networks and so does NetworkManager, but it just won't connect. The WEP and the WEPless networks just won't connect. First I'm confused as to why it's coming up at eth0 and not wlan0. Does anyone have any solutions yet!?
 
Old 06-08-2008, 06:15 AM   #7
abodana
LQ Newbie
 
Registered: Dec 2004
Location: Saudi Arabia
Distribution: Fedora
Posts: 20

Original Poster
Rep: Reputation: 0
Any idea ...

Hello Gentlemen,

I am still searching and searching Google for a solution but no avail....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 7 and Wireless Card SiMiE Fedora 1 06-02-2007 06:15 AM
Wireless Card And Fedora 5 shafty1968 Fedora 1 10-20-2006 10:11 AM
Help with wireless card in fedora 4. extendedping Linux - Wireless Networking 6 10-16-2005 10:13 PM
wireless card unlisted - fedora dmitri10 Linux - Wireless Networking 1 08-28-2005 06:40 AM
netowrk card help sis900 Druaga Linux - Networking 1 12-31-2002 09:09 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 08:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration