LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (https://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   Wireless internet: not running on full speed on Suse 9.1 (https://www.linuxquestions.org/questions/linux-wireless-networking-41/wireless-internet-not-running-on-full-speed-on-suse-9-1-a-224199/)

koenswolfs 08-30-2004 03:27 AM

Wireless internet: not running on full speed on Suse 9.1
 
Hello,

I have a little problem configuring wireless internet in Suse Personal 9.1.

When I use the (graphical) control center to configure my network adapter, by entering my SSID and access point (MAC address of the router), the internet connection works, but it is really slow! But when I run Knoppix (3.6) without having to configure something, the internet connection is very fast. Is there a possibility to "export" the settings from Knoppix to Suse? By PREFERENCE not by editing those text files...

Another strange thing: after updating Suse via the live Suse update tool (susewatcher), the internet connection doesn't work anymore at all! So for now, I re-installed Suse without updating it, but the internet connection is very slow.

Can someone please help me configuring my internet connection at full speed?

Thanks in advance,

koswo

PS: This is my infrastructure: a Toshiba laptop, an ADSL internet connection, a Netopia wireless ADSL router (I think it's the 3347W model) and a Linksys WPC11 PCMCIA wireless network adapter.

koenswolfs 08-30-2004 05:34 AM

Or maybe someone who was able to configure his/her wireless internet in Suse 9.1 can explain me how?

anyone?

koenswolfs 08-31-2004 04:06 AM

OK, this Suse distro is starting to p*$& me off. I'm going to install Mandrake 10 this evening. Does anyone know if Mandrake supports the Linksys WPC11 PCMCIA card? Or do I have to configure it from 0?

Thanks,

2Gnu 08-31-2004 11:19 AM

Which version of the WPC11?
No distro that I'm aware of supports the v4 without additional hoop-jumping.
If it's a v3 or lower, any distro should work with it with only minimal configuration.

koswo 08-31-2004 02:19 PM

First of all: thanks for your reply!

The version of my WPC11 is: ver.3.

In the meanwhile I installed Mandrakelinux 10. I configured my internet connection over the wireless PCMCIA adapter which was detected during installation. Result: internet works, but again very slow!

When I run "iwconfig", it shows the correct parameters for my internet connection.

Before I installed Mandrake, I tried the "ndiswrapper-solution" in Suse, but that didn't do the job either. And since I can't complete the process described on the Linksys support page for Linux (http://linksys.custhelp.com/cgi-bin/...aW51eA**&p_li=) because the Kernel sources aren't installed by default (see: http://www.linuxquestions.org/questi...hreadid=224394), I'm a bit lost...

Any help = welcome!

2Gnu 08-31-2004 04:15 PM

It sounds as though the wireless card is functioning, so let's stay with that assumption for now.

As for the speed - define slow. What and how are you measuring?

Does iwconfig show the MAC address of your AP? (Just thinking that maybe you're connecting to a more distant WLAN). What does it show for signal strength and transfer rate?

Does a wired connection function properly? An improper /etc/hosts file can ruin your day.

koswo 09-01-2004 01:59 AM

Hello,

If I compare the time a site needs to load, it takes much much longer than in Windows, and I'm not talking about seconds. A simple site, like let's say Google, takes almost two minutes to load. Another strange thing I noticed (in Suse, I didn't test it in Mandrake yet) is that when I download a file, it runs at full speed.

iwconfig shows the correct mac address of my wireless router.

I didn't try a wired connection yet. I'll try to post the hosts file, when I get home.

2Gnu 09-01-2004 12:12 PM

It almost sounds like an MTU problem. You might try setting the MTU for 1498 to see if it helps. I'd also look at the interface stats with ifconfig to see what's happening.

koswo 09-01-2004 12:49 PM

OK, and how do I do that?

2Gnu 09-01-2004 02:44 PM

man ifconfig

koswo 09-14-2004 08:37 AM

Thanks to another post, I managed to find out what was the cause of the slow connection : bad DNS settings.

It's ok now (in Mandrake 10).


All times are GMT -5. The time now is 07:20 AM.