LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 04-20-2006, 01:58 PM   #1
rojelio
LQ Newbie
 
Registered: Mar 2005
Posts: 4

Rep: Reputation: 0
Unhappy wireless help please!!! using SUSE 10 with Compaq presario v2000 model v2630us


wow please help I am running a compaq presario v2000 series model v2630us with suse 10 (the 5 disk set) 32bit (although I got virtually the same messages when using latest mandriva 2006 64bit on another pc. I keep seeing posts where people are getting further than I so any ideas would be greatly appreciated. it is kind of long sorry about that I just wanted to be as detailed as possible. I have already read several threads on dealing with this subject but cant seem to make any headway.
So I will begin with the beginning steps I have done.
First I issued an lspci -v and got


05:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
Subsystem: Hewlett-Packard Company: Unknown device 1355
Flags: bus master, fast devsel, latency 64, IRQ 3
Memory at c0204000 (32-bit, non-prefetchable) [size=8K]

linux:/home/junkphreak/Documents/drivers/80211/BG # ndiswrapper -i bcmwl5a.inf
Installing bcmwl5a
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2

linux:/home/junkphreak/Documents/drivers/80211/BG # ndiswrapper -m
Adding "alias wlan0 ndiswrapper" to /etc/modprobe.d/ndiswrapper


did modprobe ndiswrapper dropped me to the next prompt


issued dmesg and got info below for ndis

Process loadndisdriver (pid: 11526, threadinfo=c8ff6000 task=c921d020)
Stack: cece5580 d8f2a000 c8d5a308 c8ff6000 d8f08a61 00040004 d8f19393 c8d5a00c
00000000 d8f2a000 b7da5008 d8f091b4 d8f09110 d8f09110 d8f09110 c9138ac0
c0169a6e b7da5008 c9138ac0 00000000 c0169b7f fffffff7 fffffff7 fffffff7
Call Trace:
[<d8f08a61>] load_ndis_driver+0xf1/0x1f0 [ndiswrapper]
[<d8f091b4>] wrapper_ioctl+0xa4/0xb0 [ndiswrapper]
[<d8f09110>] wrapper_ioctl+0x0/0xb0 [ndiswrapper]
[<d8f09110>] wrapper_ioctl+0x0/0xb0 [ndiswrapper]
[<d8f09110>] wrapper_ioctl+0x0/0xb0 [ndiswrapper]
[<c0169a6e>] do_ioctl+0x4e/0x60
[<c0169b7f>] vfs_ioctl+0x4f/0x1c0
[<c0169d27>] sys_ioctl+0x37/0x70
[<c0102d1b>] sysenter_past_esp+0x54/0x79
Code: e7 8b 96 90 01 00 00 47 83 c3 38 39 fa 77 e3 8b be 74 02 00 00 85 ff 7f 3f
8b 86 78 02 00 00 85 c0 74 05 e8 13 c2 23 e7 8b 45 04 <8b> 58 0c 53 e8 67 5f 00
00 8d 45 1c 50 e8 be c8 00 00 8b 45 18
<3>ndiswrapper (ndiswrapper_load_driver:93): loadndiswrapper failed (11); check
system log for messages from 'loadndisdriver'


so I tried the bcmwl5.inf (the reason I had tried the bcmwl5a.inf was that I have also read some posts indicating that was the one to use), I get virually the same thing, which I listed below. First I uninstalled the previous driver with ndiswrapper -e bcmwl5a.



linux:/home/junkphreak/Documents # ndiswrapper -i bcmwl5.inf
Installing bcmwl5
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
linux:/home/junkphreak/Documents # ndiswrapper -l
Installed ndis drivers:
bcmwl5 driver present, hardware present
linux:/home/junkphreak/Documents # dmesg | grep ndiswrapper
ndiswrapper: module not supported by Novell, setting U taint flag.
ndiswrapper version 1.2 loaded (preempt=no,smp=no)
ndiswrapper (import:245): unknown symbol: ntoskrnl.exe:strrchr
ndiswrapper (import:245): unknown symbol: ntoskrnl.exe:MmFreeContiguousMemorySpecifyCache
ndiswrapper (import:245): unknown symbol: ntoskrnl.exe:MmAllocateContiguousMemorySpecifyCache
ndiswrapper (import:245): unknown symbol: ntoskrnl.exe:MmGetPhysicalAddress
ndiswrapper (load_sys_files:520): unable to prepare driver 'bcmwl5'
Modules linked in: ndiswrapper ipt_pkttype ipt_LOG ipt_limit cpufreq_ondemand cpufreq_userspace cpufreq_powersave powernow_k8 speedstep_lib freq_table snd_pcm_oss snd_mixer_oss snd_seq snd_seq_device af_packet edd joydev ip6t_REJECT ipt_REJECT pcmcia firmware_class ipt_state iptable_mangle iptable_nat iptable_filter ip6table_mangle 8139too mii snd_atiixp yenta_socket rsrc_nonstatic pcmcia_core ohci1394 ieee1394 snd_ac97_codec snd_ac97_bus ip_conntrack ehci_hcd snd_pcm ip_tables generic snd_timer snd soundcore snd_page_alloc ati_agp agpgart ip6table_filter ohci_hcd usbcore ip6_tables pci_hotplug ipv6 parport_pc lp parport dm_mod reiserfs ide_cd cdrom processor atiixp ide_disk ide_core
EIP is at unload_ndis_driver+0x50/0xb0 [ndiswrapper]
[<d8f08a61>] load_ndis_driver+0xf1/0x1f0 [ndiswrapper]
[<d8f091b4>] wrapper_ioctl+0xa4/0xb0 [ndiswrapper]
[<d8f09110>] wrapper_ioctl+0x0/0xb0 [ndiswrapper]
[<d8f09110>] wrapper_ioctl+0x0/0xb0 [ndiswrapper]
[<d8f09110>] wrapper_ioctl+0x0/0xb0 [ndiswrapper]
<3>ndiswrapper (ndiswrapper_load_driver:93): loadndiswrapper failed (11); check system log for messages from 'loadndisdriver'


and so again I issue less messages | grep loadndisdriver and get these messages.

linux:/var/log # less messages | grep loadndisdriver
Apr 20 02:51:35 linux kernel: Process loadndisdriver (pid: 16022, threadinfo=cb324000 task=cb430530)
Apr 20 02:51:35 linux kernel: <3>ndiswrapper (ndiswrapper_load_driver:93): loadndiswrapper failed (11); check system log for messages from 'loadndisdriver'
Apr 20 11:58:01 linux kernel: Process loadndisdriver (pid: 11526, threadinfo=c8ff6000 task=c921d020)
Apr 20 11:58:01 linux kernel: <3>ndiswrapper (ndiswrapper_load_driver:93): loadndiswrapper failed (11); check system log for messages from 'loadndisdriver'

I have read the thread called SUSE 10 and BCM4318 and a plethora of others banging head against wall right now.

Last edited by rojelio; 04-20-2006 at 02:27 PM.
 
Old 04-23-2006, 09:54 PM   #2
rojelio
LQ Newbie
 
Registered: Mar 2005
Posts: 4

Original Poster
Rep: Reputation: 0
still need help :)

any ideas would be great
 
Old 05-07-2006, 11:16 AM   #3
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
I have the exact same problem with you, however, I am using SuSE 10 and using a Dell 1390 miniPCI wireless card by Broadcom. I am getting the same error messages as you.
 
Old 09-23-2006, 02:24 AM   #4
hakan4321
LQ Newbie
 
Registered: Sep 2006
Location: Turkey
Distribution: delimanyak
Posts: 7

Rep: Reputation: 0
Ow I had the same problem.
 
Old 09-23-2006, 02:33 AM   #5
hakan4321
LQ Newbie
 
Registered: Sep 2006
Location: Turkey
Distribution: delimanyak
Posts: 7

Rep: Reputation: 0
I had the same problem with the same card Broadcom Air Force One. I used ndiswrapper version 1.23 with these commands. It works. Now I can use my wireless. You can solve your problem at this page: http://ndiswrapper.sourceforge.net/m...p/Installation
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compaq Presario 900 US Model arst05 Linux - Laptop and Netbook 2 05-17-2006 08:40 PM
Suse 10, 64-bit on Presario V2000 slacker9876 Linux - Laptop and Netbook 4 03-14-2006 03:37 PM
novell suse linux 10 sierra wireless aircard 555 hp compaq presario x1000 arjunshriram Linux - Laptop and Netbook 9 01-05-2006 12:00 PM
V2000 (64-bit) wireless works in SUSE but not Fedora? sancho Fedora 3 10-20-2005 12:46 PM
Wireless PCMCIA card working on Windows XP but not on Suse 9.0 with a Compaq Presario pacobena Linux - Laptop and Netbook 0 11-13-2003 04:33 PM


All times are GMT -5. The time now is 12:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration