-   Linux - Wireless Networking (
-   -   Wireless Freezes on Acer Aspire One 722 (AO722) (

willroberts 11-04-2011 07:47 AM

Wireless Freezes on Acer Aspire One 722 (AO722)
The wireless card in my Acer netbook locks up the entire system when attempting to connect to a wireless network (or at other seemingly random times in the boot process, or during normal use). I have tried several different distributions/kernels and two different wireless cards. The stock card is a Broadcom BCM4313, and my new card is an Intel 6200.

I'm currently using Lubuntu 11.10 with kernel 3.0.0-12. Running modprobe shows Intel's iwlagn.ko module (or the Broadcom module when that card is in). In one instance last night I was able to boot, view the available wireless networks, connect to a wireless network, disconnect from ethernet, and ping Google (successfully) for about fifteen seconds before the system locked up. No combination of antenna connections inside the netbook (the black and white connections to the MAIN/AUX ports) results in any significant difference.

Other posts on Google show many users with similar issues, along with some scattered recommendations -- disabling power saving mode, installing netcfg, and leaving eth0 connected while using the wireless card. None of these workarounds accurately address the problem.

What other options do I have for identifying the actual cause of the freezes and finding a proper solution?

P.S. Unfortunately, the wireless on this netbook works just fine (with either card) in Redmond's latest offering.

rokytnji 11-04-2011 02:07 PM


What other options do I have for identifying the actual cause of the freezes
Open LxTerminal. Type in


Look to see what is eating cpu and ram when lockup occurs. (before lockup occurs of course)

thryllkill 11-09-2011 08:58 AM

This may sound silly, but a fix I found on the archlinux boards was to press F2 while booting and change your boot priority to make network booting the first option, and then your usb or hard drive, whichever you want. Then, for reasons unknown to me, wireless should not cause the whole machine to freeze up.

jerm1027 01-01-2012 04:14 PM

I'm actually having the same problem, and I just got mine yesterday. It doesn't appear to effect Windows 7 though...

Anyway, Have you tried updating the BIOS? If a workaround is editing the BIOS, it just may be a BIOS bug. I haven't tried it yet, as I've never flashed a BIOS before.


So, I'm running BIOS v1.06. The current version of as of this writing is 1.07. Turns out Acer does NOT have any real changelog to their BIOS updates. However, I did find a workaround. You have to go into the BIOS and ENABLE network booting and set it FIRST in the boot order. I also have USB HDD 2nd the boot order followed by my HDD. I know this works because I'm writing this post from Lubuntu 11.10 connected through my home wireless network on my AO722 netbook. My best guess is either a BIOS bug, or a bad ethernet controllers/firmware from Astheros. Either way, it's beyond me from here.

I still have no idea whether or not the new BIOS will render this workaround irrelevant, but somehow I doubt it. Hope this helps out anyone else who is having this problem.

dzhonw 01-14-2012 04:08 PM

I have the same problem with my Acer AO722, and the workaround (telling the BIOS to try to boot over the network first) seems to prevent the freezes.

However, it also seems the brcmsmac drivers don't handle the included (Broadcom) BCM4313 well. Cf. the thread I started here:

The secondary, full-size mini PCIe port seems to be locked to a specific 3G card provided by Acer. Cf. this thread:

I'm likely to be getting a half-sized mini PCIe card with better driver support to replace this one, and in the meantime using a working full-size mini PCIe card taped down so it doesn't slip out of the spot. If a BIOS upgrade does indeed fix the issue, I'd be interested to hear about it.

jhw 07-19-2012 02:20 AM

Just wanted to let everybody know that this bug still persists on the Acer Aspire One 722 with current BIOS firmware version 1.08 and Slackware running Kernel 3.2.23. However, the workaround with activating network boot and putting it first in bootup list still applies and wifi will work after that.

hbandura 11-10-2012 04:04 PM

Hi. I was having issues with the same bug (netbook freezing when trying to connect to a wireless network) in ubuntu 12.04 in an acer aspire 722. The workaround solved it. Have no idea why.

All times are GMT -5. The time now is 04:02 PM.