-   Linux - Wireless Networking (
-   -   Wireless Connectivity in Fedora Core 8 on Dell Inspiron 8600 (

BlueInkAlchemist 04-18-2008 02:11 PM

Wireless Connectivity in Fedora Core 8 on Dell Inspiron 8600
Greetings all!

I'm new to Linux and have been struggling with adapting my installation of Fedora Core 8 to work on my Inspiron 8600 laptop. The built-in wireless is an Intel PRO 2200BG Network Connection. Reading over this thread I removed NetworkManager, which had at one point picked up WiFi connections, and installed ndiswrapper and wpa-supplicant instead. Here's how things stand now:


[root@localhost ~]# lspci -v

02:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)
Subsystem: Intel Corporation Dell B130 laptop integrated WLAN
Flags: bus master, medium devsel, latency 32, IRQ 7
Memory at faffc000 (32-bit, non-prefetchable) [size=4K]
Capabilities: [dc] Power Management version 2
Kernel driver in use: ipw2200
Kernel modules: ipw2200

[root@localhost ~]# ndiswrapper -l
w29n51 : driver installed
device (8086:4220) present (alternate driver: ipw2200)
From modprobe.conf in /etc:

alias eth1 ipw2200
options ndiswrapper if_name=eth1
My wireless network is being detected:

[root@localhost ~]# iwlist eth1 scan
eth1 Scan completed :
Cell 01 - Address: 00:30:BD:FD:04:09
Protocol:IEEE 802.11bg
Frequency:2.462 GHz (Channel 11)
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=97/100 Signal level=-27 dBm
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Extra: Last beacon: 48ms ago

Currently, iwconfig reads as follows:

[root@localhost ~]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 unassociated ESSID:off/any Nickname:"localhost.localdomain"
Mode:Managed Frequency=2.412 GHz Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power=20 dBm Sensitivity=8/0
Retry limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
And ifcfg-eth1 in etc/sysconfig/network-scripts:

# Intel Corporation PRO/Wireless 2200BG Network Connection
Running "dmesg | grep" for either "eth1" or "ndiswrapper" yields nothing. Perhaps they are not loading on startup? Or maybe I'm doing something else wrong? Please let me know anything I could do to resolve this issue.

Thanks so much in advance!

Brian1 04-18-2008 04:26 PM

Since its is being identified as eth1 and when you posted the ndiswrapper -l output it is using the kernel ipw2200 module. This is the module you whould use and not ndiswrapper. the ipw2200 is really designed for that chipset.

Also the cell infinity_circuit is posted as wpa mode encryption. have you defined the passkey in your wpa_supplicant.conf since not using NetworManager or NM_CONTROLLED no


BlueInkAlchemist 04-18-2008 05:02 PM

Brian1, thanks for responding so promptly.

I've uninstalled ndiswrapper and changed modprobe.conf to point eth1 at the ipw2200 module. Now, the following message appears on startup:


Bringing up interface eth1... ipw2200 device eth1 does not appear to be present, delaying initialization
Also, wpa_supplicant.conf specifies the passkey for infinity_circuit.

Brian1 04-20-2008 09:33 AM

First thing to do from here is turn off wpa on the router and try to connect to the router as plain connection no security. One thing I recommend is not use odd characters in networking names. Yes they may work fine but using just letters and numbers seems to eliminate the posiblilties of different OSes not understanding them. Just my experience working with multiple OSes. I know you are not using them but something i go by. Also you might post your unencryted passphrase it may contain something wpa in Linux cannot use. I have seen someone use a " in theirs which is fine in Windows but does not generate correctly in linux.


Hangdog42 04-20-2008 10:07 AM


I have seen someone use a " in theirs which is fine in Windows but does not generate correctly in linux.

For a lot of characters, particularly those that have a meaning in a linux shell (and " would be one of those), you need to escape them in your config files and if you do that, they work fine. You also may need to encapsulate the entire passphrase in single or double quotes (which can get kinda funky looking if " is part of the passphrase). I recently ran across a network that used ? in the passphrase, and escaping each of the ? characters worked. So in Windows, you can get away with entering:


Whereas in Linux you might need:

"passphrase\?" or 'passphrase\?'

BlueInkAlchemist 04-20-2008 10:43 AM


Originally Posted by Hangdog42 (Post 3126936)
"passphrase\?" or 'passphrase\?'

If the special character is in the middle of the passkey, do you still just need a single \, or would it look like this:


Hangdog42 04-20-2008 11:09 AM

I'm pretty sure that you just need the single \ so

"pass\?phrase" would probably work. From my limited experience, this sort of stuff seems to follow the normal rules for escaping characters in bash.

BlueInkAlchemist 04-20-2008 11:18 AM

Thanks, Hangdog. Unfortunately, both with escaped special characters and with security disabled, eth1 still refuses to activate.

Brian1 04-20-2008 12:32 PM

Have you tried no security yet? No sense fighting WPA if it is the network module or other config issue to begin with. One layer at a time.


BlueInkAlchemist 04-20-2008 12:43 PM

As I said, I tried restarting the laptop with security disabled. I got the same error message both on startup and activating the interface after logging in as root.

Brian1 04-20-2008 01:14 PM

OK with no WPA enabled on the laptop and the router then also change CHANNEL=1 to just CHANNEL= in the ifcfg-eth1 file.
As root issue the command ' /sbin/service network restart '


BlueInkAlchemist 04-20-2008 05:45 PM

Still getting the same error, with security disabled and ipw2200 installed clean without ndiswrapper.

BlueInkAlchemist 04-29-2008 04:43 PM

Added tags to post, please help!

Hangdog42 04-30-2008 08:29 AM

I'd like to go back to Brian1's suggestion that you turn off wpa encyrption and see if you can connect that way. We need to figure out if you're having a driver problem or a wpa problem, and turning off wpa for a bit is the only way to sort that out. So try to connect without wpa and post the iwconfig and ifconfig outputs if you have trouble.

BlueInkAlchemist 04-30-2008 08:42 AM

All security is disabled and SSID is broadcasting. Makes me a bit nervous, but nevermind that. My wireless connection is still called eth1.


eth0 Link encap:Ethernet HWaddr 00:11:43:6B:51:2E
inet addr: Bcast: Mask:
inet6 addr: fe80::211:43ff:fe6b:512e/64 Scope:Link
RX packets:7857 errors:0 dropped:0 overruns:0 frame:0
TX packets:6858 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:6719614 (6.4 MiB) TX bytes:977072 (954.1 KiB)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:5703 errors:0 dropped:0 overruns:0 frame:0
TX packets:5703 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2726264 (2.5 MiB) TX bytes:2726264 (2.5 MiB)

lo no wireless extensions.

eth0 no wireless extensions.
When activating eth1 via the network configuration interface:

ipw2200 device eth1 does not seem to be present, delaying initialization.

All times are GMT -5. The time now is 04:33 AM.