LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (https://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   Wireless Configuration Suse 10.0 Inspiron 8200 / Linksys WPC54G v.2 (https://www.linuxquestions.org/questions/linux-wireless-networking-41/wireless-configuration-suse-10-0-inspiron-8200-linksys-wpc54g-v-2-a-390753/)

Leatherneck 12-08-2005 10:34 PM

Wireless Configuration Suse 10.0 Inspiron 8200 / Linksys WPC54G v.2
 
Please let me start by saying I have searched the forums and found many similar issues, but I have a couple of questions re: wireless tools and wlan0 and am not sure how old of a Thread I can post to. New to linux and new to using forums, so if I am handeling this wrong please just let me know.

(I also had to go through and remove the http portion of the URL's until I have made 5 posts)

I have a dell Inspiron 8200 with Suse 10.0
My Wireless card is a Linksys Wireless-G WPC54G v.2
I am using the ndiswrapper that came with the Distribution.

I have followed the instructions I believe at:
ndiswrapper.sourceforge.net/mediawiki/index.php/Suse_Professional_9.2

and also at:
ndiswrapper.sourceforge.net/phpwiki/index.php/Installation

basically I get to the part where I run :
--------------------------------------------------------------------------------------------------------
rcraver@rcraver:~> ndiswrapper -l
Installed ndis drivers:
lstinds driver present
-------------------------------------------------------------------------------------------------------

I see the drivers installed

--------------------------------------------------------------------------------------------------------
rcraver:/home/rcraver # modprobe ndiswrapper
rcraver:/home/rcraver # iwconfig
lo no wireless extensions.

sit0 no wireless extensions.

eth0 no wireless extensions.
---------------------------------------------------------------------------------------------------------

So I am not seeing any lights on the card, I am not seeing wlan0, and
I am not seeing any lights whatsoever on the card.

Am I missing where I need to configure wlan0?

I see in the packages in Yast that I have installed the wirelss tools
but how can I tell if it is installed and not just that the package is
on the machine? If there are tools to use I can't seem to find where to run them.

Is it possible I am just not using the correct driver?

I got the driver from:

Card: Linksys #[WPC54G v2], 54Mbps -- [link here|List#WPC54G v2]

* Chipset: Texas Instruments ACX 111
* pciid: 104c:9066
* Driver: Linksys
ftp.linksys.com/pub/network/wpc54gv2_driver_utility_v2.02.zip

-The driver is a .zip and I tried all of the .sys files in the .zip
and only one of them worked, I got an error message with the oters
when I ran the "ndiswrapper -l" command.
-I never did an unzip or anything (is there something I should do with
that?

:scratch:

Cogar 12-09-2005 04:22 PM

You may be making this more difficult on yourself than you need to. I believe all of this is automated in SUSE 10.0 and I also believe the distribution includes all the necessary drivers and applications so you do not need to download anything. Let me add that I know this is a broad statement, but I think it is correct in at least 80% of the cases.

There is a wireless card configuration tool that comes with SUSE 10.0. It may take a little looking to find it, but it is there in YaST somewhere. (I am not at the right computer to look right now and I won't have a chance any time today--sorry.) Anyway, when running the tool, you will be given the following entry options or fields to fill in:

Operating Mode
(Ad-Hoc/Management/Master) <-- in a dropdown box

Network Name (ESSID)

Authentication Mode
(Open/Shared Key/WPA-PSK/WPA-EAP) <-- dropdown

Key Input Type
(Passphrase/ASCII/Hexadecimal) <-- radio buttons

Key

---

After entering these, YaST will probably tell you it needs to install one or more of the following packages:

smpppd
wireless-tools
wpa-supplicant

(You may have installed these correctly already. It is hard to tell what you may see.)

If worst comes to worst and this is a new install, you can always try installing again. You will come to a point where YaST suggests a particular installation and next to your wireless card it will state something to the effect of "Warning: no encryption is used. Change." If you click on the link, it will bring up the Wireless Network Card Configuration. I hope that helps. If I missed the point, at least I gave it a try. ;) Good luck in any case.

Leatherneck 12-10-2005 10:28 PM

Hello Cogar and thanks for the reply.

I have 2 young children so sometimes it takes me a day or two to get back to the forum to check messages.

I have actually been through the exact menu that you are describing, and yet I never see a wlan with ifconfig -a.

It very well could be that I am using a v2 card where .v3 is supported or something like that.

Tomorrow I will get the chance to double check the driver, if thats the only thing wrong you won't have to kick me, I will take care of that myself.

Thanks and I will keep you posted.

Cogar 12-11-2005 01:22 PM

I checked and located the path to this tool.

1. Select K Menu --> Control Center --> YaST2 Modules --> Network Devices --> Network Card.
2. Click on the Administrator Mode button and enter your root password. Highlight your network card and click "Edit."
3. Click "Next." You are there.

Incidentally, almost everything you need to set up a network card is available starting at the end of item 1 above. It is just a matter of choosing the correct path through the setup tool. Good luck. :)

Stump 12-14-2005 09:05 AM

Me too
 
This describes the exact problem that I am having. I've had no luck with ndiswrapper, though the driver is installed. I've also had no luck in YaST. YaST recognizes my card, and it appears that I have configured it to my network's settings. However, no power seems to be getting to my network card. No lights, and no response under iwconfig.

Please help!

Stump 12-14-2005 10:55 AM

Just figured it out!
 
I had forgotten to run "modprobe ndiswrapper"

Try that, then run "iwconfig" and you should see the wlan0 and the specs on your card show up. After that, since I had my lan cable plugged in also, I had to unplug that, then actually select the wlan0 from the dropdown menu. It didn't do it automatically.

aoberoi 03-16-2006 03:25 PM

did the lights on your card come on after ur ran modprobe ndiswrapper?

i was having an identical problem but i tried running that and it didnt fix anything.. can u elaborate on exactly what you did to get it working?

Stump 03-17-2006 06:50 PM

running ndiswrapper seemed kind of anticlimactic. modprobe was what turned it on. I then found that I had to run modprobe each time I booted the computer. I then ran yast again and typed ndiswrapper into the module name block under the advanced tab. That did the trick.

aoberoi 03-18-2006 11:39 PM

just curious... what type of a notebook are u running this card on... im still having problems but i read an article on LQ about the fact taht the 2.6 kernal and old laptops and PCMCIA network adapters have issues... i dont really kno how old is old enough to have an issue... i have a thinkpad a22n... about 6 years old

Stump 03-20-2006 05:10 PM

I don't know the answer to your question about how old is too old. My laptop is a Sony PCG-FRV35 that I bought in the spring of '04. It's not that old.


All times are GMT -5. The time now is 11:08 PM.