-   Linux - Wireless Networking (
-   -   Wireless broke with NetGear router -- unknown frame f202 (

Ima Sudonim 12-27-2003 07:55 AM

Wireless broke with NetGear router -- unknown frame f202
It seems an administrator updated the firmware on the router (which couldn't possibly hurt anything 8-( ). It looks like the latest NetGear G (WGR614)

Version 1.12 Aug 22 2003

that they installed has broken DHCP in linux for me.

Our other router works (LinkSys and LinkSysG), giving:
Dec 26 19:57:19 Client dhclient: DHCPREQUEST on eth1 to port 67
Dec 26 19:57:19 Client dhclient: DHCPACK from
Dec 26 19:57:19 Client dhclient: bound to

The Netgear gives
Dec 26 19:58:19 Client dhclient: DHCPREQUEST on eth1 to port 67
Dec 26 19:58:19 Client dhclient: DHCPDISCOVER on eth1 to port 67 interval 6
Dec 26 19:58:19 Client dhclient: No DHCPOFFERS received

dmesg has a bunch of
eth1: Unknown information frame received (type f202)

So it's looking like the problem is with the router DHCP?

I've since gone back to a Beta (Beta 1.12 from July 03) firmware version that I THOUGHT we were using, but it doesn't fix the problem.

Problem occurs on 2.6-test11 and 2.4.22

I am using yellow dog 3.01 on an apple powerbook. One of the working routers doesn't use wep, the other does. The broken one uses 128-bit wep also, but the information in /etc/sysconfig/networking/devices/ifcfg-eth1 looks good


I am trying to use the fourth of the four wep keys on the router. Is there a keyword in the file to tell ifconfig/iwconfig that?

thank you!

Ima Sudonim 12-28-2003 10:40 AM

Yes, it was the router's new firmware.

Luckilly, we were able to scrounge up the older firmware.

Strangely, we were not able to update over wireless from the macs -- got to 50%, stopped, and router status never showed a new firmware date (so we used a wired pc)

We tried both firmwares available at:

After uploading, we carefully reset the router to firmware defaults by holding in the reset button for 5 seconds, it TOTALLY messed up the router's ability to work with linux wirelessly (wired connections were not affected).

I know who I'll be calling on Monday...

Hope this helps somebody else.

BTW, the configuration files the router saves cannot be used between different firmware versions so be sure to backup before upgrading your firmware in case you have to back out the new stuff 8-( and go back to your original firmware and settings

MIZREE 05-04-2005 10:36 AM

similar problem, wireless sitting idle
Hello, I have just installed umbutu linux dist on my ibook, and having a similar problem with wireless connectivity to my netgear wgt634 router(wep enabled). I have also unsuccessfully tried to access through an old airport router with no security enabled. It shows that the wireless is connected but idle, and ibook will not come out of standby without the
eth1 unknown information frame received (type f202) error.

I do not believe it is the firmware, as I have not changed firmwares and it worked fine with osx. I'm thinking it has something to do with ipv6, and the hosts listed. (namely ff02::2 ip6-allrouters entry) but that is just a guess. I have no trouble connecting wired, but not much good to be wired. any help is appreciated.

All times are GMT -5. The time now is 03:36 PM.