LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 11-15-2006, 06:31 PM   #1
PhysicsMgr
LQ Newbie
 
Registered: Nov 2006
Location: Chicago
Posts: 4

Rep: Reputation: 0
wifi - ethernet conflict? (2 cards)


Running Fedora 5. All worked fine with ethernet card.
Then I added a Netgear WG311T PCI card, downloaded madwifi, and drove myself nearly mad trying to get it working.

I was able to get the wifi card to ping a wireless print server (as a test) after doing
ifconfig eth0 down
of course then I lost my regular lan access. I eventually disabled ath0 (the wireless card), re-enabled eth0. Now I can see my lan/internet OK but can't get ath0 working again (won't ping).
ifconfig eth0 down doesn't cause ath0 to see the wireless network anymore.
Tried restarting network,
wlanconfig ath0 destroy
wlanconfig create ath0 wlandev wifi0
I'm going nowhere.

The madwifi troubleshooting guide hints at a PCI card conflict but says nothing about resolving it. Both PCI cards share the same PCI interrupt number. Not sure if this is a problem.

Help please.

Last edited by PhysicsMgr; 11-15-2006 at 06:32 PM.
 
Old 11-18-2006, 08:35 AM   #2
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,395

Rep: Reputation: 81
Hi,

What "ifconfig" (no parameters) and "iwconfig" say?

Happy Pengiuins!!
 
Old 11-18-2006, 08:44 AM   #3
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Do you have the two devices on separate subnets? On my desktop, I have a wireless device for the internet and LAN and I use eth0 for the laser printer.

I have the wireless network on the 192.168.1.0 subnet with a netmask of 255.255.255.128. The printer is on the 192.168.1.128 subnet with the same netmask.
Code:
/sbin/route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     0.0.0.0         255.255.255.128 U     0      0        0 wlan0
192.168.1.128   0.0.0.0         255.255.255.128 U     0      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 wlan0
 
Old 11-20-2006, 10:31 AM   #4
PhysicsMgr
LQ Newbie
 
Registered: Nov 2006
Location: Chicago
Posts: 4

Original Poster
Rep: Reputation: 0
I have the cards on 2 different subnets:
eth0: 10.133.11.129 mask: 255.255.0.0
ath0: 192.168.0.25 mask: 255.255.255.0


[root@dirac ~]# ifconfig
ath0 Link encap:Ethernet HWaddr 00:0F:B5:83:45:36
inet addr:192.168.0.25 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::20f:b5ff:fe83:4536/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

eth0 Link encap:Ethernet HWaddr 00:B00:97:3D:53
inet addr:10.133.11.129 Bcast:10.133.255.255 Mask:255.255.0.0
inet6 addr: fe80::2b0:d0ff:fe97:3d53/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:4692976 errors:0 dropped:0 overruns:1 frame:0
TX packets:62512 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:402607935 (383.9 MiB) TX bytes:4597143 (4.3 MiB)
Interrupt:9 Base address:0xc00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1994 errors:0 dropped:0 overruns:0 frame:0
TX packets:1994 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2247640 (2.1 MiB) TX bytes:2247640 (2.1 MiB)

wifi0 Link encap:UNSPEC HWaddr 00-0F-B5-83-45-36-A8-EB-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:773097 errors:0 dropped:0 overruns:0 frame:967580
TX packets:3373630 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:199
RX bytes:48354484 (46.1 MiB) TX bytes:166994685 (159.2 MiB)
Interrupt:9 Memory:d0a60000-d0a70000

[root@dirac ~]#
[root@dirac ~]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wifi0 no wireless extensions.

Warning: Driver for device ath0 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

ath0 IEEE 802.11g ESSID:"default" Nickname:"dirac.physics.neiu.edu"
Mode:Managed Frequency:2.442 GHz Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power:18 dBm Sensitivity=0/3
Retryff RTS thrff Fragment thrff
Encryption keyff
Power Managementff
Link Quality=0/94 Signal level=-95 dBm Noise level=-95 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

[root@dirac ~]#
 
Old 11-21-2006, 12:40 AM   #5
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Quote:
Mode:Managed Frequency:2.442 GHz Access Point: Not-Associated
I haven't used madwifi so I don't know if you should have the ath0 interface show up after creating the wifi0 virtual interface. You might provide more information on your wireless network. What type of authentication are you using. Here is what looks like madwifi documentation central: http://madwifi.org/wiki/UserDocs
 
Old 11-22-2006, 04:09 PM   #6
PhysicsMgr
LQ Newbie
 
Registered: Nov 2006
Location: Chicago
Posts: 4

Original Poster
Rep: Reputation: 0
madwifi documentation refers to different versions so maybe I got confused about the ath0 alias. It's just an alias to ath_pci - I doubt it's causing a problem.
The only wireless network I have so far is just a test setup - trying to connect to a D-link wireless print server not set up for WEP or WPA. The print server's IP address is 192.168.0.10, I'm using ad-hoc connection mode. We've been using the print server for months so I know it's working.
 
Old 11-23-2006, 08:55 AM   #7
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Make sure you don't have it configured for managed mode then.

quote from the madwifi docs in the link I gave above:
[quote]
Creating an Ad-Hoc Station Mode Interface

This document does not apply to "old" (pre November 2005) versions of MadWifi.

First make sure that the interface you are going to create does not already exist. If 'ath0' already exists for instance, destroy it by:

wlanconfig ath0 destroy

To create an interface (called ath0) in ad-hoc mode, issue the command:

wlanconfig ath0 create wlandev wifi0 wlanmode adhoc

Or,

wlanconfig ath create wlandev wifi0 wlanmode adhoc

The only difference is the lack of '0' in the second command. The kernel will give the interface the lowest free integer as its suffix.

This will create a station mode interface which will inherit the MAC address of the base device, wifi0.

You can then use ath0 as you would any other normal (ad-hoc) wireless interface. wlanconfig is documented in its man page, wlanconfig 8.

You can find information about what to do once you have your ad-hoc interface, at UserDocs/AdHoc.

It seems only one ad-hoc VAP is possible, as creating a second one fails. Also, creating an ad-hoc VAP fails if there already is an ap VAP.
[quote]

I'm not certain why ath0 still shows up in the ifconfig list. The first command should have destroyed it I would think. Having two cards with the same IRQ shouldn't be a problem unless you disabled acpi or your motherboards implementation is broken.
If it is an Asus motherboard that might be the case. Try googling for an answer.

Last edited by jschiwal; 11-23-2006 at 09:00 AM.
 
Old 12-04-2006, 10:09 AM   #8
PhysicsMgr
LQ Newbie
 
Registered: Nov 2006
Location: Chicago
Posts: 4

Original Poster
Rep: Reputation: 0
It works now!
I am not able to ping the print server but I am able to ping other PC's in the print server's subnet.

When I reboot my Linux machine, the changes made by

wlanconfig ath0 destroy
wlanconfig ath0 create wlandev wifi0 wlanmode adhoc

go away, and the old settings come back. How do I make these changes permanent?
Do I have to edit a boot script? Seems silly....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wifi drivers with other ethernet cards sardok Linux - Wireless Networking 1 01-02-2006 06:49 AM
Ethernet IP change conflict pcm2005 Linux - Networking 4 06-25-2005 04:25 PM
IRQ conflict with NIC cards baczer Linux - Hardware 0 04-08-2004 08:27 AM
ethernet conflict nairnie Linux - Networking 1 11-17-2003 06:08 PM
Ethernet Cards and Sound Cards SchizoIV Linux - Newbie 2 07-05-2002 09:10 PM


All times are GMT -5. The time now is 05:07 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration