LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (https://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   wicd - No wireless networks found (https://www.linuxquestions.org/questions/linux-wireless-networking-41/wicd-no-wireless-networks-found-906227/)

couf 10-03-2011 02:19 PM

wicd - No wireless networks found
 
It was suggested to me to install wicd so I could connect to the internet while using Fluxbox. Under GNOME/Metacity I'm able to connect automatically and my network is detected. However, when I try to connect using Fluxbox it does not detect my network. How can I resolve this?

derstephen 10-03-2011 02:41 PM

Hi, me again. Have you tried the manual method I suggested? What's the output of
Code:

sudo iwconfig
?

couf 10-03-2011 02:44 PM

Here it is. I did it in a GNOME session, if that's relevant.
Quote:

lo no wireless extensions.

eth0 no wireless extensions.

eth2 IEEE 802.11 ESSID:"(name of my network)"
Mode:Managed Frequency:2.437 GHz Access Point: 00:21:29:AC:80:25
Bit Rate=54 Mb/s Tx-Power:24 dBm
Retry min limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Managementmode:All packets received
Link Quality=5/5 Signal level=-48 dBm Noise level=-88 dBm
Rx invalid nwid:0 Rx invalid crypt:12 Rx invalid frag:0
Tx excessive retries:271 Invalid misc:0 Missed beacon:0

pan0 no wireless extensions.

derstephen 10-03-2011 03:01 PM

Alright so now try:

Code:

sudo iwlist eth2 scan | grep nameofyournetwork
where nameofyournetwork is the name (a.k.a. essid) of the network you're trying to connect to.

Also, what kind of encryption does this network use? WPA2?

couf 10-03-2011 03:16 PM

The terminal said to that command:

Quote:

essid="nameofmynetwork"
It has WPA/WPA2 security.

derstephen 10-03-2011 03:50 PM

Good, that means your wireless card can see the network. Strange that wicd can't see it...

Well, what follows is a manual way of setting up the network. I did this successfully in Slackware, so now it detects the network automatically on boot and everything. So you can follow this if you're up to it or wait for someone with more wicd experience who may know what's up with that. It's not that hard; you just have to edit a configuration file.

Not sure but at least at one point Debian called this file /etc/network/interfaces. Slackware calls it /etc/rc.d/rc.inet1.conf, just to give you other ideas if you can't find it.

By the way, the official Debian manual for this can be found here, look at "The Wireless LAN Interface with WPA/WPA2", so defer to that if my suggestions don't work.

What it comes down to is adding this to the file:
Code:

allow-hotplug eth2
iface eth2 inet dhcp
wpa-ssid nameofyournetwork
wpa-psk yournetworkpassphrase

and you can comment out the entries that come before it using #'s at the beginning of the lines.

But make sure you have the wpasupplicant package installed too:
Code:

sudo apt-get install wpasupplicant
Save and close the file and run:
Code:

sudo /etc/init.d/networking restart
And cross your fingers!

rokytnji 10-03-2011 03:54 PM

Better check with OP to see if they are running Network Manager also, since there might be a conflict with wicd with both of them running.

couf 10-03-2011 04:11 PM

Quote:

Originally Posted by rokytnji (Post 4489091)
Better check with OP to see if they are running Network Manager also, since there might be a conflict with wicd with both of them running.

Yes, I have NetworkManager running, what should I do?

rokytnji 10-03-2011 04:24 PM

If deciding to keep Fluxbox and Gnome as dual desktop environments. You are going to have to make a decision and uninstall Network Manager and just run Wicd only.

Wicd conflicts with Network Manager and that is probably why wicd is not seeing your wireless networks and is probably the reason this whole thread was started.

frankbell 10-03-2011 08:18 PM

It would help to set your ~/.fluxbox/startup file to start wicd (or whatever network manager you eventually use) automatically, by adding

Code:

wicd &
in the correct location in the file.

The wicd icon will appear in Fluxbox's system tray and be accessible for checking status and logging on to a new network if you happen to be in the presence of one.

See the Fluxbox wiki for more.


All times are GMT -5. The time now is 09:04 PM.