-   Linux - Wireless Networking (
-   -   wicd doesn't work on Slackware 13.37 ? (

wubai 09-16-2012 12:58 AM

wicd doesn't work on Slackware 13.37 ?
Hi everybody !

recently i tried to get my laptop (dell inspiron m5110) work with wireless card but never got it worked , i am very frustraied. i've done some work, but honestly, i am not even sure if my wireless card on or not . hope someone can give me some advice.

some info:
sudo lspci | grep Network
02:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)

eth0 Link encap:Ethernet HWaddr 18:03:73:8d:55:97
inet addr: Bcast: Mask:
RX packets:38156 errors:0 dropped:3 overruns:0 frame:0
TX packets:35089 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:13457706 (12.8 MiB) TX bytes:3563646 (3.3 MiB)
Interrupt:51 Base address:0x8000

eth1 Link encap:Ethernet HWaddr cc:af:78:a5:6c:75
inet6 addr: fe80::ceaf:78ff:fea5:6c75/64 Scope:Link
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:197 errors:0 dropped:0 overruns:0 frame:0
TX packets:197 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:11280 (11.0 KiB) TX bytes:11280 (11.0 KiB)

lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11abg ESSID:off/any
Mode:Managed Frequency:2.437 GHz Access Point: Not-Associated
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off

sudo rmmod ndiswrapper b43 ssb bcm43xx b43legacy
ERROR: Module ndiswrapper does not exist in /proc/modules
ERROR: Module b43 does not exist in /proc/modules
ERROR: Module ssb is in use by ohci_hcd
ERROR: Module bcm43xx does not exist in /proc/modules
ERROR: Module b43legacy does not exist in /proc/modules

willysr 09-16-2012 01:16 AM

Your chipset is already detected. You only need to configure it so that it connects to the hotspot
You can use WICD or NetworkManager to do that

wubai 09-16-2012 01:32 AM

@willysr, thanks for your respond!

i used the slackpkg installed wicd, the latest version, it seems got a little bug that it shows two "automatically connet network" options instead of two diffrent options that should be " connect aunomatically or never connect" under the wireless section. but it works well anyway, but after i reboot my computer, it doesn't work well enough, from my laptop i can connect router, but when i open any website, it always shows checking the dns on the bottom bar of browser, and wicd shows always connecting, but also shows connecting done at the bottom, it's very confused. i reinstalled the lower version wicd manually, the "option" of "connect automatically or never connect" gets right, but still can't work, it seems can't get the dns server, i tried to set them manually, just can't get it work.

I'm looking for advice, any idea wold be appreciated very much!

Best Regard!

wubai 09-18-2012 11:04 PM

1 Attachment(s)
what does this mean ?

wubai 11-12-2012 07:11 PM

the kernel is a little bit old, new kernel in 14.0 is perfect!

thanks anyway !

frankbell 11-12-2012 08:56 PM

Edit: I didn't read far enough.

All times are GMT -5. The time now is 02:53 PM.