-   Linux - Wireless Networking (
-   -   WG311 v2 not connecting to router with iwconfig (

xploit 02-07-2008 06:45 PM

WG311 v2 not connecting to router with iwconfig
Hey guys, so Im on FC8 and I managed to get my wireless card installed.

Its a NETGEAR WG311 v2 and its isntalled with the XP drivers on ndiswrapper. ndiswrapper -l says its present and drivers are installed. Great!

Then I start ndiswrapper with modprobe ndiswrapper and check for the interface in iwconfig. wlan0 shows up, not connected to any network or AP. Now for my question, how can I connect it to my home network?

The router broadcasts SSID (I know its setup to broadcast and I can see it in iwlist wlan0 scanning) and it uses WEP encryption until I can get internet setup so I can yum wpa-supplicant. Anyhow, this is the initial command I used:

iwconfig wlan0 BSSID network ENC a0b1c2d3e4
This didnt work so well (it crashed my system) so I rebooted and did:

iwconfig wlan0 BSSID network KEY a0b1c2d3e4
This, again didn't work (at least it didnt freeze up tty) so I tried:

iwconfig wlan0 BSSID network KEY a0b1c2d3e4 MODE managed RATE 11m
Still no go!

Now what? Help appreciated :D

btw. all these commands were run as root from tty1

pentode 02-07-2008 09:45 PM

I would try turning off encryption on your router and try to connect in the clear. You will need to configure the interface settings or use your DHCP client software to get an IP address, etc. I don't use Fedora, so maybe someone else can provide more help.

Matir 02-07-2008 09:51 PM

You should be using the argument essid, not bssid. The bssid would be the MAC address of the router. I'm not sure if iwconfig is case sensitive, but I know it works for me using lower case arguments. Try:

iwconfig wlan0 essid network enc a0b1c2d3e4

xploit 02-07-2008 09:56 PM

Well I use the lowercase parameters, I just made them uppercase to improve readability :)

I thought something was fishy about using BSSID, Ill give essid a try (shame I just shut down my system, Ill do it tomorrow).

And pentode, I cant connect to my neighbor's wifi either, and his is unsecured, so I doubt its the WEP thats acting up.

Thanks, will post an update tomorrow.

xploit 02-09-2008 11:48 AM

Ok I tried using ESSID and still no go. Now I've encountered a new problem.

Ok, Ive been looking over the ndiswrapper wiki and found this:


Originally Posted by ndiswrapper wiki @ sourceforge
...set the operating mode of the interface according to your setup. In most cases, it is Managed iwconfig wlan0 mode Managed If you use encryption WEP, set the key: iwconfig wlan0 key restricted <XXXXXXXX>...



Originally Posted by ndiswrapper wiki @ sourceforge
...Set the network name iwconfig wlan0 essid <name>...



Originally Posted by ndiswrapper wiki @ sourceforge
Now, setup the network parameters for the interface wlan0. This varies from distribution to distribution. Refer to your distribution’s documents on how to do this. Once this is done, you can use network tools to bring up the network e.g., ifconfig wlan0 up or dhclient wlan0 or dhcpcd wlan0 etc.

See the problem is, I do

$ modprobe ndiswrapper
$ iwconfig wlan0 mode managed
$ iwconfig wlan0 key restricted a0b1c2d3e4

and then everything freezes up.

Ive even tried

$ iwconfig wlan0 essid network mode managed freq 2.412 channel 1 ap 00:01:02:03:04:05 key restricted a0b1c2d3e4
Whats going on? :?

xploit 02-09-2008 01:49 PM

I managed to associate my card with my neighbor's AP using

iwconfig wlan0 essid linksys mode managed freq 2.437 channel 6
Its all good and working except for one little thing, my desktop stopped responding. I dont know how to explain it better. I cant click/right click on my desktop or any of my icons or the K menu/toolbar shortcuts. But, I had 3 terminals open when this happened and they are still fully functional and parsing input.

Why is this happening?

All times are GMT -5. The time now is 05:20 PM.