LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (https://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   WEP not working with Fedora Core v1.0 (https://www.linuxquestions.org/questions/linux-wireless-networking-41/wep-not-working-with-fedora-core-v1-0-a-168692/)

fanson 04-11-2004 02:05 AM

WEP not working with Fedora Core v1.0
 
Ouch! I have to send this using my Windows XP hard disk due to this problem...

My Dell MobileMobile 1150 (oem'd from Orinocco) works greats under Windows 2000/XP with WEP. With Fedora Core v1.0 it's no good. I've used iwconfig to config the card. It finds the WAP and ESSID fine. So far so good.

Since the WAP is WEP enabled I input one of the 4 available keys.
They take and bind. No problem.

I kick over to another terminal window to do an "ifconfig eth0 up" command. No IP address. When I return to the terminal window and do a few "iwconfig eth0" commands I notice that "RX Crypt Errors" (or equivalent) is upticking. All other categories are zeroed out.

I'm stumped. Normally I would down WEP to see if that fixes the problem however, there is a suspected wireless whacko within the range of my WAP so I am reluctant to disable it. (the guy's ESSID is "FU" just to give you an idea)

Any suggestions gang?

/fwa


(note: I accidently posted this at the end of another thread - I am new to this forum and I'm getting my 'sea legs' I apologize for the dupe!)

fanson 04-11-2004 06:22 PM

Getting naked did it! ;-)
 
Well... I don't know what to tell you (or myself for that matter)...

Disabling WEP did it for me. I'm very happily typing this on my newly installed Fedora Core v1.0 installation. This scares me because I KNOW that there is a knowledgeable wireless sicko nearby (yes, "Darth" in the "FU" network I'm talkin' about you) that worries me.

At any rate... I'm going to stay naked for the time being unless - at the very least - I can be my kernel up to 2.6 and some hardening that requires web access. If I figure out how to make this work WITH WEP I will come back and repost.

/fwa

beyer42 04-11-2004 08:49 PM

Is eth0 your only ethernet device?

If so can you post your
/etc/syconfig/network-scripts/ifcfg-eth0

and just replace your ESSID and KEY info with made up stuff for privacy.

fanson 06-19-2004 02:21 AM

Well Fedora Core 2 did the trick! The WEP support seems to be MUCH better than it was in Fedora Core 1. However the BIG trick was the tip that I found in the "Network Devices" toolbox that instructed me to prefix a hex WEP ID with "0x". I did that and everything came flying up nicely -- in fact I am doing this post with my newly configured wireless connection.

/fwa


All times are GMT -5. The time now is 02:28 AM.