-   Linux - Wireless Networking (
-   -   WEP key in place but "this network requires encryption to be enabled" (

jdtiede 02-03-2009 04:48 PM

WEP key in place but "this network requires encryption to be enabled"
Message appears under gutsy, intrepid and jaunty (gave up on hardy weeks ago). I have a DLink card with Atheros 2413 chip, Athlon 64, Netgear DGN2000 modem-router. Was using ath5k since madwifi kept losing parts. Since ath9k is on synaptic and ath5k isn't, I am trying to use ath9k. I am using wicd as I have never seen anything from NetManager. The computer I need to be wireless is 22' from the router, with no walls in the way, but the signal is only 40-50% according to wicd. I have gotten as far as being able to see the network admin screens but unable to get to the internet--this before the above message started coming up. I have made all the proper settings in ifconfig and iwconfig.

SkinnerC 02-03-2009 05:23 PM

With Wicd open, click on the network you want to connect to. This will give you the advanced settings button. Click on that and complete your settings.

jdtiede 02-04-2009 01:29 PM

Re: WEP key in place but "this network requires encryption ..."
The error message appears as soon as I click on the network, giving me no chance even to see the Advanced button.

SkinnerC 02-04-2009 01:59 PM

Did you try to set up your network manually? If you did, you need to remove those settings.

open /etc/network/interfaces and make sure that the only thing in there is


auto lo
iface lo inet loopback

jdtiede 02-04-2009 03:27 PM

/etc/network/interfaces is exactly as you suggest.

SkinnerC 02-05-2009 07:41 AM

I have searched around and read through the docs for Wicd and I can not find anything to help you. I know that the encription is handled through wpa_supplicant. MAke sure that you have that installed.

Hopfully someone else here will be able to help you.

alan_ri 02-05-2009 08:23 AM

I had the same error when I've tried for the first time to use wicd.First left click on the tray wicd icon,then there is an arrow near your ESSID on which you need to click and advanced options will show up,then you need to enable encryption and enter your key.Try with madwifi and with the default driver to see which one works better.

All times are GMT -5. The time now is 08:55 AM.