LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 10-07-2018, 03:04 PM   #1
bodge99
LQ Newbie
 
Registered: Oct 2018
Posts: 9

Rep: Reputation: Disabled
Weird Intel AC9260 dual band problem. Cannot connect to 5Ghz wifi AP


Hello All.. My first post here.

Hardware:
Core i7 8550U laptop. 12GB Ram.
Wifi card: Intel Dual Band Wireless AC 9260, REV=0x324
Slackware wifi card firmware version 38.c0e03d94.0

Kernel version 4.18.12 (Slackware & Mint)

Background:
I'm currently in the process of setting up my new laptop with multiple Linux distros (don't ask!).
I've got Mint 19 fully installed and working perfectly. I'm presently tweaking Slackware current.

The only problem I had with Mint was with the wifi card. Connections would fail after a couple of seconds. I assumed that this was a firmware problem so I installed Kernel 4.18.12 via ukuu. This fixed the problem.

I'm using two TP-link EAP225 (dual band) wifi access points. One is directly connected to my main VDSL router and the other to a secondary router that is set up for VPN use.
This setup gives me 4 (downstairs) wifi networks. A VPN network on both bands and 1 "open" one on both bands when I need "that little extra" speed.
Everything is working as expected with my other devices.. A mix of W7, Linux Mint, Android, Devuan and a couple of *BSD's.

Problem:
In Slackware, (Cinnamon and XFCE DEs) any connection to the non-VPN wifi AP fails after a second or two. The system then repeatedly retries, connects for a second and then disconnects.
Connections to the VPN network (either band) are fine.
The only thing that I can see in dmesg is this:

deauthenticating from {non-VPN MAC address} by local choice (Reason: 3=DEAUTH_LEAVING)

This appears after every 3 connection attempts.

What I've Tried:

I compiled and installed the latest stable kernel from source.
Both wifi AP's have identical hardware, firmware and settings (except IP settings, obviously.).

I've tried switching off the wifi on the laptop, powering down & up again (cold boot). Attempts to connect to the non-VPN AP fail in an identical fashion.

I'm at a bit of a loss as to what to look at next...

Any suggestions??

Bodge99

Last edited by bodge99; 10-12-2018 at 06:47 AM.
 
Old 10-12-2018, 06:57 AM   #2
bodge99
LQ Newbie
 
Registered: Oct 2018
Posts: 9

Original Poster
Rep: Reputation: Disabled
Hello All,

I've found out what the problem was... after spending some time checking and double checking everything I looked more closely at the VDSL router settings. One thing I tried was to disable the IPv6 DHCP server.

The problem then immediately disappeared.

I'm not particularly bothered about IPv6 functionality just yet.. I'll look further into this when I've got some free time.

Back to Slackware tweaking... Devuan next..

Bodge99
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
dual band usb wifi stick Slakerlife Slackware 3 11-07-2016 11:02 AM
help with wifi driver Intel® Dual Band Wireless-AC 3160 cwc Linux - Hardware 8 08-17-2014 09:26 AM
atheros AR5B93 setup for 5GHz Dual Band keratos Linux - Hardware 7 04-12-2014 04:25 AM
Starting SoftAP mode in 5GHz band alok_aggarwal Linux - Wireless Networking 3 08-16-2012 01:44 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 01:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration