-   Linux - Wireless Networking (
-   -   Weird errors with MA111 on FC 2 (

ssimontis 09-15-2004 06:37 AM

Weird errors with MA111 on FC 2
Last night, I download the wlan-driver-ng package so I could use my Netgear MA111 USB adapter. Everything compiled okay, and the wlan script executed correctly. When I restarted the computer, the power light of the adapter came on. I then went to the networking utility to configure the device. It informed me that it couldn't get an IP address for the advice. After this, the power light for the device turned off. Puzzled, I restarted. When I restarted, it remained the same. Under networking, I selected the option to activate this device upon startup option, and restarted again to see if I had better luck. Still, it didn't work. While Fedora Core was starting up, I switched my mouse and the MA111 to different USB spots. Like before, the MA111 was still off, but the mouse worked fine. I did see an error this time. After FC2 initialized and the screen was at the text login waiting to launch the graphical login, three errors regarding USB popped up. However, I was unable to read them in time. I then checked the lsusb output. It detected the mouse and nothing else. I switched the mouse and the MA111 again. lsusb still reported that the mouse was in its new slot, but the MA111 didn't exist. Does anyone have any ideas? Thanks in advanced. Below is my system specs in case it helps.

FC2 with kernel
AMD Athlon XP 2000+
FIC AU13 nForce 2 mobo
1024MB PC-2700 RAM
40GB 7200 RPM Maxtor IDE HD
ATI Radeon 9200 SE 64MB

ssimontis 09-15-2004 04:10 PM

I found some things out. It wasn't working because all the configuration files got deleted somehow. I went back and recreated them, ran /etc/init.d/wlan, and things were back to normal. The light on the adapter now comes on, showing that it is on. However, I still cannot get an IP address. When I run iwconfig, I am told that the device has none of my devices, including wlan0, have wireless extensions. What is wrong here? I did notice one thing that puzzled me. In the file /etc/sysconfig/network-scripts/ifcfg-wlan0, I noticed that TYPE is set to Ethernet. Should it be set to Wireless or something similar for it to function?

jarrywhu 09-18-2004 05:23 AM

I am puzzled too,I have problem in making it work in red hat linux-2.6.3,by the way,how did you install the driver?I installed linux-wlan-ng-0.2.1-pre20 according with the "how to",but I failed!who can help?

ssimontis 09-18-2004 09:24 AM

I did everything okay, but don't know the problem. My hard drive failed, so i can't go back to Linux for a while and try again.

All times are GMT -5. The time now is 11:17 PM.