LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (https://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   USB Network Interface Card: HELP! (https://www.linuxquestions.org/questions/linux-wireless-networking-41/usb-network-interface-card-help-353206/)

Saketh 08-14-2005 02:15 PM

USB Network Interface Card: HELP!
 
I have a Linksys Wireless-G WUSB54G NIC. This receives a signal from my Linksys router, which is connected to my Westell Modem. I'm using Fedora Core 3.

I downloaded and compiled ndiswrapper, got the .inf drivers. It says this when I do ndiswrapper -l.
Quote:

Installed ndis drivers:
wusb54g driver present, hardware present
But now it says this when I do iwconfig:
Quote:

lo no wireless extensions.

eth0 no wireless extensions.

Warning: Driver for device wlan0 recommend version 18 of Wireless Extension,
but has been compiled with version 16, therefore some driver features
may not be available...

wlan0 IEEE 802.11g ESSID:off/any Nickname:"localhost.localdomain"
Mode:Ad-Hoc Frequency:2.437GHz Cell: 00:00:00:00:00:00
Bit Rate=2Mb/s
RTS thr=2432 B Fragment thr=2346 B
Power Management:off
Link Quality:100 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:967 Missed beacon:0

sit0 no wireless extensions.
I would just set up a PPPoE connection for my Verizon DSL internet, but eth0 is not working. According to system-config-network, wlan0 is active, but there is no eth0.

My computer does not use a PCI Ethernet card. It only uses the USB Linksys NIC adapter. I am very confused about getting my internet connection to work through the router.

I was under the impression that my adapter should be eth0, but I don't have the option of converting it from wlan0 to eth0.

The Internet works when I'm on my Windows partition, but not for Linux.

Pleeeeeeeeeaaaaaaaaaaaaaaase help. I am very much in need of it.

kz26 08-14-2005 04:07 PM

iwconfig is saying you are in ad-hoc mode. If you have a router, shouldn't you set it to infrastructure/managed mode?

Also, the device names eth0/wlan0 doesn't make a difference.

Saketh 08-14-2005 06:26 PM

According to my router settings, it's in Ad-Hoc mode. Should this be changed?

Also, when I'm creating a new xDSL connection, it doesn't give me the option of using my wireless NIC. It forces me to use ethX, where X is a digit.

Arrowx7 08-14-2005 10:12 PM

lol,
First change it to managed mode, see if it solves the problem:
iwconfig wlan0 mode managed
I would really advise you to leave wlan0 if it was set as default by the driver, but if you really want to change:
you can change it under /etc/network-scripts/
find a file called ifcfg-wlan0.
mkdir backup
cp ifcfg-wlan0 backup/.
mv ifcfg-wlan0 ifcfg-ethX (where X is the number of network device that's not in use)
nano ifcfg-ethX
change NAME=wlan0 to ethX
F2 to exit and save
then you need to change /etc/modprobe.conf (or /etc/modules.conf if you use Debian) and change whereever you see wlan0 to ethX
make sure you back up all those files before you screw them up :)
now "service network restart"
see what you get, you may have to reboot.

Saketh 08-15-2005 08:16 AM

The driver set it to ndiswrapper(wlan0) by default, so I don't think I'll change it.

However, you are telling me to change the mode on Linux into Managed mode. Should I change it to Managed in my router settings? That's strange...I can't find Managed mode in my router settings. I can't find Ad-Hoc either! It gives me the options of:
  • Disabled
  • Mixed
  • B-Only
  • G-Only
I am unable to locate Managed mode. Or is managed mode just a client thing?

Also, I have a Windows partition that has an internet connection through the router. I don't want to disable this internet connection by changing something in the settings. However, getting the Linux internet connection is first priority.

I assume that when it says wlan0 is active, that the settings are all correct? That I just need to configure xDSL?

Arrowx7 08-15-2005 11:22 AM

from the looks of you iwconfig, your card supports only g connections. Make sure it's set to "G-only" then in the router. And in the linux run:
iwconfig wlan mode managed
then try to set your essid:
iwconfig wlan0 essid <youressidname>
run dhclient wlan0 and see if you can fetch the IP

Saketh 08-16-2005 01:24 PM

I'm using Fedora Core 3, so I decided to use the GUI to do what you asked me to do.

dhclient wlan0 does this, I don't know if it's good or bad:
Quote:

Internet Systems Consortium DHCP Client V3.0.1
Copyright 2004 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

sit0: unknown hardware address type 776
sit0: unknown hardware address type 776
Listening on LPF/wlan0/00:0f:66:71:54:70
Sending on LPF/wlan0/00:0f:66:71:54:70
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 18
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 2
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
Here are some screenshots that may be helpful in solving my problems.

Network Devices:
http://img248.imageshack.us/img248/1...figuration.png
Wireless Device Settings:
http://img248.imageshack.us/img248/4...viceconfig.png
General Wireless Settings:
http://img248.imageshack.us/img248/5...iceconfig1.png

Saketh 08-16-2005 09:19 PM

Also, my router is a WRT54G if that helps at all.

My ISP is Verizon, and that might be a problem seeing as how Verizon does not support Linux (directly).

The main issue here is connecting to the Internet. It's not physically possible for me to attach a wire from the computer to the modem. Wireless is the only way to go.


All times are GMT -5. The time now is 02:39 PM.