-   Linux - Wireless Networking (
-   -   Unable to set encryption key Cisco Aironet 350, RH 8.0 (

arbit0 05-23-2004 12:53 PM

Unable to set encryption key Cisco Aironet 350, RH 8.0

I am trying to set up a Cisco Aironet 350 wireless adapter on a RH 8.0 laptop in "Managed" mode. Using iwconfig, I am able to set the ESSID, channel, rate, etc., but I am simply unable to set the encryption key and the AP. The encryption key is always shown as ****-****-****-** and the AP is always shown as FF:FF:FF:FF:FF:FF. I am thus unable to ping the AP. I used the exact same iwconfig and ifconfig commands to set up a Lucent Orinoco Gold wireless adapter, BTW, and it worked just fine. I used the following two commands:

iwconfig eth1 essid "<my_essid>" enc s:<my_128bit_WEPenckey_in_ascii> rate 2M
ifconfig eth1 up

(My AP's IP is

For the Lucent Orinoco card, the above two commands work fine; I don't even need to enter the AP's MAC address or the channel frequency. For the Cisco Aironet 350, the encryption key and AP simply do not register with the firmware, it appears. I even tried to add the 'ap' and 'channel' options to the iwconfig command. The channel registered with the firmware, the AP's MAC address didn't.

I am also getting the "driver has been compiled using version 16 of wireless extension, this program has been compiled using version 13" message when I run iwconfig, but I paid no attention to it since I was able to get my Lucent Orinoco adapter to work just fine regardless.

I don't know where to start solving this problem - get a new iwconfig version, upgrade the firmware in the card, problem with the driver, something wrong in the way I'm using the config programs? I've spent a couple of days on this already - any help will be greatly appreciated.


2Gnu 05-23-2004 07:40 PM

I've no experience with Cisco, so take this with a grain of salt. I've seen several posts that were solved by back-revving the firmware on the Cisco card. No idea from what or to what, but maybe this will get you started.
Good luck.

All times are GMT -5. The time now is 02:25 PM.