LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 10-10-2009, 02:10 AM   #1
Perrorist
LQ Newbie
 
Registered: Oct 2009
Location: Australia
Distribution: Ubuntu
Posts: 15

Rep: Reputation: 0
Unable to get wireless LAN working in Ubuntu 9.10


I installed Ubuntu 9.10 beta over 9.04 yesterday and that meant getting the wireless network to fire up again. The Ubuntu machine is on a LAN and has a fixed address (192.169.0.7).

I installed the driver without difficulty, but the only way I could get a LAN and Internet connection with a fixed IP was to remove DHCP and change etc/network/interfaces as follows:

auto wlan0
iface wlan0 inet static
address 192.168.0.7
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.1

The router is 192.168.0.1.

I then changed (actually added, as it must have disappeared when I removed DHCP) resolv.conf with the following:

search NETGEAR
address 192.168.0.1

where NETGEAR is the SSID of the router (though I'm not sure if this is the domain. The machine name is Ubuntu but it's not a name server).

For some reason, it's not connecting. Checking Network Tools, the static IP is recognised and it has the correct MAC. Ditto, when I look at ipconfig for wlan0.

Can anyone point out what I've missed out or got wrong?
 
Old 10-10-2009, 07:28 AM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 420Reputation: 420Reputation: 420Reputation: 420Reputation: 420
I suspect that you haven't set a gateway. Check the output of route -n, and if your router isn't set as the gateway try running this:

route add default gw 192.168.0.1


and hopefully that will get you going.
 
Old 10-10-2009, 05:46 PM   #3
Perrorist
LQ Newbie
 
Registered: Oct 2009
Location: Australia
Distribution: Ubuntu
Posts: 15

Original Poster
Rep: Reputation: 0
route -n gave me this:

Code:
Destination  Gateway     Genmask       Flags Metric Ref Use Iface
192.168.0.0  0.0.0.0     255.255.255.0  U        0   0   0  wlan0
169.254.0.0  0.0.0.0     255.255.0.0    U     1000   0   0  wlan0
0.0.0.0      192.168.0.1 0.0.0.0        U      100   0   0  wlan0
After I added the route I got an extra line:

Code:
0.0.0.0      192.168.0.1 0.0.0.0        U        0   0   0  wlan0
Clearly something is stuffed but I don't know how or what.

Last edited by Perrorist; 10-10-2009 at 08:06 PM.
 
Old 10-10-2009, 10:07 PM   #4
rkski
Member
 
Registered: Jan 2009
Location: Canada
Distribution: CentOS 6.3, Fedora 17
Posts: 247

Rep: Reputation: 51
Quote:
search NETGEAR
address 192.168.0.1
should be:
Quote:
search yourISPdomain_goes_here
nameserver 192.168.0.1
Also you could keep DHCP and assign a static address to a particular MAC in the router config.
 
Old 10-10-2009, 10:26 PM   #5
Perrorist
LQ Newbie
 
Registered: Oct 2009
Location: Australia
Distribution: Ubuntu
Posts: 15

Original Poster
Rep: Reputation: 0
Thanks, I thought that might be wrong. I've changed it and restarted the network. I got 'RTNETLINK answers: No such process' and another message, but route -n showed the correct info.

I'm also getting the Wireless Network Authentication Required dialog. Entering the WEP key causes it to try to connect and then the dialog box reappears.
 
Old 10-10-2009, 10:32 PM   #6
Perrorist
LQ Newbie
 
Registered: Oct 2009
Location: Australia
Distribution: Ubuntu
Posts: 15

Original Poster
Rep: Reputation: 0
BTW, I've also added the ESSID, channel, mode, etc info into the etc/network/interfaces file.
 
Old 10-10-2009, 11:33 PM   #7
rkski
Member
 
Registered: Jan 2009
Location: Canada
Distribution: CentOS 6.3, Fedora 17
Posts: 247

Rep: Reputation: 51
Hi,

First, which wireless card do you have & did you install the driver correctly for the new Ubuntu version?

Second, try connecting without WEP (which isn't great security to begin with, should investigate WPA2 later) to see if that's the problem.

Also post the output of
Code:
iwconfig
ifconfig
cat /etc/network/interfaces
I should say i'm not familiar with the ubuntu way of doing things but that shouldn't matter much.

Also have a look at this link:
http://www.linuxquestions.org/questi...errors-637610/

Also show output now of
Quote:
route -n

Last edited by rkski; 10-10-2009 at 11:47 PM.
 
Old 10-11-2009, 04:39 AM   #8
Perrorist
LQ Newbie
 
Registered: Oct 2009
Location: Australia
Distribution: Ubuntu
Posts: 15

Original Poster
Rep: Reputation: 0
I came to the conclusion that something was screwed with my installation of 9.10 beta, so I reinstalled it from scratch. I installed the driver using ndiswrapper (something I've done umpteen times in different versions of Ubuntu) and did a ndiswrapper -m to make sure the driver would load with a reboot. I ran iwconfig and wlan0 was definitely there.

I rebooted. Guess what? No wlan0.

I re-ran ndiswrapper -m and it said the alias was already configured.

I wish I could make sense of this.
 
Old 10-11-2009, 02:29 PM   #9
xcristi
Member
 
Registered: Sep 2005
Distribution: Slackware
Posts: 35

Rep: Reputation: 16
After reboot what ndiswrapper -l say?
What about ifconfig -a ? wlan0 still missing?
 
Old 10-11-2009, 02:47 PM   #10
Perrorist
LQ Newbie
 
Registered: Oct 2009
Location: Australia
Distribution: Ubuntu
Posts: 15

Original Poster
Rep: Reputation: 0
Initially, nothing. I restarted the network and it showed eth0 with most of the static details I'd entered for wlan0 before I re-installed from scratch. So much for a clean install... resolv.conf was also the same.

I changed eth0 to wlan0 in the interfaces file, restarted the network, and the wireless option came up at the top of the GUI screen, showing a number of local access points, including NETGEAR, which I clicked. It cogitated for a while, prompted me for the WEP key, cogitated again, prompted me for the WEP key... In other words, I was no better off.

I can't get the system to acknowledge my Corsair USB stick, otherwise I'd dump all the data and show it here.

One thought I have is to try the wired option and see if that's successful.
 
Old 10-11-2009, 05:01 PM   #11
Perrorist
LQ Newbie
 
Registered: Oct 2009
Location: Australia
Distribution: Ubuntu
Posts: 15

Original Poster
Rep: Reputation: 0
Found a portable drive and captured the output. From bootup:

Code:
ROUTE -N

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 wlan0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlan0
0.0.0.0         192.168.0.1     0.0.0.0         UG    100    0        0 wlan0

IWCONFIG:

wlan0     IEEE 802.11g  ESSID:off/any  
          Mode:Managed  Channel:0  Access Point: Not-Associated   
          Bit Rate:1 Mb/s   Sensitivity=-200 dBm  
          RTS thr=2346 B   Fragment thr=2346 B   
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

IFCONFIG:

eth0      Link encap:Ethernet  HWaddr 00:11:85:e5:da:ae  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:17 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:14 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1170 (1.1 KB)  TX bytes:1170 (1.1 KB)

wlan0     Link encap:Ethernet  HWaddr 00:0f:b5:f4:46:fc  
          inet addr:192.168.0.7  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:18 Memory:f0510000-f0520000 

ETC/NETWORK/INTERFACES

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto wlan0
iface wlan0 inet static
	address 192.168.0.7
	netmask 255.255.255.0
	network 192.168.0.0
	broadcast 192.168.0.255
	gateway 192.168.0.1
	# dns-* options are implemented by the resolvconf package, if installed
	dns-nameservers 192.168.0.1
	dns-search internode.on.net

RESOLV.CONF

search internode.on.net
nameserver 192.168.0.1
The GUI menu said there was no managed wireless available. I restarted the network (no errors) and tried again. Still no wireless available. So I've gone back a step.
 
Old 10-12-2009, 07:24 AM   #12
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 420Reputation: 420Reputation: 420Reputation: 420Reputation: 420
Quote:
IWCONFIG:

wlan0 IEEE 802.11g ESSIDff/any
Mode:Managed Channel:0 Access Point: Not-Associated
Bit Rate:1 Mb/s Sensitivity=-200 dBm
RTS thr=2346 B Fragment thr=2346 B
Power Managementff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
Everything looks good except for this. Bascially, it looks like the wireless card has not been configured. Essentially you need to run two iwconfig commands (as root):

iwconfig essid wlan0 YourESSID
iwconfig key wlan0 YourWEPKeyInHex

or

iwconfig key wlan0 s:YourWEPKeyInText

Try that and see if you get going.
 
Old 10-12-2009, 05:19 PM   #13
Perrorist
LQ Newbie
 
Registered: Oct 2009
Location: Australia
Distribution: Ubuntu
Posts: 15

Original Poster
Rep: Reputation: 0
Thumbs up

That did the trick. Many thanks for your help (you, too, rkski).

BTW, the iwconfig command requires wlan0 to be the first argument.
 
Old 11-01-2009, 10:56 PM   #14
jiapei100
Member
 
Registered: Jan 2005
Location: Surrey, BC, Canada
Distribution: Ubuntu 12.04
Posts: 69

Rep: Reputation: 15
Unhappy Sorry, my problem continued, please help!!

Please can anybody give me a hand?

I just installed Ubuntu 9.10 and I'm now not able to use internet.

Code:
jiapei@jiapei-laptop:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11abg  ESSID:"Tiscali12D18F"  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:on



jiapei@jiapei-laptop:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:40:d0:a9:19:ff  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:240 (240.0 B)  TX bytes:240 (240.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:19:d2:7c:1b:71  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)



jiapei@jiapei-laptop:~$ cat /etc/network/interfaces
auto lo
iface lo inet loopback


jiapei@jiapei-laptop:~$ lshw -C network
WARNING: you should run this program as super-user.
  *-network               
       description: Wireless interface
       product: PRO/Wireless 3945ABG [Golan] Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 02
       serial: 00:19:d2:7c:1b:71
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwl3945 latency=0 multicast=yes wireless=IEEE 802.11abg
       resources: irq:29 memory:aa100000-aa100fff
  *-network
       description: Ethernet interface
       product: PRO/100 VE Network Connection
       vendor: Intel Corporation
       physical id: 8
       bus info: pci@0000:09:08.0
       logical name: eth0
       version: 02
       serial: 00:40:d0:a9:19:ff
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical
       configuration: broadcast=yes driver=e100 driverversion=3.5.24-k2-NAPI firmware=N/A latency=64 maxlatency=56 mingnt=8 multicast=yes
       resources: irq:20 memory:a4000000-a4000fff ioport:1200(size=64)
Looking forward to your reply.

Best Regards
JIA
 
Old 11-02-2009, 07:09 AM   #15
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 420Reputation: 420Reputation: 420Reputation: 420Reputation: 420
Quote:
wlan0 IEEE 802.11abg ESSID:"Tiscali12D18F"
Mode:Managed Access Point: Not-Associated Tx-Power=15 dBm
Retry long limit:7 RTS thrff Fragment thrff
Power Managementn
It looks like you haven't configured your wireless connection. I don't use Ubuntu, but I think you do it through Network Manager.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to enable wireless lan JoahSun Red Hat 1 08-22-2009 06:12 PM
unable to configure W-LAN Adapter(Sinus 154 data II + Ubuntu) Black Bird Linux - Wireless Networking 7 05-05-2008 08:38 AM
Unable to access internal LAN from outside Belkin wireless router tedthened Linux - Wireless Networking 3 01-31-2008 02:54 PM
Cant get the wireless lan working Sonny89 Linux - Wireless Networking 1 12-06-2005 08:24 AM
neither wireless or lan is working... pAn1k Linux - Wireless Networking 2 12-01-2004 08:22 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 02:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration