-   Linux - Wireless Networking (
-   -   Unable to get wifi working on acer aspire with Atheros AR9285 (

ledatica 09-03-2011 10:20 AM

Unable to get wifi working on acer aspire with Atheros AR9285
have the same problem as some one else with debian squeeze earlier a while ago. I get the same message as below

my-comp:/home/myuser# iwconfig
lo no wireless extensions

eth0 no wireless extensions

wmaster0 no wireless extensions

wlan0 IEEE 802.11bg ESSID: ""
Mode: Managed Frequency:2.437Ghz Access Point: Not-Associated
Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

pan0 no wireless extensions

There were several suggestions on adding contrib non-free and similar sopurce lists and doing an update. Another suggestion was to apt get firmware:ath9

did all that and still no luck. Any suggestions?

LBM 09-03-2011 09:55 PM

Which kernel are you running? It must be 2.6.29 or newer, then you can use the builtin ath9k module.

Secondly, check this.

ledatica 09-07-2011 06:14 AM

wifi not working on squeeze
Thanks. Yes the kernel is the same. I already tried the procedure outlined in the link you posted. I was on that link before and followed the procedure. May be I will try that again and check my steps. will post the result here. Thanks again

All times are GMT -5. The time now is 11:28 AM.