-   Linux - Wireless Networking (
-   -   unable to do modprobe ndiswrapper in knoppix 6.0.1 (

blindndangerous 11-10-2009 11:53 PM

unable to do modprobe ndiswrapper in knoppix 6.0.1
Hello all,
I'm a total newbie at linux. I've used ubuntu 8.10, and 9.04, mostly because of their accessibility. I am now trying out knoppix 6.0.1, and am so far liking it. However, when I tried to get ndiswrapper working something goes wrong.
I have a dell e5400 with a n N wireless card. I can't remember its exact name off of the top of my head right now. I am trying to get it working with ndiswrapper, and here's what I've done so far.
ndiswrapper -i bcmwlf6.inf
driver installs.
modprobe ndiswrapper
Fatal: module ndiswrapper can not be found.
So, I did a bit of searching around, and did the following command.
modinfo ndiswrapper
Unable to find ndiswrapper
modinfo usbcore
unable to find usbcore.
So then I think ok, lets just start over complete from scratch.
dpkg -r ndiswrapper
Ignoring request to remove ndiswrapper because it can not be found.
but if I do
It still shows up, same if I do
ndiswrapper -l
It still shows that my driver is installed.
So I guess my question is, why can't I use modprobe ndiswrapper? I looked around, but all I found was things that were extremely old, and didn't seem to help. I did try ndiswrapper -m, and recieved an error saying that update-modules was depricated and should not be used. So now I'm at a complete loss for what I should do. Should I see if ndiswrapper has a newer version? I have common 1.53 and utils 1.9 on my jump drive. Should I just reinstall knoppix and try again? If anyone can help, it'd be greatly appreciated.
I also tried bridging my ethernet and wireless connections, then hooking one end of my ethernet cable into my windows7 laptop, and the other end into my linux laptop but that didn't do anything either. This was the first thing I did before just trying ndiswrapper, since my college has a bit of an odd setup if you want to get on wireless, and I thought that since I was already logged on to my campus's wireless with windows that it would work if I bridged and tried it that way. It did work when I was looking at linux mint7 as that was how I installed orca.

nimnull22 11-11-2009 09:01 AM

Take a look:

All times are GMT -5. The time now is 02:37 AM.