-   Linux - Wireless Networking (
-   -   Unable to connect to wireless networks on HPG60 running Linux Mint 11 (

Micheil 01-01-2012 06:53 PM

Unable to connect to wireless networks on HPG60 running Linux Mint 11
Let me start from the beginning.
I recently upgraded my laptop from Linux mint 7 to Mint 11. Back on mint 7, I could connect to wireless networks right out of the box, with no problems. Now, whenever I click on the network manager, it will either tell me that the wireless is disabled by a hardware switch or simply not enabled.
When it claims that a hardware switch is disabling wireless, I can easily fix the problem.
When the wireless is simply not enabled, however, I can click on the option "enable wireless". The first few times I did this, the menu would close, and upon re-opening it, I would find that the wireless was still enabled. However, I could not connect to any networks as it said that wireless was still disabled. After about 5 minutes, if I checked it again, the "enable wireless" option was no longer checked off.
Earlier today, I tried again to find that the option stayed checked for several hours, and has remained so since. However, I am still unable to connect as it still says that wireless is disabled under wireless networks.

I'm currently using an Ethernet cable that's tethered directly to my modem, and have about 6 feet of distance. Being a person who can't stay in one part of my house for long but needs to get work done, wireless was extremely important to me, and I would be extremely gratefull eif anybody could help me fix this problem.


tvphil 01-03-2012 12:17 AM

This problem might need more info about your network config (encryption type, g or n speed router, etc.). For now, lets try something simple. Go to "edit connections", delete your current network connection (all of them, if there are more than one). Then restart your computer, let it find your network and enter the ssid and the network key (if your using one). Once it connects, then restart again and see if it holds the connection. If that doesn't work, do it again, only this time shut the computer down and the router. Wait a minute, power the router back up and then the computer. This should assign a new ip address for your computer on your network. No guarantees this will cure this problem, but it has for mine in the past.

gloeppky 01-03-2012 07:35 AM

One issue that came up with Ubuntu 11.04 and 11.10 was that wireless N has flaky behavior. Once I turned off wireless N on my router all my wireless connections became stable. The type of problem you describe is exactly the problem that I experienced. When researching the problem there were a couple of solutions but none that worked reliably for me other than turning wireless N off. I guess it's the new Network Manager that is flaky for Ubuntu. I don't know if the same applies for Mint or maybe it was my routers I can't say for sure.

All times are GMT -5. The time now is 07:59 PM.