LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 04-05-2005, 05:54 PM   #1
MarkR
LQ Newbie
 
Registered: Aug 2004
Distribution: Dapper Ubuntu
Posts: 10

Rep: Reputation: 0
Ubunto found my card, now what?


Im running ubunto on a compaq laptop with a orinoco / proxim 802.11 a/b combo card (8460-05). It's detected in ubunto as an atheros chipset, which I believe is right. It wan't able to detect my wireless windows network during the auto configuration, and i'm a bit of a novice with networking in linux. Bit more so than in windows anyway! It show up as ath0 , I configured my network name to be the network name, removed any wep for the time being, set it to use dhcp and crossed my fingers. It's active but I don't get any network connection, no pings etc. My setup on the network is pretty simple, just windows xp desktop with a cnet wireless pci card sharing a dsl connection through an ad hoc network.

If you're worried about dumbing it down to much for me don't.



mark@notebook:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

ath0 IEEE 802.11 ESSID:"wireless"
Mode:Ad-Hoc Frequency:5.765 GHz Cell: 02:20:A6:4C:1A:3E
Bit Rate:0 kb/s Tx-Power:50 dBm Sensitivity=0/3
Retryff RTS thrff Fragment thrff
Power Managementff
Link Quality=0/94 Signal level=-95 dBm Noise level=-95 dBm
Rx invalid nwid:111 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:33 Invalid misc:33 Missed beacon:0

sit0 no wireless extensions.

and ifconfig gives me

mark@notebook:~$ ifconfig
ath0 Link encap:Ethernet HWaddr 00:20:A6:4C:1A:3E
inet6 addr: fe80::220:a6ff:fe4c:1a3e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:305 errors:479 dropped:0 overruns:0 frame:479
TX packets:1118 errors:33 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:199
RX bytes:22400 (21.8 KiB) TX bytes:144881 (141.4 KiB)
Interrupt:11 Memory:d7ac0000-d7ad0000

lo Link encap:Local Loopback
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:44059 errors:0 dropped:0 overruns:0 frame:0
TX packets:44059 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3034443 (2.8 MiB) TX bytes:3034443 (2.8 MiB)

sit0 Link encap:IPv6-in-IPv4
inet6 addr: ::127.0.0.1/96 Scope:Unknown
inet6 addr: ::192.168.1.1/96 Scope:Compat
UP RUNNING NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:106 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
 
Old 04-05-2005, 09:51 PM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 420Reputation: 420Reputation: 420Reputation: 420Reputation: 420
Quote:
mark@notebook:~$ ifconfig
ath0 Link encap:Ethernet HWaddr 00:20:A6:4C:1A:3E
inet6 addr: fe80::220:a6ff:fe4c:1a3e/64 Scope:Link
It looks to me like dhcp isn't working right since you have an inet6 address instead of the normal inet4.

So here is one thing to try. Using ifconfig, assign a static IP address to your card like this:

ifconfig ath0 xxx.xxx.xxx.xxx

Just replace the xxx bit with an IP address that your router will understand.

Next, use the route command to set your gateway to your router's IP address.

route add default gw yyy.yyy.yyy.yyy

Finally, open up your /etc/resolv.conf file in a text editor and add a line for each of your ISP's nameservers

nameserver zzz.zzz.zzz.zzz

Save it and then you should be good to go. If this works, then the problem is with dhcp and not your card configuration.
 
Old 04-06-2005, 06:23 PM   #3
MarkR
LQ Newbie
 
Registered: Aug 2004
Distribution: Dapper Ubuntu
Posts: 10

Original Poster
Rep: Reputation: 0
Had it working for a while, but messed up again. Kicking myself repeatedly. :-) Setting up a static ip address did work, as i got google up, but it was crawling on my 1mb line. I tried changing things and went too far! Think it might be easier to start from scratch. What should I set up my wireless nic's ip address / subnet / gateway etc? Ditto for my laptop if you can. Windows is able to see the laptop's wireless connection (it's essid is the mac address).

Thanks. Back to puzzling!
 
Old 04-06-2005, 07:04 PM   #4
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 420Reputation: 420Reputation: 420Reputation: 420Reputation: 420
I'm not entirely sure I understand what you're asking, but here is a rip at it


Quote:
What should I set up my wireless nic's ip address / subnet / gateway etc?
The IP address needs to be in the range that your router understands. For most home routers that tends to be 192.168.x.x. Have a look at your router's documentation to see what it uses. Subnet is almost always 255.255.255.0. The gateway needs to be the router's IP address. Again, have a look at your router's documentation.

Each card (whether wireless or wired) needs its own IP address so don't issue the same IP to all your cards. Also, it probably isn't a good idea to have both a wired and a wireless connection going at the same time. Pick one and don't use the other.

As for the crawling speed, I'm really not sure what could be causing that. If the problem continues, it might be worth installing ethereal and watching what packets are getting flung around your network. However, be sure to set up your resolv.conf right. A mis-configured file can actually have some pretty nasty effects.
 
Old 04-07-2005, 02:30 PM   #5
MarkR
LQ Newbie
 
Registered: Aug 2004
Distribution: Dapper Ubuntu
Posts: 10

Original Poster
Rep: Reputation: 0
I'm not actually using a router, the base computer has a wireless network card, and a wired network card. The wired network card has the adsl modem attached. This is where i'm probably making the mistake. I assume that both of these network cards would have ip's of 192.168.1.1 and 192.168.1.2, but which would be the default gateway?
 
Old 04-07-2005, 04:06 PM   #6
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 420Reputation: 420Reputation: 420Reputation: 420Reputation: 420
Ah, OK, that changes everything. And actually if I had been paying attention to your first post, you said that. Since you are running wireless as an ad hoc network, I don't think you're not going to be able to reach the internet from the laptop through the XP machine. Ad hoc mode is really meant for computer to computer connections, kind of like a wireless version of a crossover cable. Now I know diddly about configuring an XP box to act as a router (which is really what you are asking it to do). However, for configuring the laptop, the wireless card on the XP box should be the gateway.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubunto 4.10 No Sound mookie2125 Ubuntu 4 07-13-2005 12:12 AM
Thinking about using ubunto (A few questions). RoaCh Of DisCor Ubuntu 2 06-27-2005 05:48 PM
using ubunto with MDK and W98. d1l2w3 Ubuntu 0 05-19-2005 09:58 AM
migrante to ubunto migu Ubuntu 7 04-11-2005 09:17 PM
ubunto:gui flynnki Linux - Distributions 6 01-24-2005 12:13 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 09:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration