-   Linux - Wireless Networking (
-   -   trying wireless for the first time (

radiodee1 08-07-2007 09:33 AM

trying wireless for the first time
I'm trying to connect to my wireless router at school. I'm not sure what I'm doing wrong, but it's probably a simple problem. Maybe somebody could look at this and help me out. I have to modprobe bcm43xx right now, so the network is not up automatically when I reboot. eth2 is in my 'interfaces' file, though.


# ifup eth2
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit

Listening on LPF/eth2/00:19:7e:bd:d7:ca
Sending on  LPF/eth2/00:19:7e:bd:d7:ca
Sending on  Socket/fallback
DHCPDISCOVER on eth2 to port 67 interval 3
DHCPDISCOVER on eth2 to port 67 interval 3
DHCPDISCOVER on eth2 to port 67 interval 8
DHCPDISCOVER on eth2 to port 67 interval 10
DHCPDISCOVER on eth2 to port 67 interval 15
DHCPDISCOVER on eth2 to port 67 interval 9
DHCPDISCOVER on eth2 to port 67 interval 12
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

this is iwconfig:


# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

Warning: Driver for device eth2 has been compiled with version 22
of Wireless Extension, while this program supports up to version 20.
Some things may be broken...

eth2      IEEE 802.11b/g  ESSID:"newpaltz"  Nickname:"Broadcom 4311"
          Mode:Managed  Frequency=2.462 GHz  Access Point: 00:11:5C:DD:1F:90 
          Bit Rate=24 Mb/s  Tx-Power=18 dBm 
          RTS thr:off  Fragment thr:off
          Encryption key:off
          Link Quality=61/100  Signal level=-69 dBm  Noise level=-62 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0  Missed beacon:0

finally this is 'interfaces'

# cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

iface ppp0 inet ppp
provider ppp0

auto eth2
iface eth2 inet dhcp

Occasionally I try 'dhclient eth2' but that says the same as 'ifup eth2' for the most part. I'm really not sure what I'm doing wrong, so If anyone knows, I'd really appreciate it. Thanks. :)

EDIT: My profile says 'Debian Etch' but I'm using a 2.6.22 stock kernel from unstable. I read that in 2.6.18 bcm43xx didn't work well - and I couldn't get it to work either - but I think bcm43xx should work with this kernel.

EDIT: My card is a Dell Wireless 1390. Another post mentions the same card. I will watch both posts.

raskin 08-08-2007 02:20 AM

First, what does 'iwlist scan' give?
Install wireless_tools from unstable - just to match wireless extensions version.
Rest assured that even if you fail to configure bcm43xx quickly, you will be able to use your wireless card with Windows drivers using ndiswrapper.

radiodee1 08-08-2007 08:54 AM

This is the output of 'iwlist scan' after 'iwconfig eth2 essid newpaltz' and 'modprobe bcm43xx':

# iwlist scan
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

eth2      Scan completed :
          Cell 01 - Address: 00:11:5C:DD:1F:90
                    Protocol:IEEE 802.11bg
                    Frequency:2.462 GHz (Channel 11)
                    Encryption key:off
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Quality=85/100  Signal level=-68 dBm  Noise level=-60 dBm
                    Extra: Last beacon: 4ms ago
          Cell 02 - Address: 00:11:5C:DC:D7:E0
                    Protocol:IEEE 802.11bg
                    Frequency:2.412 GHz (Channel 1)
                    Encryption key:off
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Quality=75/100  Signal level=-80 dBm  Noise level=-60 dBm
                    Extra: Last beacon: 9224ms ago

(I tried to install wireless-tools and libiw29 from unstable using dpkg, but it notified me that newer libc6 was needed. I don't know if I should try using libc6 from testing, since I think it would satisfy the pre-requisites - but would it break my system? Still, wireless-tools seemed to install, and in the end dpkg only complained that it was going to leave wireless-tools unconfigured. I hope that doesn't mean the program is now broken.)

'iwconfig' lists the same as before but only without the warning. 'dhclient eth2' returns the same as before. Thanks.

raskin 08-08-2007 11:05 AM

What is in dmesg output about bcm43xx ?

radiodee1 08-08-2007 03:36 PM

Well, I'm at home now, BUT maybe this will be helpfull. This is the output from dmesg after I removed bcm43xx from '/etc/modprobe.d/blacklist' from home with no wireless router nearby. First it says this:


bcm43xx driver
then it says this:


bcm43xx: Chip ID 0x4311, rev 0x1
bcm43xx: Number of cores: 4
bcm43xx: Core 0: ID 0x800, rev 0x11, vendor 0x4243
bcm43xx: Core 1: ID 0x812, rev 0xa, vendor 0x4243
bcm43xx: Core 2: ID 0x817, rev 0x3, vendor 0x4243
bcm43xx: Core 3: ID 0x820, rev 0x1, vendor 0x4243
bcm43xx: PHY connected
bcm43xx: Detected PHY: Analog: 4, Type 2, Revision 8
bcm43xx: Detected Radio: ID: 2205017f (Manuf: 17f Ver: 2050 Rev: 2)
bcm43xx: Radio turned off
bcm43xx: Radio turned off

then it says this:


bcm43xx: PHY connected
bcm43xx: Microcode rev 0x118, pl 0x17 (2004-05-06  21:34:00)
bcm43xx: Radio turned on
bcm43xx: Radio enabled by hardware
bcm43xx: Chip initialized
bcm43xx: 32-bit DMA initialized
bcm43xx: Keys cleared
bcm43xx: Selected 802.11 core (phytype 2)

I won't be in school again untill tomorow. Then I will post again.

raskin 08-08-2007 03:40 PM

Looks promising. But signal level less than noise level was alarming. Sorry, noticed only now..

GregLee 08-08-2007 11:40 PM

I've just compared outputs of iwlist/iwscan on my system, and everything seems similar to yours except for the noise level. Mine is -95dBm and yours is -60dBm or -62dBm. So maybe that's the problem. An interfering wireless device perhaps?

radiodee1 08-09-2007 07:49 AM

Thanks for the advice. The solution was that the computer had to be closer to the wireless router... I don't know why the first location worked with Windows Vista and not linux, but it doesn't matter... now I can connect using both. Thanks again.

radiodee1 08-16-2007 02:18 PM

I'm pretty desperate. My wireless worked for a while, but I had to scrap the 2.6.22 kernel I was using, as it took 8 minutes to boot up. I also re-installed. I'm back to square one and am now trying to install ndiswrapper. Please look at this thread and offer any suggestions you might have. I am using a 2.6.18 kernel, and debian etch. The link to the thread is: . For reasons unknown to me people don't want to answer my thread. Maybe my situation is that bad. The thread has been on the forum for several days. Thanks.

All times are GMT -5. The time now is 02:00 AM.