-   Linux - Wireless Networking (
-   -   Trying to load module "ndiswrapper" with modprobe; modprobe ndiswrapper doesn't work! (

Benjamin 05-10-2005 09:52 PM

Trying to load module "ndiswrapper" with modprobe; modprobe ndiswrapper doesn't work!
I've had Linux for about a week, and I'm still trying to get ndiswrapper to work! I have a Microsoft MN-720 card. When I do ndiswrapper -l it says I have the driver and hardware there. But, when I do modprobe ndiswrapper, it says "FATAL: Module ndiswrapper not found." I've tried everything I can think of! Can anyone help me?

[bendreyzen@localhost utils]$ ./ndiswrapper -l
Installed ndis drivers:
mn720-ankh driver present, hardware present
[bendreyzen@localhost utils]$ /sbin/modprobe nidswrapper
FATAL: Module nidswrapper not found.
[bendreyzen@localhost utils]$

From Ben

pengy666 05-11-2005 05:08 PM

what version distro you running ? what wersion ndis you got? what version kernel you got?

it difficult to say what is happenning without enough info??

Benjamin 05-11-2005 11:09 PM

I have Fedora 2.85 I think and I have ndiswrapper v-1.1. My kernel version is 2.6.11-1.14_FC3.

From Ben

rjkfsm 05-12-2005 10:58 AM

I had this error with Debian. Somehow the ndiswrapper module didn't get installed correctly. In Debian, I had to use module-assistant to get it working correctly. I'm not sure what you would use in Fedora.

Edit: I did a little research on Fedora's web site and found that they have "modutils" available as a package, so I added what's below.

Try typing in "modinfo ndiswrapper" and see what you get.

If you get "modinfo: could not find module ndiswrapper", then try, "modinfo usbcore". ndiswrapper depends on usbcore. No usbcore, try "modprobe usbcore" then "modprobe ndiswrapper"

if you do have usbcore and you don't have ndiswrapper, try "update-modules". You may have to reboot after that one, then try "modprobe ndiswrapper"

BTW: When you try to modprobe anything in, you should use: modprobe -n -v --first-time [module-name] to have a dry run to make sure everything will be OK. (NOW we tell you, right?)

If all else fails, try the old school way: "insmod lib/modules/`uname -r`/misc/ndiswrapper.ko". If you get file not found, then ndiswrapper.ko was put in an unusual place. Do a search for it and change the above path to fit.

Note: the ` marks around uname -r are NOT apostrophe's. They are the tick marks located to the left of the number "1" on a US keyboard.


Benjamin 05-12-2005 07:05 PM

Ok, either I'm really clueless or there are some serious problems with ndiswrapper on my computer... Probably both. I tried all of the things you suggested, and nothing did much. It couldn't find usbcore, and it didn't even recognize the command "insmod." It's probably just not in my path, right? Which directory is it in? Also, I did a search for "ndiswrapper" and ".ko" and neither one found ndiswrapper.ko. Geez I'm bad at this stuff...

rjkfsm 05-13-2005 11:38 AM

Try "modprobe -n -v --first-time usbcore". If you don't get any errors, remove the -n switch and do it for real.


Benjamin 05-13-2005 10:35 PM

Still got "FATAL: Could not find module usbcore."

lindberg 05-19-2005 10:10 PM

With ndiswrapper-1.1, I did make rpm, then installed the rpm on FC3, but ndiswrapper.ko did not get installed. I had to:

mkdir /lib/modules/[kernel-version-here]/misc
cd ..../ndiswrapper-1.1
cp driver/ndiswrapper.ko /lib/modules/[kernel-version-here]/misc/
depmod -a
modprobe ndiswrapper

then I saw the devide with iwconfig.

Good luck


choad 06-13-2005 10:30 PM

depmod sort of worked
I was having the same issue as above:

FATAL:Module ndiswrapper not found

Then I moved ndiswrapper.ko to the correct location and ran
depmod -a
modprobe ndiswrapper

Now I get this error:
FATAL:Error inserting ndiswrapper (/lib/modules/ Invalid module format

Does anyone have any suggestions? My specs are below:
Toshiba Portege 7140CT
P-III 500 MHz, 192 MB RAM, 6 GB HD
MiniSlack 1.1 (Kernel
ndiswrapper 1.1
Belkin Wireless PCMCIA card FD7010 54G BroadCom Chipset

Thank you in advance....


samsharp99 06-14-2005 04:27 PM

Erm, im not sure if anyone else noticed, but it looks like he spelt ndiswrapper wrong at the top, not sure if its just he typed it wrong on the forums but hey - it's worth saying...


[bendreyzen@localhost utils]$ /sbin/modprobe nidswrapper

foobar15 02-16-2006 07:30 AM

1. Upgrade your kernel to 2.6.12-1.1381_FC3.
2. install ipw2200-firmware.
3. install kernel-module-ndiswrapper-2.6.12-1.1381_FC3
(Better way is to use yum and install as takes care of the dependencies),
4.install cabextract
5. download the driver SP30290.exe from the winxp site.
6. Unpack the SP30290.exe to some directory. To do so run
$ cabextract SP30290.exe
7. /usr/sbin/ndiswrapper -i bcmwl5a.inf
8. $ /usr/sbin/ndiswrapper -m
It will add an alias to /etc/modprobe.conf

Now you can reboot to have it activated,
or you can run
$ depmod -a
$ modprobe ndiswrapper

Configure using iwconfig.

rjlasser 05-15-2006 11:18 PM

more weirdness with ndiswrapper

After upgrading to Fedora Core 5, ndiswrapper worked perfectly everytime (on an Acer Aspire 5004WLMi). I found the driver for the Broadcom wireless card, followed the ndiswrapper instructions and everything was great.

The other night, I had some work to do but was getting sleepy so I enabled the wireless card and took the laptop into bed. I then did a "yum update". Ever since, when I try to run modprobe I get the ol' "FATAL: Module ndiswrapper not found.".

The softlink to /lib/modules is there, everything looks as it should but still I get the error. Even "ndiswrapper -l" returns:

bcmwl5 driver installed, hardware present

yet the problem persists.

Any help/advice/suggestions are *greatly* appreciated.


P.S. I am now on 2.6.16-1.2111

impulse() 05-17-2006 03:53 PM

I'm in the same boat as Choad here. I couldn't get it working on FC4 so I got FC5 and it worked but because of the 4k stack it crashed so I rebooted and upgraded the kernel to 16k stack and now it wont find the ndiswrapper module. I've ran the usual several times and have tried moving the ndiswrapper.ko to the directory suggested in a post above this and get :

"FATAL: Error inserting ndiswrapper (/lib/modules/2.6.16-1.2111_FC5.stk16/misc/ndiswrapper.ko): Invalid module format"

Any ideas from here? I've tried installing kernel-module-ndiswrapper but this does sweet f*** all.

Kernel: 2.6.16-1.2111_FC5.stk16
Distro: Fedora Core 5
Ndiswrapper: 1.16

Thanx in advance.

gerrit_hoekstra 06-15-2006 08:06 PM

Perhaps FC5 comes with a GCC version that is not supported by ndiswrapper?

I proudly installed the latest GCC 4.1.1 on my Gentoo machine and got the 'module not recognized' error. After lots of fumbling I got it to work with GCC 3.4.5. Easy mistake to make I guess. To select the correct compiler in Gentoo, do:

$ eselect compiler list
$ eselect compiler set [item # of compiler in list]

impulse() 06-16-2006 05:09 AM

This problem was sorted mate. When I upgraded the kernel to a 16k stack size it sent Ndiswrapper loopy. If I kept the 4k stack size kernel it worked. Luckily the 4k stack didn't crash the kernel.

Thanx for the reply though, Ste.

All times are GMT -5. The time now is 11:31 AM.